summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-02-22 09:56:41 +0100
committerRemi Collet <remi@php.net>2024-02-22 09:56:41 +0100
commit95ddabe4e55d44966f059bbf29dd75910035b4f0 (patch)
tree86f243185ebc24cdb1f1e5c0dc311cb0c6e05ec0
parent09771e38ed357a5e60cb90c07c49ac328b18ab72 (diff)
update to 1.2.0HEADmaster
run tests in parallel
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-fann.spec30
3 files changed, 25 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
index 0a183e6..6f55c0f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
fann
FANN support => enabled
-FANN version => 1.2.0RC2
+FANN version => 1.2.0
FANN library version => 2.2
diff --git a/REFLECTION b/REFLECTION
index dfff847..d34aed9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 fann version 1.2.0RC2 ] {
+Extension [ <persistent> extension #68 fann version 1.2.0 ] {
- Constants [51] {
Constant [ string FANN_VERSION ] { 2.2 }
@@ -1045,7 +1045,7 @@ Extension [ <persistent> extension #119 fann version 1.2.0RC2 ] {
- Properties [3] {
Property [ public $from_neuron = 0 ]
Property [ public $to_neuron = 0 ]
- Property [ public $weight = 0 ]
+ Property [ public $weight = 0.0 ]
}
- Methods [5] {
diff --git a/php-pecl-fann.spec b/php-pecl-fann.spec
index 4c2938b..18d4c10 100644
--- a/php-pecl-fann.spec
+++ b/php-pecl-fann.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-fann
#
-# Copyright (c) 2013-2023 Remi Collet
+# Copyright (c) 2013-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -12,6 +12,12 @@
%{?scl:%scl_package php-pecl-fann}
+# For PHP < 5.6 and EPEL-9
+%{!?__phpize: %global __phpize %{_bindir}/phpize}
+%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
+%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
+%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
+
%bcond_without tests
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -23,17 +29,17 @@
%endif
%global upstream_version 1.2.0
-%global upstream_prever RC2
+#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Summary: Wrapper for FANN Library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -54,7 +60,7 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
This package provides a PHP binding for FANN
(Fast Artificial Neural Network) Library.
-Documentation: http://php.net/fann
+Documentation: https://php.net/fann
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -78,7 +84,6 @@ cd ..
mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
mkdir ZTS
%endif
@@ -140,11 +145,16 @@ cd %{sources}
--modules | grep '^%{pecl_name}$'
%if %{with tests}
+OPTS="-q --show-diff"
+%if "%{php_version}" >= "8"
+OPTS="$OPTS %{?_smp_mflags}"
+%endif
+
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/../NTS/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php -q --show-diff
+%{__php} -n run-tests.php $OPTS
%endif
%if %{with_zts}
@@ -158,7 +168,7 @@ REPORT_EXIT_STATUS=1 \
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/../ZTS/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php -q --show-diff
+%{__ztsphp} -n run-tests.php $OPTS
%endif
%endif
@@ -198,6 +208,10 @@ fi
%changelog
+* Thu Feb 22 2024 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+- run tests in parallel
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.2.0~RC2-4
- rebuild for PHP 8.3.0RC1