summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 10:58:03 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 10:58:03 +0100
commit25bd8abaeaec228a4c9669b0f5f46d6db5f68c48 (patch)
treeb76816c689139af85377e7db8eacb6c172617723
parent5340e36ac51a9649e8575ae0ecfd34d493f5c304 (diff)
php-pecl-expect: F24
-rw-r--r--php-pecl-expect.spec28
1 files changed, 17 insertions, 11 deletions
diff --git a/php-pecl-expect.spec b/php-pecl-expect.spec
index 471e47c..ec3444e 100644
--- a/php-pecl-expect.spec
+++ b/php-pecl-expect.spec
@@ -14,11 +14,8 @@
%endif
%endif
-%{?scl: %scl_package php-pecl-expect}
+%{?scl: %scl_package php-pecl-expect}
%{!?scl: %global _root_libdir %{_libdir}}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name expect
@@ -32,7 +29,7 @@
Summary: PHP extension for expect library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.3.3
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -48,10 +45,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -92,7 +91,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Don't install tests
-sed -e '/role="test"/d' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
: Find the libexpect name
@@ -216,6 +217,7 @@ REPORT_EXIT_STATUS=1 \
%endif
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -232,6 +234,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%clean
@@ -240,7 +243,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc %{pecl_docdir}/%{pecl_name}
+#doc %%{pecl_docdir}/%%{pecl_name}
%{?_licensedir:%license NTS/LICENSE}
%{pecl_xmldir}/%{name}.xml
@@ -254,6 +257,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.3.3-2
+- adapt for F24
+
* Sun Sep 13 2015 Remi Collet <remi@fedoraproject.org> - 0.3.3-1
- Update to 0.3.3 (stable)
@@ -261,4 +267,4 @@ rm -rf %{buildroot}
- fix EL-5 build
* Fri Sep 11 2015 Remi Collet <remi@fedoraproject.org> - 0.3.2-1
-- initial package, version 0.3.2 (stable) \ No newline at end of file
+- initial package, version 0.3.2 (stable)