summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION20
-rw-r--r--php-pecl-excimer.spec22
3 files changed, 36 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index 63cb350..2c06e0c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
excimer
excimer support => enabled
-excimer version => 1.0.4
+excimer version => 1.1.1
diff --git a/REFLECTION b/REFLECTION
index 2837eae..fb420ec 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #73 excimer version 1.0.4 ] {
+Extension [ <persistent> extension #74 excimer version 1.1.1 ] {
- Dependencies {
}
@@ -110,7 +110,7 @@ Extension [ <persistent> extension #73 excimer version 1.0.4 ] {
- Properties [0] {
}
- - Methods [14] {
+ - Methods [15] {
Method [ <internal:excimer, ctor> final private method __construct ] {
- Parameters [0] {
@@ -123,6 +123,12 @@ Extension [ <persistent> extension #73 excimer version 1.0.4 ] {
}
}
+ Method [ <internal:excimer> public method getSpeedscopeData ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:excimer> public method aggregateByFunction ] {
- Parameters [0] {
@@ -140,36 +146,42 @@ Extension [ <persistent> extension #73 excimer version 1.0.4 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:excimer, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:excimer, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:excimer, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:excimer, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:excimer, prototype Countable> public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:excimer, prototype ArrayAccess> public method offsetExists ] {
@@ -177,6 +189,7 @@ Extension [ <persistent> extension #73 excimer version 1.0.4 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:excimer, prototype ArrayAccess> public method offsetGet ] {
@@ -184,6 +197,7 @@ Extension [ <persistent> extension #73 excimer version 1.0.4 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:excimer, prototype ArrayAccess> public method offsetSet ] {
@@ -192,6 +206,7 @@ Extension [ <persistent> extension #73 excimer version 1.0.4 ] {
Parameter #0 [ <required> $offset ]
Parameter #1 [ <required> $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:excimer, prototype ArrayAccess> public method offsetUnset ] {
@@ -199,6 +214,7 @@ Extension [ <persistent> extension #73 excimer version 1.0.4 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Tentative return [ void ]
}
}
}
diff --git a/php-pecl-excimer.spec b/php-pecl-excimer.spec
index 424d141..33259e8 100644
--- a/php-pecl-excimer.spec
+++ b/php-pecl-excimer.spec
@@ -1,7 +1,7 @@
# spec file for php-pecl-excimer
#
-# Copyright (c) 2021-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2021-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -21,9 +21,9 @@
Summary: Interrupting timer and low-overhead sampling profiler
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.4
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: ASL 2.0
+Version: 1.1.1
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: Apache-2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -149,6 +149,9 @@ fi
%check
+# erratic results, randomly fails in mock
+rm ?TS/tests/cpu.phpt
+
OPT="-q -P --show-diff"
%if "%{php_version}" > "7.4"
OPT="$OPT %{?_smp_mflags}"
@@ -196,6 +199,15 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Tue Mar 14 2023 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+- drop patch merged upstream
+
+* Fri Mar 3 2023 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- fix build with PHP <= 7.3 using patch from
+ https://github.com/wikimedia/mediawiki-php-excimer/pull/5
+
* Fri Aug 5 2022 Remi Collet <remi@remirepo.net> - 1.0.4-2
- cleanup