summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-02 09:22:09 +0100
committerRemi Collet <remi@remirepo.net>2021-03-02 09:22:09 +0100
commitbe2cbc1bc1736f5c0233b2f26bdd2e75d317d739 (patch)
tree2c431253f357729325a8bee46a982cb7e3f04e32
initial package
add build fix with PHP 8 from https://github.com/wikimedia/php-excimer/pull/1
-rw-r--r--.gitignore9
-rw-r--r--1.patch31
-rw-r--r--Makefile4
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION309
-rw-r--r--php-pecl-excimer.spec215
6 files changed, 572 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/1.patch b/1.patch
new file mode 100644
index 0000000..a2a6286
--- /dev/null
+++ b/1.patch
@@ -0,0 +1,31 @@
+From 435049e9b4b55955b77d32e29f7ea7df12799668 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 2 Mar 2021 08:48:09 +0100
+Subject: [PATCH] fix [-Wincompatible-pointer-types] with PHP 8
+
+---
+ excimer_log.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/excimer_log.c b/excimer_log.c
+index 4d5f74e..4c6b844 100644
+--- a/excimer_log.c
++++ b/excimer_log.c
+@@ -408,10 +408,17 @@ static void excimer_log_array_incr(HashTable *ht, zend_string *sp_key, zend_long
+ }
+ }
+
++#if PHP_VERSION_ID < 80000
+ static int excimer_log_aggr_compare(const void *a, const void *b)
+ {
+ zval *zp_a = &((Bucket*)a)->val;
+ zval *zp_b = &((Bucket*)b)->val;
++#else
++static int excimer_log_aggr_compare(Bucket *a, Bucket *b)
++{
++ zval *zp_a = &a->val;
++ zval *zp_b = &b->val;
++#endif
+
+ zval *zp_a_incl = zend_hash_str_find(Z_ARRVAL_P(zp_a), "inclusive", sizeof("inclusive")-1);
+ zval *zp_b_incl = zend_hash_str_find(Z_ARRVAL_P(zp_b), "inclusive", sizeof("inclusive")-1);
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..9a145a9
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,4 @@
+
+excimer
+
+excimer support => enabled
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..3a95cf5
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,309 @@
+Extension [ <persistent> extension #72 excimer version 1.0.0 ] {
+
+ - Dependencies {
+ }
+
+ - Constants [2] {
+ Constant [ int EXCIMER_REAL ] { 0 }
+ Constant [ int EXCIMER_CPU ] { 1 }
+ }
+
+ - Functions {
+ Function [ <internal:excimer> function excimer_set_timeout ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $callback ]
+ Parameter #1 [ <required> $interval ]
+ }
+ }
+ }
+
+ - Classes [4] {
+ Class [ <internal:excimer> class ExcimerProfiler ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [9] {
+ Method [ <internal:excimer> public method setPeriod ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $period ]
+ }
+ }
+
+ Method [ <internal:excimer> public method setEventType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $event_type ]
+ }
+ }
+
+ Method [ <internal:excimer> public method setMaxDepth ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $max_depth ]
+ }
+ }
+
+ Method [ <internal:excimer> public method setFlushCallback ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $callback ]
+ Parameter #1 [ <required> $max_samples ]
+ }
+ }
+
+ Method [ <internal:excimer> public method clearFlushCallback ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method start ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method stop ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method getLog ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method flush ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:excimer> <iterateable> class ExcimerLog implements Iterator, Traversable, Countable, ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [14] {
+ Method [ <internal:excimer, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method formatCollapsed ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method aggregateByFunction ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method getEventCount ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:excimer, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:excimer, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:excimer, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:excimer> class ExcimerLogEntry ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:excimer, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method getEventCount ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:excimer> class ExcimerTimer ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:excimer> public method setEventType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $event_type ]
+ }
+ }
+
+ Method [ <internal:excimer> public method setInterval ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:excimer> public method setPeriod ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $period ]
+ }
+ }
+
+ Method [ <internal:excimer> public method setCallback ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:excimer> public method start ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method stop ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:excimer> public method getTime ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-excimer.spec b/php-pecl-excimer.spec
new file mode 100644
index 0000000..1e24a7c
--- /dev/null
+++ b/php-pecl-excimer.spec
@@ -0,0 +1,215 @@
+# spec file for php-pecl-excimer
+#
+# Copyright (c) 2021 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-excimer
+%else
+%global _root_prefix %{_prefix}
+%endif
+
+%global pecl_name excimer
+%global ini_name 40-%{pecl_name}.ini
+# segfault in test suite
+%global with_zts 0
+
+Summary: Interrupting timer and low-overhead sampling profiler
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 1.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: ASL 2.0
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+Patch0: https://patch-diff.githubusercontent.com/raw/wikimedia/php-excimer/pull/1.patch
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+%if "%{php_version}" > "7.3"
+Obsoletes: php73-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name}
+%endif
+%endif
+
+
+%description
+Calls a user-defined callback when a one-shot or periodic timer expires.
+Also a sampling profiler backend, which aggregates backtraces collected
+by a periodic timer.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+%patch0 -p1 -b .pr1
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_EXCIMER_VERSION/{s/.* "//;s/".*$//;p}' php_excimer.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --enable-excimer \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --enable-excimer \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS \
+ install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS \
+ install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+cd NTS
+# Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+# Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+
+%if %{with_zts}
+cd ../ZTS
+# Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+# Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Mar 2 2021 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package
+- add build fix with PHP 8 from
+ https://github.com/wikimedia/php-excimer/pull/1