summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-19 08:08:32 +0200
committerRemi Collet <remi@php.net>2021-10-19 08:08:32 +0200
commitaaab85b9eda928db70d7fadc1206e1d8c3b73953 (patch)
tree65df3662536f8558037166c129296ed03bfc3e33
parent5d4802bad15d8875f3e7cc570e02e4e3aa2e1ef4 (diff)
update to 1.0.2
drop patches merged upstream
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--excimer-info.patch21
-rw-r--r--excimer-php81.patch74
-rw-r--r--php-pecl-excimer.spec12
5 files changed, 7 insertions, 104 deletions
diff --git a/PHPINFO b/PHPINFO
index dc5adb1..6bc0a0c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
excimer
excimer support => enabled
-excimer version => 1.0.1
+excimer version => 1.0.2
diff --git a/REFLECTION b/REFLECTION
index dd29abf..08991fa 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #73 excimer version 1.0.1 ] {
+Extension [ <persistent> extension #73 excimer version 1.0.2 ] {
- Dependencies {
}
diff --git a/excimer-info.patch b/excimer-info.patch
deleted file mode 100644
index 3cba206..0000000
--- a/excimer-info.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From a70fe7ae6ca3c1c621e902fdd43a2f51e1537c77 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 6 Oct 2021 06:17:21 +0200
-Subject: [PATCH] add ext version in phpinfo
-
----
- excimer.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/excimer.c b/excimer.c
-index 347bdd8..110f0a2 100644
---- a/excimer.c
-+++ b/excimer.c
-@@ -560,6 +560,7 @@ static PHP_MINFO_FUNCTION(excimer)
- {
- php_info_print_table_start();
- php_info_print_table_header(2, "excimer support", "enabled");
-+ php_info_print_table_row(2, "excimer version", PHP_EXCIMER_VERSION);
- php_info_print_table_end();
- }
- /* }}} */
diff --git a/excimer-php81.patch b/excimer-php81.patch
deleted file mode 100644
index bab26d1..0000000
--- a/excimer-php81.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From e709af4c60f5f70dd277ec34ee5c3af2555e6654 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 6 Oct 2021 06:01:29 +0200
-Subject: [PATCH] fix Iterator prototypes for PHP 8.1
-
----
- excimer.c | 25 +++++++++++++++----------
- 1 file changed, 15 insertions(+), 10 deletions(-)
-
-diff --git a/excimer.c b/excimer.c
-index 347bdd8..2024a07 100644
---- a/excimer.c
-+++ b/excimer.c
-@@ -238,6 +238,11 @@ static zend_object_handlers ExcimerLogEntry_handlers;
- static zend_object_handlers ExcimerTimer_handlers;
-
- /** {{{ arginfo */
-+#ifndef ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX
-+#define ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(name, return_reference, required_num_args, type, allow_null) \
-+ ZEND_BEGIN_ARG_INFO_EX(name, 0, return_reference, required_num_args)
-+#endif
-+
- ZEND_BEGIN_ARG_INFO(arginfo_ExcimerProfiler_setPeriod, 0)
- ZEND_ARG_INFO(0, period)
- ZEND_END_ARG_INFO()
-@@ -282,38 +287,38 @@ ZEND_END_ARG_INFO()
- ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_getEventCount, 0)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_current, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_current, 0, 0, IS_MIXED, 0)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_key, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_key, 0, 0, IS_MIXED, 0)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_next, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_next, 0, 0, IS_VOID, 0)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_rewind, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_rewind, 0, 0, IS_VOID, 0)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_valid, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_valid, 0, 0, _IS_BOOL, 0)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_count, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_count, 0, 0, IS_LONG, 0)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_offsetExists, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_offsetExists, 0, 1, _IS_BOOL, 0)
- ZEND_ARG_INFO(0, offset)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_offsetGet, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_offsetGet, 0, 1, IS_MIXED, 0)
- ZEND_ARG_INFO(0, offset)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_offsetSet, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_offsetSet, 0, 2, IS_VOID, 0)
- ZEND_ARG_INFO(0, offset)
- ZEND_ARG_INFO(0, value)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_ExcimerLog_offsetUnset, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_ExcimerLog_offsetUnset, 0, 1, IS_VOID, 0)
- ZEND_ARG_INFO(0, offset)
- ZEND_END_ARG_INFO()
-
diff --git a/php-pecl-excimer.spec b/php-pecl-excimer.spec
index ded895c..60891ef 100644
--- a/php-pecl-excimer.spec
+++ b/php-pecl-excimer.spec
@@ -20,15 +20,12 @@
Summary: Interrupting timer and low-overhead sampling profiler
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.1
+Version: 1.0.2
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-php81.patch
-Patch1: %{pecl_name}-info.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
@@ -79,9 +76,6 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p1
-%patch1 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_EXCIMER_VERSION/{s/.* "//;s/".*$//;p}' php_excimer.h)
if test "x${extver}" != "x%{version}"; then
@@ -208,6 +202,10 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Tue Oct 19 2021 Remi Collet <remi@remirepo.net> - 1.0.2-1
+- update to 1.0.2
+- drop patches merged upstream
+
* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 1.0.1-1
- update to 1.0.1
- drop patch merged upstream