summaryrefslogtreecommitdiffstats
path: root/php-pecl-event.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-09 19:33:42 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-09 19:33:42 +0200
commitd6f943d1ba1cbe3890d7de5c542d355313b86260 (patch)
tree6a082cfdd1ca22a5c2182815f4b5f007f305e21e /php-pecl-event.spec
parent28cb035a4b3afaf1a8ebe0537a22db4c5e32944e (diff)
php-pecl: add numerical prefix to extension configuration file (4)
Diffstat (limited to 'php-pecl-event.spec')
-rw-r--r--php-pecl-event.spec22
1 files changed, 16 insertions, 6 deletions
diff --git a/php-pecl-event.spec b/php-pecl-event.spec
index 273d1c0..28f5765 100644
--- a/php-pecl-event.spec
+++ b/php-pecl-event.spec
@@ -15,11 +15,18 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%global pecl_name event
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+# After sockets.so
+%global ini_name z-%{pecl_name}.ini
+%else
+# After 20-sockets.so
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Provides interface to libevent library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.9.1
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/event
@@ -105,7 +112,7 @@ cp -pr NTS ZTS
%endif
# Drop in the bit of configuration
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension = %{pecl_name}.so
EOF
@@ -144,12 +151,12 @@ rm -rf %{buildroot}
# use z-event.ini to ensure event.so load "after" sockets.so
: Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/z-%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
: Install the ZTS stuff
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/z-%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
: Install the package XML file
@@ -224,16 +231,19 @@ rm -rf %{buildroot}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/z-%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/z-%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 1.9.1-3
+- add numerical prefix to extension configuration file
+
* Sun Mar 23 2014 Remi Collet <remi@fedoraproject.org> - 1.9.1-2
- allow SCL build, with libevent from SCL when needed