summaryrefslogtreecommitdiffstats
path: root/php-pecl-event-dev.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-07-26 16:57:07 +0200
committerRemi Collet <fedora@famillecollet.com>2013-07-26 16:57:07 +0200
commit96284891a3be14917d52bd5da2f5d5dc57b94ba3 (patch)
treebb9d070f12abb3268ce7e882b003186311d49b87 /php-pecl-event-dev.spec
parent63356e588210ba6d4a618810fb22e81090dea3b7 (diff)
php-pecl-event: save our spec
Diffstat (limited to 'php-pecl-event-dev.spec')
-rw-r--r--php-pecl-event-dev.spec197
1 files changed, 197 insertions, 0 deletions
diff --git a/php-pecl-event-dev.spec b/php-pecl-event-dev.spec
new file mode 100644
index 0000000..0f4a50a
--- /dev/null
+++ b/php-pecl-event-dev.spec
@@ -0,0 +1,197 @@
+# spec file for php-pecl-event
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global pecl_name event
+
+Summary: Provides interface to libevent library
+Name: php-pecl-event
+Version: 1.7.1
+Release: 1%{?dist}.1
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/event
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: php-devel > 5.4
+BuildRequires: php-pear
+BuildRequires: libevent-devel > 2
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires: php-sockets%{?_isa}
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+Obsoletes: php54-pecl-%{pecl_name}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55-pecl-%{pecl_name}
+%endif
+
+
+# Filter private shared
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+
+
+%description
+This is an extension to efficiently schedule I/O, time and signal based
+events using the best I/O notification mechanism available for specific platform.
+This is a port of libevent to the PHP infrastructure.
+
+Version 1.0.0 introduces:
+* new OO API breaking backwards compatibility
+* support of libevent 2+ including HTTP, DNS, OpenSSL and the event listener.
+
+
+%prep
+%setup -q -c
+
+cd %{pecl_name}-%{version}
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_EVENT_VERSION/{s/.* "//;s/".*$//;p}' php_event.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+# duplicate for ZTS build
+cp -pr %{pecl_name}-%{version} %{pecl_name}-zts
+
+# Drop in the bit of configuration
+cat > %{pecl_name}.ini << 'EOF'
+; Enable %{pecl_name} extension module
+extension = %{pecl_name}.so
+EOF
+
+
+%build
+# --with-event-pthreads cause test failure
+
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure \
+ --with-event-core \
+ --with-event-extra \
+ --with-event-openssl \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+cd ../%{pecl_name}-zts
+%{_bindir}/zts-phpize
+%configure \
+ --with-event-core \
+ --with-event-extra \
+ --with-event-openssl \
+ --with-event-pthreads \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+
+# use z-event.ini to ensure event.so load "after" sockets.so
+: Install the NTS stuff
+make -C %{pecl_name}-%{version} install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/z-%{pecl_name}.ini
+
+: Install the ZTS stuff
+make -C %{pecl_name}-zts install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/z-%{pecl_name}.ini
+
+: Install the package XML file
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+
+%check
+cd %{pecl_name}-%{version}
+if [ -f %{php_extdir}/sockets.so ]; then
+ OPTS="-d extension=sockets.so"
+fi
+
+SKIP_ONLINE_TESTS=1 \
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n $OPTS -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php
+
+cd ../%{pecl_name}-zts
+if [ -f %{php_ztsextdir}/sockets.so ]; then
+ OPTS="-d extension=sockets.so"
+fi
+
+SKIP_ONLINE_TESTS=1 \
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n $OPTS -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-, root, root, 0755)
+%doc %{pecl_name}-%{version}/{CREDITS,LICENSE,README.md}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/z-%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+
+%config(noreplace) %{php_ztsinidir}/z-%{pecl_name}.ini
+%{php_ztsextdir}/%{pecl_name}.so
+
+
+%changelog
+* Wed Jul 24 2013 Remi Collet <remi@fedoraproject.org> - 1.7.1-1
+- Update to 1.7.1
+
+* Thu Jul 18 2013 Remi Collet <remi@fedoraproject.org> - 1.7.0-1
+- Update to 1.7.0
+
+* Thu Jul 18 2013 Remi Collet <remi@fedoraproject.org> - 1.6.2-2
+- missing requires php-sockets
+- enable thread safety for ZTS extension
+
+* Thu Jul 18 2013 Remi Collet <remi@fedoraproject.org> - 1.6.2-1
+- Update to 1.6.2
+
+* Sat Apr 20 2013 Remi Collet <remi@fedoraproject.org> - 1.6.1-1
+- initial package, version 1.6.1
+- upstream bugs:
+ https://bugs.php.net/64678 missing License
+ https://bugs.php.net/64679 buffer overflow
+ https://bugs.php.net/64680 skip online test