summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-14 07:53:19 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-14 07:53:19 +0100
commit77062eaf08c9131f5d57da5b9eca0aea352af790 (patch)
tree20eae97772c332cc116e879c1d1655c030ae4c04
parent60f478cb1c0c4ede89987d876fba8b37d0b0914c (diff)
php-pecl-event: 1.11.1 (stable)
-rw-r--r--REFLECTION2
-rw-r--r--event-openssl.patch86
-rw-r--r--php-pecl-event.spec10
3 files changed, 6 insertions, 92 deletions
diff --git a/REFLECTION b/REFLECTION
index e5ff88e..668d062 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #180 event version 1.11.0 ] {
+Extension [ <persistent> extension #180 event version 1.11.1 ] {
- Dependencies {
Dependency [ sockets (Required) ]
diff --git a/event-openssl.patch b/event-openssl.patch
deleted file mode 100644
index a778155..0000000
--- a/event-openssl.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From e76022e2f4abe48774b667ef4fc1ed83fa6afa51 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 13 Nov 2014 18:59:10 +0100
-Subject: [PATCH] fix build with old openssl (RHEL-5)
-
----
- classes/ssl_context.c | 32 ++++++++++++++++++++++++++++++++
- 1 file changed, 32 insertions(+)
-
-diff --git a/classes/ssl_context.c b/classes/ssl_context.c
-index 6f71a08..345e68f 100644
---- a/classes/ssl_context.c
-+++ b/classes/ssl_context.c
-@@ -240,6 +240,7 @@ static inline void set_ssl_ctx_options(SSL_CTX *ctx, HashTable *ht TSRMLS_DC)
- SSL_CTX_clear_options(ctx, SSL_OP_NO_TLSv1);
- }
- break;
-+#ifdef SSL_OP_NO_TLSv1_1
- case PHP_EVENT_OPT_NO_TLSv1_1:
- if (zval_is_true(*ppzval)) {
- SSL_CTX_set_options(ctx, SSL_OP_NO_TLSv1_1);
-@@ -247,6 +248,8 @@ static inline void set_ssl_ctx_options(SSL_CTX *ctx, HashTable *ht TSRMLS_DC)
- SSL_CTX_clear_options(ctx, SSL_OP_NO_TLSv1_1);
- }
- break;
-+#endif
-+#ifdef SSL_OP_NO_TLSv1_2
- case PHP_EVENT_OPT_NO_TLSv1_2:
- if (zval_is_true(*ppzval)) {
- SSL_CTX_set_options(ctx, SSL_OP_NO_TLSv1_2);
-@@ -254,6 +257,7 @@ static inline void set_ssl_ctx_options(SSL_CTX *ctx, HashTable *ht TSRMLS_DC)
- SSL_CTX_clear_options(ctx, SSL_OP_NO_TLSv1_2);
- }
- break;
-+#endif
- case PHP_EVENT_OPT_CIPHER_SERVER_PREFERENCE:
- if (zval_is_true(*ppzval)) {
- SSL_CTX_set_options(ctx, SSL_OP_CIPHER_SERVER_PREFERENCE);
-@@ -342,16 +346,44 @@ static zend_always_inline SSL_METHOD *get_ssl_method(long in_method TSRMLS_DC)
- method = (SSL_METHOD *) TLSv1_server_method();
- break;
- case PHP_EVENT_TLSv11_CLIENT_METHOD:
-+#ifdef SSL_OP_NO_TLSv1_1
- method = (SSL_METHOD *) TLSv1_1_client_method();
-+#else
-+ php_error_docref(NULL TSRMLS_CC, E_WARNING,
-+ "TLSv1_1 support is not compiled into the "
-+ "OpenSSL library PHP is linked against");
-+ return NULL;
-+#endif
- break;
- case PHP_EVENT_TLSv11_SERVER_METHOD:
-+#ifdef SSL_OP_NO_TLSv1_1
- method = (SSL_METHOD *) TLSv1_1_server_method();
-+#else
-+ php_error_docref(NULL TSRMLS_CC, E_WARNING,
-+ "TLSv1_1 support is not compiled into the "
-+ "OpenSSL library PHP is linked against");
-+ return NULL;
-+#endif
- break;
- case PHP_EVENT_TLSv12_CLIENT_METHOD:
-+#ifdef SSL_OP_NO_TLSv1_2
- method = (SSL_METHOD *) TLSv1_2_client_method();
-+#else
-+ php_error_docref(NULL TSRMLS_CC, E_WARNING,
-+ "TLSv1_2 support is not compiled into the "
-+ "OpenSSL library PHP is linked against");
-+ return NULL;
-+#endif
- break;
- case PHP_EVENT_TLSv12_SERVER_METHOD:
-+#ifdef SSL_OP_NO_TLSv1_2
- method = (SSL_METHOD *) TLSv1_2_server_method();
-+#else
-+ php_error_docref(NULL TSRMLS_CC, E_WARNING,
-+ "TLSv1_2 support is not compiled into the "
-+ "OpenSSL library PHP is linked against");
-+ return NULL;
-+#endif
- break;
- default:
- return NULL;
---
-2.1.1
-
diff --git a/php-pecl-event.spec b/php-pecl-event.spec
index ed7c07c..e581f41 100644
--- a/php-pecl-event.spec
+++ b/php-pecl-event.spec
@@ -25,16 +25,13 @@
Summary: Provides interface to libevent library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.11.0
+Version: 1.11.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/event
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://bitbucket.org/osmanov/pecl-event/pull-request/10
-Patch0: %{pecl_name}-openssl.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
@@ -110,7 +107,6 @@ sed -e 's/role="test"/role="src"/' -i package.xml
mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p1 -b .openssl
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_EVENT_VERSION/{s/.* "//;s/".*$//;p}' php_event.h)
@@ -251,6 +247,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Nov 14 2014 Remi Collet <remi@fedoraproject.org> - 1.11.1-1
+- Update to 1.11.1 (stable)
+- no change, only our patch merged upstream
+
* Thu Nov 13 2014 Remi Collet <remi@fedoraproject.org> - 1.11.0-1
- Update to 1.11.0 (stable)
- don't provide test suite