summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-28 09:37:45 +0100
committerRemi Collet <remi@php.net>2023-12-28 09:37:45 +0100
commit682b9bf644231f46327a4adfb06f864aa8d0c3de (patch)
tree485cf970a088a7ab9ea2b3632350639795de8747
parent757719a6ca5befc5f60765d1d46b762d4be73599 (diff)
update to 3.1.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION6
-rw-r--r--event-build.patch10
-rw-r--r--php-pecl-event.spec5
4 files changed, 13 insertions, 10 deletions
diff --git a/PHPINFO b/PHPINFO
index 22ec1ab..39e695c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,5 +7,5 @@ Debug support => disabled
Extra functionality support including HTTP, DNS, and RPC => enabled
OpenSSL support => enabled
Thread safety support => disabled
-Extension version => 3.1.0RC1
+Extension version => 3.1.0
libevent2 headers version => 2.1.12-stable
diff --git a/REFLECTION b/REFLECTION
index 4e9c65c..b8e8a85 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #126 event version 3.1.0RC1 ] {
+Extension [ <persistent> extension #63 event version 3.1.0 ] {
- Dependencies {
Dependency [ sockets (Required) ]
@@ -1677,8 +1677,8 @@ Extension [ <persistent> extension #126 event version 3.1.0RC1 ] {
Constant [ public int OPT_CIPHER_SERVER_PREFERENCE ] { 15 }
Constant [ public int OPT_REQUIRE_CLIENT_CERT ] { 16 }
Constant [ public int OPT_VERIFY_CLIENT_ONCE ] { 17 }
- Constant [ public string OPENSSL_VERSION_TEXT ] { OpenSSL 3.0.9 30 May 2023 }
- Constant [ public int OPENSSL_VERSION_NUMBER ] { 805306512 }
+ Constant [ public string OPENSSL_VERSION_TEXT ] { OpenSSL 3.1.1 30 May 2023 }
+ Constant [ public int OPENSSL_VERSION_NUMBER ] { 806354960 }
Constant [ public int SSL3_VERSION ] { 768 }
Constant [ public int TLS1_VERSION ] { 769 }
Constant [ public int TLS1_1_VERSION ] { 770 }
diff --git a/event-build.patch b/event-build.patch
index 453a4a6..90e7a63 100644
--- a/event-build.patch
+++ b/event-build.patch
@@ -36,7 +36,7 @@ index 3a7bb37..3286efa 100644
if (flags & ~(EVDNS_BASE_DISABLE_WHEN_INACTIVE
- | EVDNS_BASE_INITIALIZE_NAMESERVERS
- | EVDNS_BASE_NAMESERVERS_NO_DEFAULT)) {
-+#if LIBEVENT_VERSION_NUMBER >= 0x02011000
++#if LIBEVENT_VERSION_NUMBER >= 0x02010a00
+ | EVDNS_BASE_NAMESERVERS_NO_DEFAULT
+#endif
+ | EVDNS_BASE_INITIALIZE_NAMESERVERS)) {
@@ -52,7 +52,7 @@ index a903020..6676cad 100644
PHP_EVENT_REG_CLASS_CONST_LONG(php_event_dns_base_ce, DISABLE_WHEN_INACTIVE, EVDNS_BASE_DISABLE_WHEN_INACTIVE);
PHP_EVENT_REG_CLASS_CONST_LONG(php_event_dns_base_ce, INITIALIZE_NAMESERVERS, EVDNS_BASE_INITIALIZE_NAMESERVERS);
+#endif
-+#if LIBEVENT_VERSION_NUMBER >= 0x02011000
++#if LIBEVENT_VERSION_NUMBER >= 0x02010a00
PHP_EVENT_REG_CLASS_CONST_LONG(php_event_dns_base_ce, NAMESERVERS_NO_DEFAULT, EVDNS_BASE_NAMESERVERS_NO_DEFAULT);
#endif
@@ -81,7 +81,7 @@ index 075b24b..1c08c1e 100644
if (flags & ~(EVDNS_BASE_DISABLE_WHEN_INACTIVE
- | EVDNS_BASE_INITIALIZE_NAMESERVERS
- | EVDNS_BASE_NAMESERVERS_NO_DEFAULT)) {
-+#if LIBEVENT_VERSION_NUMBER >= 0x02011000
++#if LIBEVENT_VERSION_NUMBER >= 0x02010a00
+ | EVDNS_BASE_NAMESERVERS_NO_DEFAULT
+#endif
+ | EVDNS_BASE_INITIALIZE_NAMESERVERS)) {
@@ -97,7 +97,7 @@ index e593b80..17b66f3 100644
PHP_EVENT_REG_CLASS_CONST_LONG(php_event_dns_base_ce, DISABLE_WHEN_INACTIVE, EVDNS_BASE_DISABLE_WHEN_INACTIVE);
PHP_EVENT_REG_CLASS_CONST_LONG(php_event_dns_base_ce, INITIALIZE_NAMESERVERS, EVDNS_BASE_INITIALIZE_NAMESERVERS);
+#endif
-+#if LIBEVENT_VERSION_NUMBER >= 0x02011000
++#if LIBEVENT_VERSION_NUMBER >= 0x02010a00
PHP_EVENT_REG_CLASS_CONST_LONG(php_event_dns_base_ce, NAMESERVERS_NO_DEFAULT, EVDNS_BASE_NAMESERVERS_NO_DEFAULT);
#endif
@@ -110,7 +110,7 @@ index c0e8e7d..07cf7fc 100644
$eventUtilClass = EVENT_NS . '\\EventUtil';
-if ($eventUtilClass::LIBEVENT_VERSION_NUMBER < 0x02010000) {
-+if ($eventUtilClass::LIBEVENT_VERSION_NUMBER < 0x02011000) {
++if ($eventUtilClass::LIBEVENT_VERSION_NUMBER < 0x02010a00) {
die('skip this test is for libevent version >= 2.1');
}
?>
diff --git a/php-pecl-event.spec b/php-pecl-event.spec
index 5ff4ff0..aaa7165 100644
--- a/php-pecl-event.spec
+++ b/php-pecl-event.spec
@@ -34,7 +34,7 @@
%global ini_name 40-%{pecl_name}.ini
%endif
%global upstream_version 3.1.0
-%global upstream_prever RC1
+#global upstream_prever RC1
#global upstream_postver r1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -255,6 +255,9 @@ fi
%changelog
+* Thu Dec 28 2023 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+
* Mon Oct 16 2023 Remi Collet <remi@remirepo.net> - 3.1.0~RC1-1
- update to 3.1.0RC1
- add patch for old libevent in EL-7 and EL-8