summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-23 18:29:42 +0100
committerRemi Collet <remi@remirepo.net>2020-02-23 18:29:42 +0100
commit44a97b9166e9b5aba2d9e3c4641e03d16c9f00a8 (patch)
tree7aa472aea3fe9135e69c4b535474610f7fac6ba1
parent7d34a13c67a6356f9cdcbf0c45d514f38b41666d (diff)
v2.5.4
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION238
-rw-r--r--php-pecl-event.spec11
3 files changed, 127 insertions, 124 deletions
diff --git a/PHPINFO b/PHPINFO
index 4090c35..03713e2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,5 +7,5 @@ Debug support => disabled
Extra functionality support including HTTP, DNS, and RPC => enabled
OpenSSL support => enabled
Thread safety support => disabled
-Extension version => 2.5.3
+Extension version => 2.5.4
libevent2 headers version => 2.1.8-stable
diff --git a/REFLECTION b/REFLECTION
index c693f6f..0feb019 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #203 event version 2.5.3 ] {
+Extension [ <persistent> extension #111 event version 2.5.4 ] {
- Dependencies {
Dependency [ sockets (Required) ]
@@ -12,12 +12,12 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class Event ] {
- Constants [6] {
- Constant [ public integer ET ] { 32 }
- Constant [ public integer PERSIST ] { 16 }
- Constant [ public integer READ ] { 2 }
- Constant [ public integer WRITE ] { 4 }
- Constant [ public integer SIGNAL ] { 8 }
- Constant [ public integer TIMEOUT ] { 1 }
+ Constant [ public int ET ] { 32 }
+ Constant [ public int PERSIST ] { 16 }
+ Constant [ public int READ ] { 2 }
+ Constant [ public int WRITE ] { 4 }
+ Constant [ public int SIGNAL ] { 8 }
+ Constant [ public int TIMEOUT ] { 1 }
}
- Static properties [0] {
@@ -157,14 +157,14 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class EventBase ] {
- Constants [8] {
- Constant [ public integer LOOP_ONCE ] { 1 }
- Constant [ public integer LOOP_NONBLOCK ] { 2 }
- Constant [ public integer NOLOCK ] { 1 }
- Constant [ public integer STARTUP_IOCP ] { 4 }
- Constant [ public integer NO_CACHE_TIME ] { 8 }
- Constant [ public integer EPOLL_USE_CHANGELIST ] { 16 }
- Constant [ public integer IGNORE_ENV ] { 2 }
- Constant [ public integer PRECISE_TIMER ] { 32 }
+ Constant [ public int LOOP_ONCE ] { 1 }
+ Constant [ public int LOOP_NONBLOCK ] { 2 }
+ Constant [ public int NOLOCK ] { 1 }
+ Constant [ public int STARTUP_IOCP ] { 4 }
+ Constant [ public int NO_CACHE_TIME ] { 8 }
+ Constant [ public int EPOLL_USE_CHANGELIST ] { 16 }
+ Constant [ public int IGNORE_ENV ] { 2 }
+ Constant [ public int PRECISE_TIMER ] { 32 }
}
- Static properties [0] {
@@ -291,9 +291,9 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class EventConfig ] {
- Constants [3] {
- Constant [ public integer FEATURE_ET ] { 1 }
- Constant [ public integer FEATURE_O1 ] { 2 }
- Constant [ public integer FEATURE_FDS ] { 4 }
+ Constant [ public int FEATURE_ET ] { 1 }
+ Constant [ public int FEATURE_O1 ] { 2 }
+ Constant [ public int FEATURE_FDS ] { 4 }
}
- Static properties [0] {
@@ -359,19 +359,19 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class EventBufferEvent ] {
- Constants [13] {
- Constant [ public integer READING ] { 1 }
- Constant [ public integer WRITING ] { 2 }
- Constant [ public integer EOF ] { 16 }
- Constant [ public integer ERROR ] { 32 }
- Constant [ public integer TIMEOUT ] { 64 }
- Constant [ public integer CONNECTED ] { 128 }
- Constant [ public integer OPT_CLOSE_ON_FREE ] { 1 }
- Constant [ public integer OPT_THREADSAFE ] { 2 }
- Constant [ public integer OPT_DEFER_CALLBACKS ] { 4 }
- Constant [ public integer OPT_UNLOCK_CALLBACKS ] { 8 }
- Constant [ public integer SSL_OPEN ] { 0 }
- Constant [ public integer SSL_CONNECTING ] { 1 }
- Constant [ public integer SSL_ACCEPTING ] { 2 }
+ Constant [ public int READING ] { 1 }
+ Constant [ public int WRITING ] { 2 }
+ Constant [ public int EOF ] { 16 }
+ Constant [ public int ERROR ] { 32 }
+ Constant [ public int TIMEOUT ] { 64 }
+ Constant [ public int CONNECTED ] { 128 }
+ Constant [ public int OPT_CLOSE_ON_FREE ] { 1 }
+ Constant [ public int OPT_THREADSAFE ] { 2 }
+ Constant [ public int OPT_DEFER_CALLBACKS ] { 4 }
+ Constant [ public int OPT_UNLOCK_CALLBACKS ] { 8 }
+ Constant [ public int SSL_OPEN ] { 0 }
+ Constant [ public int SSL_CONNECTING ] { 1 }
+ Constant [ public int SSL_ACCEPTING ] { 2 }
}
- Static properties [0] {
@@ -610,13 +610,13 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> class EventBuffer ] {
- Constants [7] {
- Constant [ public integer EOL_ANY ] { 0 }
- Constant [ public integer EOL_CRLF ] { 1 }
- Constant [ public integer EOL_CRLF_STRICT ] { 2 }
- Constant [ public integer EOL_LF ] { 3 }
- Constant [ public integer EOL_NUL ] { 4 }
- Constant [ public integer PTR_SET ] { 0 }
- Constant [ public integer PTR_ADD ] { 1 }
+ Constant [ public int EOL_ANY ] { 0 }
+ Constant [ public int EOL_CRLF ] { 1 }
+ Constant [ public int EOL_CRLF_STRICT ] { 2 }
+ Constant [ public int EOL_LF ] { 3 }
+ Constant [ public int EOL_NUL ] { 4 }
+ Constant [ public int PTR_SET ] { 0 }
+ Constant [ public int PTR_ADD ] { 1 }
}
- Static properties [0] {
@@ -794,11 +794,11 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class EventDnsBase ] {
- Constants [5] {
- Constant [ public integer OPTION_SEARCH ] { 1 }
- Constant [ public integer OPTION_NAMESERVERS ] { 2 }
- Constant [ public integer OPTION_MISC ] { 4 }
- Constant [ public integer OPTION_HOSTSFILE ] { 8 }
- Constant [ public integer OPTIONS_ALL ] { 15 }
+ Constant [ public int OPTION_SEARCH ] { 1 }
+ Constant [ public int OPTION_NAMESERVERS ] { 2 }
+ Constant [ public int OPTION_MISC ] { 4 }
+ Constant [ public int OPTION_HOSTSFILE ] { 8 }
+ Constant [ public int OPTIONS_ALL ] { 15 }
}
- Static properties [0] {
@@ -880,13 +880,13 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class EventListener ] {
- Constants [7] {
- Constant [ public integer OPT_LEAVE_SOCKETS_BLOCKING ] { 1 }
- Constant [ public integer OPT_CLOSE_ON_FREE ] { 2 }
- Constant [ public integer OPT_CLOSE_ON_EXEC ] { 4 }
- Constant [ public integer OPT_REUSEABLE ] { 8 }
- Constant [ public integer OPT_DISABLED ] { 32 }
- Constant [ public integer OPT_THREADSAFE ] { 16 }
- Constant [ public integer OPT_DEFERRED_ACCEPT ] { 64 }
+ Constant [ public int OPT_LEAVE_SOCKETS_BLOCKING ] { 1 }
+ Constant [ public int OPT_CLOSE_ON_FREE ] { 2 }
+ Constant [ public int OPT_CLOSE_ON_EXEC ] { 4 }
+ Constant [ public int OPT_REUSEABLE ] { 8 }
+ Constant [ public int OPT_DISABLED ] { 32 }
+ Constant [ public int OPT_THREADSAFE ] { 16 }
+ Constant [ public int OPT_DEFERRED_ACCEPT ] { 64 }
}
- Static properties [0] {
@@ -1200,17 +1200,17 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class EventHttpRequest ] {
- Constants [11] {
- Constant [ public integer CMD_GET ] { 1 }
- Constant [ public integer CMD_POST ] { 2 }
- Constant [ public integer CMD_HEAD ] { 4 }
- Constant [ public integer CMD_PUT ] { 8 }
- Constant [ public integer CMD_DELETE ] { 16 }
- Constant [ public integer CMD_OPTIONS ] { 32 }
- Constant [ public integer CMD_TRACE ] { 64 }
- Constant [ public integer CMD_CONNECT ] { 128 }
- Constant [ public integer CMD_PATCH ] { 256 }
- Constant [ public integer INPUT_HEADER ] { 1 }
- Constant [ public integer OUTPUT_HEADER ] { 2 }
+ Constant [ public int CMD_GET ] { 1 }
+ Constant [ public int CMD_POST ] { 2 }
+ Constant [ public int CMD_HEAD ] { 4 }
+ Constant [ public int CMD_PUT ] { 8 }
+ Constant [ public int CMD_DELETE ] { 16 }
+ Constant [ public int CMD_OPTIONS ] { 32 }
+ Constant [ public int CMD_TRACE ] { 64 }
+ Constant [ public int CMD_CONNECT ] { 128 }
+ Constant [ public int CMD_PATCH ] { 256 }
+ Constant [ public int INPUT_HEADER ] { 1 }
+ Constant [ public int OUTPUT_HEADER ] { 2 }
}
- Static properties [0] {
@@ -1396,33 +1396,33 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class EventUtil ] {
- Constants [27] {
- Constant [ public integer AF_INET ] { 2 }
- Constant [ public integer AF_INET6 ] { 10 }
- Constant [ public integer AF_UNIX ] { 1 }
- Constant [ public integer AF_UNSPEC ] { 0 }
- Constant [ public integer SO_DEBUG ] { 1 }
- Constant [ public integer SO_REUSEADDR ] { 2 }
- Constant [ public integer SO_KEEPALIVE ] { 9 }
- Constant [ public integer SO_DONTROUTE ] { 5 }
- Constant [ public integer SO_LINGER ] { 13 }
- Constant [ public integer SO_BROADCAST ] { 6 }
- Constant [ public integer SO_OOBINLINE ] { 10 }
- Constant [ public integer SO_SNDBUF ] { 7 }
- Constant [ public integer SO_RCVBUF ] { 8 }
- Constant [ public integer SO_SNDLOWAT ] { 19 }
- Constant [ public integer SO_RCVLOWAT ] { 18 }
- Constant [ public integer SO_SNDTIMEO ] { 21 }
- Constant [ public integer SO_RCVTIMEO ] { 20 }
- Constant [ public integer SO_TYPE ] { 3 }
- Constant [ public integer SO_ERROR ] { 4 }
- Constant [ public integer TCP_NODELAY ] { 1 }
- Constant [ public integer SOL_SOCKET ] { 1 }
- Constant [ public integer SOL_TCP ] { 6 }
- Constant [ public integer SOL_UDP ] { 17 }
- Constant [ public integer SOCK_RAW ] { 3 }
- Constant [ public integer IPPROTO_IP ] { 0 }
- Constant [ public integer IPPROTO_IPV6 ] { 41 }
- Constant [ public integer LIBEVENT_VERSION_NUMBER ] { 33622016 }
+ Constant [ public int AF_INET ] { 2 }
+ Constant [ public int AF_INET6 ] { 10 }
+ Constant [ public int AF_UNIX ] { 1 }
+ Constant [ public int AF_UNSPEC ] { 0 }
+ Constant [ public int SO_DEBUG ] { 1 }
+ Constant [ public int SO_REUSEADDR ] { 2 }
+ Constant [ public int SO_KEEPALIVE ] { 9 }
+ Constant [ public int SO_DONTROUTE ] { 5 }
+ Constant [ public int SO_LINGER ] { 13 }
+ Constant [ public int SO_BROADCAST ] { 6 }
+ Constant [ public int SO_OOBINLINE ] { 10 }
+ Constant [ public int SO_SNDBUF ] { 7 }
+ Constant [ public int SO_RCVBUF ] { 8 }
+ Constant [ public int SO_SNDLOWAT ] { 19 }
+ Constant [ public int SO_RCVLOWAT ] { 18 }
+ Constant [ public int SO_SNDTIMEO ] { 21 }
+ Constant [ public int SO_RCVTIMEO ] { 20 }
+ Constant [ public int SO_TYPE ] { 3 }
+ Constant [ public int SO_ERROR ] { 4 }
+ Constant [ public int TCP_NODELAY ] { 1 }
+ Constant [ public int SOL_SOCKET ] { 1 }
+ Constant [ public int SOL_TCP ] { 6 }
+ Constant [ public int SOL_UDP ] { 17 }
+ Constant [ public int SOCK_RAW ] { 3 }
+ Constant [ public int IPPROTO_IP ] { 0 }
+ Constant [ public int IPPROTO_IPV6 ] { 41 }
+ Constant [ public int LIBEVENT_VERSION_NUMBER ] { 33622016 }
}
- Static properties [0] {
@@ -1498,37 +1498,37 @@ Extension [ <persistent> extension #203 event version 2.5.3 ] {
Class [ <internal:event> final class EventSslContext ] {
- Constants [31] {
- Constant [ public integer TLS_CLIENT_METHOD ] { 4 }
- Constant [ public integer TLS_SERVER_METHOD ] { 8 }
- Constant [ public integer TLSv11_CLIENT_METHOD ] { 9 }
- Constant [ public integer TLSv11_SERVER_METHOD ] { 10 }
- Constant [ public integer TLSv12_CLIENT_METHOD ] { 11 }
- Constant [ public integer TLSv12_SERVER_METHOD ] { 12 }
- Constant [ public integer OPT_LOCAL_CERT ] { 1 }
- Constant [ public integer OPT_LOCAL_PK ] { 2 }
- Constant [ public integer OPT_PASSPHRASE ] { 3 }
- Constant [ public integer OPT_CA_FILE ] { 4 }
- Constant [ public integer OPT_CA_PATH ] { 5 }
- Constant [ public integer OPT_ALLOW_SELF_SIGNED ] { 6 }
- Constant [ public integer OPT_VERIFY_PEER ] { 7 }
- Constant [ public integer OPT_VERIFY_DEPTH ] { 8 }
- Constant [ public integer OPT_CIPHERS ] { 9 }
- Constant [ public integer OPT_NO_SSLv2 ] { 10 }
- Constant [ public integer OPT_NO_SSLv3 ] { 11 }
- Constant [ public integer OPT_NO_TLSv1 ] { 12 }
- Constant [ public integer OPT_NO_TLSv1_1 ] { 13 }
- Constant [ public integer OPT_NO_TLSv1_2 ] { 14 }
- Constant [ public integer OPT_CIPHER_SERVER_PREFERENCE ] { 15 }
- Constant [ public integer OPT_REQUIRE_CLIENT_CERT ] { 16 }
- Constant [ public integer OPT_VERIFY_CLIENT_ONCE ] { 17 }
- Constant [ public string OPENSSL_VERSION_TEXT ] { OpenSSL 1.1.1b FIPS 26 Feb 2019 }
- Constant [ public integer OPENSSL_VERSION_NUMBER ] { 269488175 }
- Constant [ public integer SSL3_VERSION ] { 768 }
- Constant [ public integer TLS1_VERSION ] { 769 }
- Constant [ public integer TLS1_1_VERSION ] { 770 }
- Constant [ public integer TLS1_2_VERSION ] { 771 }
- Constant [ public integer DTLS1_VERSION ] { 65279 }
- Constant [ public integer DTLS1_2_VERSION ] { 65277 }
+ Constant [ public int TLS_CLIENT_METHOD ] { 4 }
+ Constant [ public int TLS_SERVER_METHOD ] { 8 }
+ Constant [ public int TLSv11_CLIENT_METHOD ] { 9 }
+ Constant [ public int TLSv11_SERVER_METHOD ] { 10 }
+ Constant [ public int TLSv12_CLIENT_METHOD ] { 11 }
+ Constant [ public int TLSv12_SERVER_METHOD ] { 12 }
+ Constant [ public int OPT_LOCAL_CERT ] { 1 }
+ Constant [ public int OPT_LOCAL_PK ] { 2 }
+ Constant [ public int OPT_PASSPHRASE ] { 3 }
+ Constant [ public int OPT_CA_FILE ] { 4 }
+ Constant [ public int OPT_CA_PATH ] { 5 }
+ Constant [ public int OPT_ALLOW_SELF_SIGNED ] { 6 }
+ Constant [ public int OPT_VERIFY_PEER ] { 7 }
+ Constant [ public int OPT_VERIFY_DEPTH ] { 8 }
+ Constant [ public int OPT_CIPHERS ] { 9 }
+ Constant [ public int OPT_NO_SSLv2 ] { 10 }
+ Constant [ public int OPT_NO_SSLv3 ] { 11 }
+ Constant [ public int OPT_NO_TLSv1 ] { 12 }
+ Constant [ public int OPT_NO_TLSv1_1 ] { 13 }
+ Constant [ public int OPT_NO_TLSv1_2 ] { 14 }
+ Constant [ public int OPT_CIPHER_SERVER_PREFERENCE ] { 15 }
+ Constant [ public int OPT_REQUIRE_CLIENT_CERT ] { 16 }
+ Constant [ public int OPT_VERIFY_CLIENT_ONCE ] { 17 }
+ Constant [ public string OPENSSL_VERSION_TEXT ] { OpenSSL 1.1.1d FIPS 10 Sep 2019 }
+ Constant [ public int OPENSSL_VERSION_NUMBER ] { 269488207 }
+ Constant [ public int SSL3_VERSION ] { 768 }
+ Constant [ public int TLS1_VERSION ] { 769 }
+ Constant [ public int TLS1_1_VERSION ] { 770 }
+ Constant [ public int TLS1_2_VERSION ] { 771 }
+ Constant [ public int DTLS1_VERSION ] { 65279 }
+ Constant [ public int DTLS1_2_VERSION ] { 65277 }
}
- Static properties [0] {
diff --git a/php-pecl-event.spec b/php-pecl-event.spec
index c8e6ab9..21101ce 100644
--- a/php-pecl-event.spec
+++ b/php-pecl-event.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-event
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -30,7 +30,7 @@
# After 20-sockets.so
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 2.5.3
+%global upstream_version 2.5.4
#global upstream_prever RC3
Summary: Provides interface to libevent library
@@ -38,8 +38,8 @@ Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-URL: http://pecl.php.net/package/event
-Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+URL: https://pecl.php.net/package/event
+Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -282,6 +282,9 @@ fi
%changelog
+* Sun Feb 23 2020 Remi Collet <remi@remirepo.net> - 2.5.4-1
+- update to 2.5.4
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 2.5.3-3
- rebuild for 7.4.0RC1