summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-29 07:16:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-29 07:16:11 +0200
commit47c9bf7e02d64bdb2def89b8e31ee1bf41d4f55a (patch)
tree6d3101e7735e464b3ba223a8464148f8923abe6b
parent860bbc413e9b82cb35664de8f502d7ccb99376ae (diff)
php-pecl-ev: 1.0.1
-rw-r--r--REFLECTION140
-rw-r--r--php-pecl-ev.spec37
2 files changed, 99 insertions, 78 deletions
diff --git a/REFLECTION b/REFLECTION
index 4a67de2..e547a9b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #91 ev version 1.0.0 ] {
+Extension [ <persistent> extension #80 ev version 1.0.1 ] {
- Dependencies {
Dependency [ sockets (Optional) ]
@@ -184,14 +184,14 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [8] {
- Property [ <default> public $data ]
- Property [ <default> public $backend ]
- Property [ <default> public $is_default_loop ]
- Property [ <default> public $iteration ]
- Property [ <default> public $pending ]
- Property [ <default> public $io_interval ]
- Property [ <default> public $timeout_interval ]
- Property [ <default> public $depth ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"backend" ]
+ Property [ <default> public $"is_default_loop" ]
+ Property [ <default> public $"iteration" ]
+ Property [ <default> public $"pending" ]
+ Property [ <default> public $"io_interval" ]
+ Property [ <default> public $"timeout_interval" ]
+ Property [ <default> public $"depth" ]
}
- Methods [22] {
@@ -392,10 +392,10 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [4] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
}
- Methods [9] {
@@ -478,12 +478,12 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [6] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
- Property [ <default> public $fd ]
- Property [ <default> public $events ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
+ Property [ <default> public $"fd" ]
+ Property [ <default> public $"events" ]
}
- Methods [10] {
@@ -582,12 +582,12 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [6] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
- Property [ <default> public $repeat ]
- Property [ <default> public $remaining ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
+ Property [ <default> public $"repeat" ]
+ Property [ <default> public $"remaining" ]
}
- Methods [11] {
@@ -693,12 +693,12 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [6] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
- Property [ <default> public $offset ]
- Property [ <default> public $interval ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
+ Property [ <default> public $"offset" ]
+ Property [ <default> public $"interval" ]
}
- Methods [12] {
@@ -809,11 +809,11 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [5] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
- Property [ <default> public $signum ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
+ Property [ <default> public $"signum" ]
}
- Methods [10] {
@@ -910,13 +910,13 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [7] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
- Property [ <default> public $pid ]
- Property [ <default> public $rpid ]
- Property [ <default> public $rstatus ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
+ Property [ <default> public $"pid" ]
+ Property [ <default> public $"rpid" ]
+ Property [ <default> public $"rstatus" ]
}
- Methods [10] {
@@ -1015,12 +1015,12 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [6] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
- Property [ <default> public $path ]
- Property [ <default> public $interval ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
+ Property [ <default> public $"path" ]
+ Property [ <default> public $"interval" ]
}
- Methods [13] {
@@ -1135,10 +1135,10 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [4] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
}
- Methods [9] {
@@ -1225,10 +1225,10 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [4] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
}
- Methods [9] {
@@ -1315,10 +1315,10 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [4] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
}
- Methods [9] {
@@ -1406,11 +1406,11 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [5] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
- Property [ <default> public $embed ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
+ Property [ <default> public $"embed" ]
}
- Methods [11] {
@@ -1511,10 +1511,10 @@ Extension [ <persistent> extension #91 ev version 1.0.0 ] {
}
- Properties [4] {
- Property [ <default> public $is_active ]
- Property [ <default> public $data ]
- Property [ <default> public $is_pending ]
- Property [ <default> public $priority ]
+ Property [ <default> public $"is_active" ]
+ Property [ <default> public $"data" ]
+ Property [ <default> public $"is_pending" ]
+ Property [ <default> public $"priority" ]
}
- Methods [9] {
diff --git a/php-pecl-ev.spec b/php-pecl-ev.spec
index 9a49f46..5022d96 100644
--- a/php-pecl-ev.spec
+++ b/php-pecl-ev.spec
@@ -6,10 +6,17 @@
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-pecl-ev}
#
# NOTE: bundled libev
#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%scl_package php-pecl-ev
+%endif
%global pecl_name ev
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -23,8 +30,8 @@
#global prever RC9
Summary: Provides interface to libev library
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.0
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 1.0.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
@@ -43,13 +50,13 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-sockets%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
@@ -70,6 +77,10 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -181,6 +192,11 @@ fi
%check
+%if "%{php_version}" < "5.5"
+# https://bitbucket.org/osmanov/pecl-ev/issues/28/101-failed-test-with-php-54
+rm ?TS/tests/16_generator_cb.phpt
+%endif
+
DEPMOD=
[ -f %{php_extdir}/sockets.so ] && DEPMOD="$DEPMOD -d extension=sockets.so"
[ -f %{php_extdir}/posix.so ] && DEPMOD="$DEPMOD -d extension=posix.so"
@@ -238,6 +254,11 @@ rm -rf %{buildroot}
%changelog
+* Fri Jul 29 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- Update to 1.0.1 (stable)
+- ignore 1 failed test with PHP 5.4, see
+ https://bitbucket.org/osmanov/pecl-ev/issues/28/101-failed-test-with-php-54
+
* Tue May 17 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
- update to 1.0.0 (stable)