summaryrefslogtreecommitdiffstats
path: root/php-pecl-env.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-22 15:05:35 +0200
committerRemi Collet <remi@remirepo.net>2020-09-22 15:05:35 +0200
commit9e5072893e7c11738085a5d21aec566637f1512d (patch)
treed2688f7722c04383c34d79dbcc4518e1ab93cd03 /php-pecl-env.spec
parent980e464e949499625e111e4855c8451d09272166 (diff)
add patch for PHP 8
from https://github.com/beberlei/env/pull/10
Diffstat (limited to 'php-pecl-env.spec')
-rw-r--r--php-pecl-env.spec19
1 files changed, 11 insertions, 8 deletions
diff --git a/php-pecl-env.spec b/php-pecl-env.spec
index 4596693..4d3184b 100644
--- a/php-pecl-env.spec
+++ b/php-pecl-env.spec
@@ -22,7 +22,7 @@
Summary: Load environment variables
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.2.1
-Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 10%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
@@ -30,6 +30,7 @@ Source: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Patch0: %{pecl_name}-pr4.patch
Patch1: %{pecl_name}-pr8.patch
+Patch2: %{pecl_name}-pr10.patch
BuildRequires: %{?dtsprefix}gcc
# ignore min PHP version 5.5 (as work with 5.4)
@@ -45,19 +46,16 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -89,6 +87,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
%patch0 -p1 -b .pr4
%patch1 -p1 -b .pr8
+%patch2 -p1 -b .pr10
# Check upstream version (often broken)
extver=$(sed -n '/#define PHP_ENV_VERSION/{s/.* "//;s/".*$//;p}' php_env.h)
@@ -220,6 +219,10 @@ fi
%changelog
+* Tue Sep 22 2020 Remi Collet <remi@remirepo.net> - 0.2.1-10
+- add patch for PHP 8
+ from https://github.com/beberlei/env/pull/10
+
* Wed Feb 19 2020 Remi Collet <remi@remirepo.net> - 0.2.1-9
- add patch for GCC 10
from https://github.com/beberlei/env/pull/8