summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-eio.spec25
3 files changed, 13 insertions, 16 deletions
diff --git a/PHPINFO b/PHPINFO
index a600111..fb9b8c8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,4 +3,4 @@ eio
eio support => enabled
Debug support => disabled
-Version => 3.1.0
+Version => 3.1.2
diff --git a/REFLECTION b/REFLECTION
index 1503428..0ca627c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #125 eio version 3.1.0 ] {
+Extension [ <persistent> extension #66 eio version 3.1.2 ] {
- Dependencies {
Dependency [ sockets (Optional) ]
diff --git a/php-pecl-eio.spec b/php-pecl-eio.spec
index 910913c..75b32a3 100644
--- a/php-pecl-eio.spec
+++ b/php-pecl-eio.spec
@@ -26,7 +26,7 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.1.0
+%global upstream_version 3.1.2
#global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -38,7 +38,7 @@
Summary: Provides interface to the libeio library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is PHP-3.01, library is BSD-2-Clause (or GPL-2.0-or-later)
License: PHP-3.01 AND BSD-2-Clause
URL: https://pecl.php.net/package/%{pecl_name}
@@ -185,9 +185,6 @@ cd %{sources}
--modules | grep '^%{pecl_name}$'
%if %{with tests}
-# see https://github.com/rosmanov/pecl-eio/issues/21
-rm tests/eio_fallocate_basic.phpt
-
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
@@ -201,14 +198,6 @@ REPORT_EXIT_STATUS=1 \
$DEPMOD \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
-
-%if %{with tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php -q --show-diff
-%endif
%endif
@@ -227,7 +216,15 @@ REPORT_EXIT_STATUS=1 \
%changelog
-* Mon Feb 26 2024 Remi Collet <remi@remirepo.net> - 3.1.0-2
+* Wed Feb 21 2024 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+
+* Wed Feb 21 2024 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- update to 3.1.1
+- add missing xthread.h reported as
+ https://github.com/rosmanov/pecl-eio/issues/22
+
+* Mon Feb 19 2024 Remi Collet <remi@remirepo.net> - 3.1.0-2
- F40: ignore 1 test failing reported as
https://github.com/rosmanov/pecl-eio/issues/21