summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-11 06:33:04 +0200
committerRemi Collet <remi@php.net>2023-09-11 06:33:04 +0200
commitf2320ac9f1f856ea837c167b4d5bfe01c0c57272 (patch)
tree3463b567c37149dbef7fe630d26d9a9aae86e263
parentf6310198d46dc98ebb4943280d361f1b3ac6b5c9 (diff)
update to 3.1.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--eio-php83.patch28
-rw-r--r--php-pecl-eio.spec15
4 files changed, 7 insertions, 40 deletions
diff --git a/PHPINFO b/PHPINFO
index 29dfa36..a600111 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,4 +3,4 @@ eio
eio support => enabled
Debug support => disabled
-Version => 3.1.0RC1
+Version => 3.1.0
diff --git a/REFLECTION b/REFLECTION
index f3445da..1503428 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 eio version 3.1.0RC1 ] {
+Extension [ <persistent> extension #125 eio version 3.1.0 ] {
- Dependencies {
Dependency [ sockets (Optional) ]
diff --git a/eio-php83.patch b/eio-php83.patch
deleted file mode 100644
index 522897c..0000000
--- a/eio-php83.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/php8/php_eio.c b/php8/php_eio.c
-index e79d10f..c87ca82 100644
---- a/php8/php_eio.c
-+++ b/php8/php_eio.c
-@@ -479,6 +479,10 @@ static void php_eio_custom_execute(eio_req *req)
- ZVAL_NULL(&zarg);
- }
-
-+#ifdef ZEND_CHECK_STACK_LIMIT
-+ zend_call_stack_init();
-+#endif
-+
- zend_call_method(Z_ISUNDEF(pf->obj) ? NULL : Z_OBJ_P(&pf->obj), pf->ce, &pf->func_ptr,
- ZSTR_VAL(pf->func_ptr->common.function_name),
- ZSTR_LEN(pf->func_ptr->common.function_name),
-@@ -863,8 +867,11 @@ static inline void php_eio_init()
- pid_t cur_pid = getpid();
-
- if (php_eio_pid <= 0 || (php_eio_pid > 0 && cur_pid != php_eio_pid)) {
-- /* Uninitialized or forked a process(which needs it's own eio pipe) */
-+#ifdef ZEND_CHECK_STACK_LIMIT
-+ zend_call_stack_init();
-+#endif
-
-+ /* Uninitialized or forked a process(which needs it's own eio pipe) */
- if (php_eio_pipe_new()) {
- php_error_docref(NULL, E_ERROR,
- "Failed creating internal pipe: %s", strerror(errno));
diff --git a/php-pecl-eio.spec b/php-pecl-eio.spec
index fd4aaa0..d736b94 100644
--- a/php-pecl-eio.spec
+++ b/php-pecl-eio.spec
@@ -27,7 +27,7 @@
%endif
%global upstream_version 3.1.0
-%global upstream_prever RC1
+#global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -38,14 +38,12 @@
Summary: Provides interface to the libeio library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is PHP-3.01, library is BSD-2-Clause (or GPL-2.0-or-later)
License: PHP-3.01 AND BSD-2-Clause
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: %{pecl_name}-php83.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -87,12 +85,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%if "%{php_version}" >= "8.3"
-%patch -P0 -p1
-%endif
-
-sed -e 's/3.0.0RC5/%{upstream_version}%{?upstream_prever}/' -i php%(%{__php} -r 'echo PHP_MAJOR_VERSION;')/php_eio.h
-
# Sanity check, really often broken
extver=$(sed -n '/define PHP_EIO_VERSION/{s/.* "//;s/".*$//;p}' php%(%{__php} -r 'echo PHP_MAJOR_VERSION;')/php_eio.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -234,6 +226,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Sep 11 2023 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+
* Tue Sep 5 2023 Remi Collet <remi@remirepo.net> - 3.1.0~RC1-2
- add patch for PHP from discussion on
https://github.com/rosmanov/pecl-eio/issues/19