summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-23 16:15:40 +0200
committerRemi Collet <remi@remirepo.net>2019-07-23 16:15:40 +0200
commite71c32799fd604ea0104e8a99dd581c4fab50acd (patch)
treefaf1c8fc4f5585ec35569735a9524a69fbdd2a56
parentda60fe98a9579d36f62d4ee371f0e7b418ec1eff (diff)
fix configuration file name in SCL
-rw-r--r--php-pecl-eio.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php-pecl-eio.spec b/php-pecl-eio.spec
index 9b8bcd7..1d43aab 100644
--- a/php-pecl-eio.spec
+++ b/php-pecl-eio.spec
@@ -6,6 +6,11 @@
#
# Please, preserve the changelog entries
#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-eio
+%endif
+
%global pecl_name eio
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
@@ -15,10 +20,6 @@
# After 20-sockets
%global ini_name 40-%{pecl_name}.ini
%endif
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-eio
-%endif
#global prever RC3
#
@@ -28,7 +29,7 @@
Summary: Provides interface to the libeio library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 2.0.4
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
@@ -132,7 +133,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{ini_name} << 'EOF'
+cat << 'EOF' | tee %{ini_name}
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -165,7 +166,7 @@ make %{?_smp_mflags}
make -C NTS install INSTALL_ROOT=%{buildroot}
-# install config file - z-eio.ini to ensure load order (after sockets)
+# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
@@ -262,6 +263,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Jul 23 2019 Remi Collet <remi@remirepo.net> - 2.0.4-4
+- fix configuration file name in SCL
+
* Tue Jul 23 2019 Remi Collet <remi@remirepo.net> - 2.0.4-3
- rebuild for 7.4.0beta1