summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-09 16:45:57 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-09 16:45:57 +0200
commit2e7e865990a67e21f2d66c5e5c29fa53e30bc9b2 (patch)
tree006fa4e20cfd17a747a593ae6890f2ac72bd951f
parent9aed9f7fce288350ff90c072e27ca8f8e3bf99b7 (diff)
php-pecl: add numerical prefix to extension configuration file (2)
-rw-r--r--php-pecl-eio.spec23
1 files changed, 17 insertions, 6 deletions
diff --git a/php-pecl-eio.spec b/php-pecl-eio.spec
index 01a5d08..71638f1 100644
--- a/php-pecl-eio.spec
+++ b/php-pecl-eio.spec
@@ -18,10 +18,18 @@
%global pecl_name eio
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+# After sockets
+%global ini_name z-%{pecl_name}.ini
+%else
+# After 20-sockets
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
Summary: Provides interface to the libeio library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.2.5
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -104,7 +112,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -136,7 +144,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file - z-eio.ini to ensure load order (after sockets)
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/z-%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -144,7 +152,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/z-%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -224,16 +232,19 @@ rm -rf %{buildroot}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/z-%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/z-%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 1.2.5-2
+- add numerical prefix to extension configuration file
+
* Thu Mar 27 2014 Remi Collet <remi@fedoraproject.org> - 1.2.5-1
- Update to 1.2.5 (stable)