summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION128
-rw-r--r--php-pecl-ds.spec10
3 files changed, 81 insertions, 62 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..c83236f
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,5 @@
+
+ds
+
+ds support => enabled
+ds version => 1.2.7
diff --git a/REFLECTION b/REFLECTION
index 49e2859..dd2e498 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #84 ds version 1.2.6 ] {
+Extension [ <persistent> extension #86 ds version 1.2.7 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -62,7 +62,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds> abstract public method isEmpty ] {
@@ -79,7 +79,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Return [ array ]
}
- Method [ <internal:SPL, inherits Countable> abstract public method count ] {
+ Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
}
@@ -135,7 +135,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $callback ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds> abstract public method find ] {
@@ -185,7 +185,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds> abstract public method merge ] {
@@ -193,7 +193,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> $values ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds> abstract public method pop ] {
@@ -257,7 +257,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
Parameter #0 [ <required> integer $index ]
Parameter #1 [ <optional> integer or NULL $length ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds> abstract public method sort ] {
@@ -284,7 +284,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds, inherits Ds\Collection> abstract public method isEmpty ] {
@@ -301,7 +301,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Return [ array ]
}
- Method [ <internal:SPL, inherits Countable> abstract public method count ] {
+ Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
}
@@ -372,7 +372,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $callback ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method find ] {
@@ -422,7 +422,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method merge ] {
@@ -430,7 +430,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> $values ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method pop ] {
@@ -471,7 +471,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method rotate ] {
@@ -501,7 +501,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
Parameter #0 [ <required> integer $index ]
Parameter #1 [ <optional> integer or NULL $length ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method sort ] {
@@ -516,7 +516,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $comparator ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds> public method sum ] {
@@ -542,7 +542,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds, prototype Countable> public method count ] {
@@ -607,7 +607,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds, prototype Countable> public method count ] {
@@ -671,7 +671,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $callback ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method find ] {
@@ -721,7 +721,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method merge ] {
@@ -729,7 +729,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> $values ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method pop ] {
@@ -770,7 +770,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method rotate ] {
@@ -800,7 +800,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
Parameter #0 [ <required> integer $index ]
Parameter #1 [ <optional> integer or NULL $length ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method sort ] {
@@ -815,7 +815,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $comparator ]
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds> public method sum ] {
@@ -898,7 +898,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds, prototype Countable> public method count ] {
@@ -996,7 +996,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds, prototype Countable> public method count ] {
@@ -1077,7 +1077,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> Ds\Map $map ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method filter ] {
@@ -1085,14 +1085,14 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $callback ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method first ] {
- Parameters [0] {
}
- - Return [ Ds\Pair or NULL ]
+ - Return [ Ds\Pair ]
}
Method [ <internal:ds> public method get ] {
@@ -1124,14 +1124,14 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> Ds\Map $map ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method keys ] {
- Parameters [0] {
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method ksort ] {
@@ -1146,14 +1146,14 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $comparator ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method last ] {
- Parameters [0] {
}
- - Return [ Ds\Pair or NULL ]
+ - Return [ Ds\Pair ]
}
Method [ <internal:ds> public method map ] {
@@ -1161,7 +1161,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method merge ] {
@@ -1169,14 +1169,14 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> $values ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method pairs ] {
- Parameters [0] {
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds> public method put ] {
@@ -1220,7 +1220,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method skip ] {
@@ -1228,7 +1228,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> integer $position ]
}
- - Return [ Ds\Pair or NULL ]
+ - Return [ Ds\Pair ]
}
Method [ <internal:ds> public method slice ] {
@@ -1237,7 +1237,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
Parameter #0 [ <required> integer $index ]
Parameter #1 [ <optional> integer or NULL $length ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method sort ] {
@@ -1252,7 +1252,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $comparator ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method sum ] {
@@ -1266,14 +1266,14 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> $map ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds> public method values ] {
- Parameters [0] {
}
- - Return [ Ds\Sequence or NULL ]
+ - Return [ Ds\Sequence ]
}
Method [ <internal:ds> public method xor ] {
@@ -1281,7 +1281,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> Ds\Map $map ]
}
- - Return [ Ds\Map or NULL ]
+ - Return [ Ds\Map ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1294,7 +1294,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds, prototype Countable> public method count ] {
@@ -1341,7 +1341,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Properties [0] {
}
- - Methods [29] {
+ - Methods [30] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1383,15 +1383,15 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> Ds\Set $set ]
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method filter ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $callback ]
+ Parameter #0 [ <optional> callable or NULL $predicate ]
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method first ] {
@@ -1412,7 +1412,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> Ds\Set $set ]
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method join ] {
@@ -1428,12 +1428,20 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
}
}
+ Method [ <internal:ds> public method map ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ Ds\Set ]
+ }
+
Method [ <internal:ds> public method merge ] {
- Parameters [1] {
Parameter #0 [ <required> $values ]
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method reduce ] {
@@ -1461,7 +1469,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method slice ] {
@@ -1470,7 +1478,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
Parameter #0 [ <required> integer $index ]
Parameter #1 [ <optional> integer or NULL $length ]
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method sort ] {
@@ -1485,7 +1493,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <optional> callable or NULL $comparator ]
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method sum ] {
@@ -1499,7 +1507,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> Ds\Set $set ]
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds> public method xor ] {
@@ -1507,7 +1515,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [1] {
Parameter #0 [ <required> Ds\Set $set ]
}
- - Return [ Ds\Set or NULL ]
+ - Return [ Ds\Set ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1520,7 +1528,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds, prototype Countable> public method count ] {
@@ -1604,7 +1612,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [2] {
Parameter #0 [ <required> $value ]
- Parameter #1 [ <required> integer $priority ]
+ Parameter #1 [ <required> $priority ]
}
}
@@ -1618,7 +1626,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Collection or NULL ]
+ - Return [ Ds\Collection ]
}
Method [ <internal:ds, prototype Countable> public method count ] {
@@ -1661,7 +1669,9 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [2] {
+ Property [ <default> public $key ]
+ Property [ <default> public $value ]
}
- Methods [4] {
@@ -1677,7 +1687,7 @@ Extension [ <persistent> extension #84 ds version 1.2.6 ] {
- Parameters [0] {
}
- - Return [ Ds\Pair or NULL ]
+ - Return [ Ds\Pair ]
}
Method [ <internal:ds, prototype JsonSerializable> public method jsonSerialize ] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 182230f..16d3ed0 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -25,7 +25,7 @@
%global ini_name 40-%{pecl_name}.ini
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit cca728734beec20b8c2ba52db3c1eb8fe0ce4a1c
+%global gh_commit 31d238c463ff04b5bc8a6015b19be134175be141
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -33,8 +33,8 @@
Summary: Data Structures for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.6
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.7
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -45,6 +45,7 @@ Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-json
%if %{with_tests}
BuildRequires: %{_bindir}/phpunit6
@@ -243,6 +244,9 @@ cd ..
%changelog
+* Mon Nov 19 2018 Remi Collet <remi@remirepo.net> - 1.2.7-1
+- update to 1.2.7
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.2.6-3
- rebuild for 7.3.0beta2 new ABI