summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-ds.spec16
-rw-r--r--php_common_handlers.c21
-rw-r--r--php_common_handlers.h11
4 files changed, 15 insertions, 44 deletions
diff --git a/REFLECTION b/REFLECTION
index de6a638..65c767e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #78 ds version 1.0.0 ] {
+Extension [ <persistent> extension #144 ds version 1.0.1 ] {
- Classes [11] {
Interface [ <internal:ds> interface Ds\Hashable ] {
@@ -1052,7 +1052,7 @@ Extension [ <persistent> extension #78 ds version 1.0.0 ] {
- Properties [0] {
}
- - Methods [36] {
+ - Methods [37] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1067,6 +1067,13 @@ Extension [ <persistent> extension #78 ds version 1.0.0 ] {
}
}
+ Method [ <internal:ds> public method apply ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ }
+
Method [ <internal:ds> public method capacity ] {
- Parameters [0] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 8ac975d..2cbce97 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -20,8 +20,8 @@
# After json
%global ini_name 40-%{pecl_name}.ini
-# For test suite
-%global gh_commit 538b39609f8d8a5d1cb074dde9b14c80ad72bf8e
+# For test suite, see https://github.com/php-ds/tests/commits/master
+%global gh_commit 6bed9cfe04d35f9fe857a430dcecdac2a651ccdc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -29,7 +29,7 @@
Summary: Data Structures for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.0
+Version: 1.0.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -38,9 +38,6 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# Only use for tests during the build, no value to be packaged separately
# in composer.json: "require-dev": { "php-ds/tests": "dev-master" }
Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
-# https://github.com/php-ds/extension/pull/26
-Source2: https://raw.githubusercontent.com/php-ds/extension/master/src/php/handlers/php_common_handlers.c
-Source3: https://raw.githubusercontent.com/php-ds/extension/master/src/php/handlers/php_common_handlers.h
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -94,7 +91,6 @@ mv %{gh_project}-%{gh_commit} tests
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-cp %{SOURCE2} %{SOURCE3} src/php/handlers/
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DS_VERSION/{s/.* "//;s/".*$//;p}' php_ds.h)
@@ -200,9 +196,6 @@ cd ../ZTS
cd ..
%if %{with_tests}
-# see https://github.com/php-ds/tests/issues/3
-rm tests/tests/Map/sorted.php
-
: Generate autoloader for tests
%{_bindir}/phpab \
--output tests/autoload.php \
@@ -232,6 +225,9 @@ rm tests/tests/Map/sorted.php
%changelog
+* Thu Jul 28 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- Update to 1.0.1
+
* Thu Jul 28 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
- initial package, version 1.0.0 (devel)
open tests/tests/Map/sort.php
diff --git a/php_common_handlers.c b/php_common_handlers.c
deleted file mode 100644
index 73e5006..0000000
--- a/php_common_handlers.c
+++ /dev/null
@@ -1,21 +0,0 @@
-#include "php_common_handlers.h"
-#include "zend_smart_str.h"
-
-int ds_default_cast_object(zval *obj, zval *return_value, int type)
-{
- switch (type) {
- case IS_STRING: {
- smart_str buffer = {0};
-
- smart_str_appendl(&buffer, "object(", 7);
- smart_str_append (&buffer, Z_OBJCE_P(obj)->name);
- smart_str_appendc(&buffer, ')');
-
- smart_str_0(&buffer);
- ZVAL_STR(return_value, buffer.s);
- return SUCCESS;
- }
- }
-
- return FAILURE;
-}
diff --git a/php_common_handlers.h b/php_common_handlers.h
deleted file mode 100644
index 64b9e21..0000000
--- a/php_common_handlers.h
+++ /dev/null
@@ -1,11 +0,0 @@
-#ifndef PHP_COMMON_HANDLERS_H
-#define PHP_COMMON_HANDLERS_H
-
-#include "php.h"
-
-/**
- * Default object cast handler.
- */
-int ds_default_cast_object(zval *obj, zval *return_value, int type);
-
-#endif