summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-ds.spec7
2 files changed, 14 insertions, 4 deletions
diff --git a/REFLECTION b/REFLECTION
index 65c767e..0434be4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #144 ds version 1.0.1 ] {
+Extension [ <persistent> extension #144 ds version 1.0.2 ] {
- Classes [11] {
Interface [ <internal:ds> interface Ds\Hashable ] {
@@ -1052,7 +1052,7 @@ Extension [ <persistent> extension #144 ds version 1.0.1 ] {
- Properties [0] {
}
- - Methods [37] {
+ - Methods [38] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1196,6 +1196,13 @@ Extension [ <persistent> extension #144 ds version 1.0.1 ] {
}
}
+ Method [ <internal:ds> public method putAll ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $values ]
+ }
+ }
+
Method [ <internal:ds> public method reduce ] {
- Parameters [2] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 2cbce97..359a0f4 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -21,7 +21,7 @@
%global ini_name 40-%{pecl_name}.ini
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit 6bed9cfe04d35f9fe857a430dcecdac2a651ccdc
+%global gh_commit bff759ed81f7cb2042700700eb9c1d68e74fb3dd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -29,7 +29,7 @@
Summary: Data Structures for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.1
+Version: 1.0.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -225,6 +225,9 @@ cd ..
%changelog
+* Sat Jul 30 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- Update to 1.0.2 (stable)
+
* Thu Jul 28 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
- Update to 1.0.1