summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION446
-rw-r--r--php-pecl-ds.spec38
3 files changed, 373 insertions, 113 deletions
diff --git a/PHPINFO b/PHPINFO
index 56730ba..a6135e2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
ds
ds support => enabled
-ds version => 1.2.9
+ds version => 1.3.0
diff --git a/REFLECTION b/REFLECTION
index acddce9..e7c5f64 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #90 ds version 1.2.9 ] {
+Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -32,12 +32,12 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [1] {
Parameter #0 [ <required> $obj ]
}
- - Return [ boolean ]
+ - Return [ bool ]
}
}
}
- Interface [ <internal:ds> interface Ds\Collection extends Traversable, Countable, JsonSerializable ] {
+ Interface [ <internal:ds> interface Ds\Collection extends IteratorAggregate, Traversable, Countable, JsonSerializable ] {
- Constants [0] {
}
@@ -51,7 +51,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:ds> abstract public method clear ] {
- Parameters [0] {
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds> abstract public method toArray ] {
@@ -79,6 +79,9 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Return [ array ]
}
+ Method [ <internal:Core, inherits IteratorAggregate> abstract public method getIterator ] {
+ }
+
Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
@@ -93,7 +96,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
- Interface [ <internal:ds> interface Ds\Sequence extends Ds\Collection, JsonSerializable, Countable, Traversable ] {
+ Interface [ <internal:ds> interface Ds\Sequence extends Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate, ArrayAccess ] {
- Constants [0] {
}
@@ -107,11 +110,11 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [29] {
+ - Methods [34] {
Method [ <internal:ds> abstract public method allocate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $capacity ]
+ Parameter #0 [ <required> int $capacity ]
}
}
@@ -119,7 +122,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds> abstract public method contains ] {
@@ -127,7 +130,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [1] {
Parameter #0 [ <optional> ...$values ]
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds> abstract public method filter ] {
@@ -154,14 +157,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> abstract public method get ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
}
}
Method [ <internal:ds> abstract public method insert ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
Parameter #1 [ <optional> ...$values ]
}
}
@@ -220,7 +223,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> abstract public method remove ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
}
}
@@ -233,14 +236,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> abstract public method rotate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rotations ]
+ Parameter #0 [ <required> int $rotations ]
}
}
Method [ <internal:ds> abstract public method set ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
Parameter #1 [ <required> $value ]
}
}
@@ -254,8 +257,8 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> abstract public method slice ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
- Parameter #1 [ <optional> integer or NULL $length ]
+ Parameter #0 [ <required> int $index ]
+ Parameter #1 [ <optional> int or NULL $length ]
}
- Return [ Ds\Sequence ]
}
@@ -291,7 +294,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, inherits Ds\Collection> abstract public method toArray ] {
@@ -301,6 +304,9 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Return [ array ]
}
+ Method [ <internal:Core, inherits IteratorAggregate> abstract public method getIterator ] {
+ }
+
Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
@@ -312,13 +318,42 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
}
}
- Class [ <internal:ds> <iterateable> final class Ds\Vector implements Ds\Sequence, Traversable, Countable, JsonSerializable, Ds\Collection ] {
+ Class [ <internal:ds> <iterateable> final class Ds\Vector implements Ds\Sequence, ArrayAccess, IteratorAggregate, Traversable, Countable, JsonSerializable, Ds\Collection ] {
- Constants [1] {
- Constant [ public integer MIN_CAPACITY ] { 8 }
+ Constant [ public int MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
@@ -330,7 +365,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [34] {
+ - Methods [39] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -338,10 +373,17 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
+ Method [ <internal:ds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Traversable or NULL ]
+ }
+
Method [ <internal:ds, prototype Ds\Sequence> public method allocate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $capacity ]
+ Parameter #0 [ <required> int $capacity ]
}
}
@@ -356,7 +398,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method contains ] {
@@ -364,7 +406,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [1] {
Parameter #0 [ <optional> ...$values ]
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method filter ] {
@@ -391,14 +433,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method get ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
}
}
Method [ <internal:ds, prototype Ds\Sequence> public method insert ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
Parameter #1 [ <optional> ...$values ]
}
}
@@ -433,6 +475,36 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Return [ Ds\Sequence ]
}
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
Method [ <internal:ds, prototype Ds\Sequence> public method pop ] {
- Parameters [0] {
@@ -457,7 +529,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method remove ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
}
}
@@ -477,14 +549,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method rotate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rotations ]
+ Parameter #0 [ <required> int $rotations ]
}
}
Method [ <internal:ds, prototype Ds\Sequence> public method set ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
Parameter #1 [ <required> $value ]
}
}
@@ -498,8 +570,8 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method slice ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
- Parameter #1 [ <optional> integer or NULL $length ]
+ Parameter #0 [ <required> int $index ]
+ Parameter #1 [ <optional> int or NULL $length ]
}
- Return [ Ds\Sequence ]
}
@@ -549,14 +621,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Collection> public method isEmpty ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype JsonSerializable> public method jsonSerialize ] {
@@ -574,10 +646,10 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
- Class [ <internal:ds> <iterateable> final class Ds\Deque implements Ds\Sequence, Traversable, Countable, JsonSerializable, Ds\Collection ] {
+ Class [ <internal:ds> <iterateable> final class Ds\Deque implements Ds\Sequence, ArrayAccess, IteratorAggregate, Traversable, Countable, JsonSerializable, Ds\Collection ] {
- Constants [1] {
- Constant [ public integer MIN_CAPACITY ] { 8 }
+ Constant [ public int MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
@@ -589,7 +661,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [34] {
+ - Methods [39] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -597,6 +669,13 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
+ Method [ <internal:ds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Traversable or NULL ]
+ }
+
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
- Parameters [0] {
@@ -614,14 +693,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Collection> public method isEmpty ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype JsonSerializable> public method jsonSerialize ] {
@@ -640,7 +719,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method allocate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $capacity ]
+ Parameter #0 [ <required> int $capacity ]
}
}
@@ -655,7 +734,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method contains ] {
@@ -663,7 +742,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [1] {
Parameter #0 [ <optional> ...$values ]
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method filter ] {
@@ -690,14 +769,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method get ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
}
}
Method [ <internal:ds, prototype Ds\Sequence> public method insert ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
Parameter #1 [ <optional> ...$values ]
}
}
@@ -732,6 +811,36 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Return [ Ds\Sequence ]
}
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
Method [ <internal:ds, prototype Ds\Sequence> public method pop ] {
- Parameters [0] {
@@ -756,7 +865,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method remove ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
}
}
@@ -776,14 +885,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method rotate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $rotations ]
+ Parameter #0 [ <required> int $rotations ]
}
}
Method [ <internal:ds, prototype Ds\Sequence> public method set ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
Parameter #1 [ <required> $value ]
}
}
@@ -797,8 +906,8 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method slice ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
- Parameter #1 [ <optional> integer or NULL $length ]
+ Parameter #0 [ <required> int $index ]
+ Parameter #1 [ <optional> int or NULL $length ]
}
- Return [ Ds\Sequence ]
}
@@ -833,7 +942,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
- Class [ <internal:ds> <iterateable> final class Ds\Stack implements Ds\Collection, JsonSerializable, Countable, Traversable ] {
+ Class [ <internal:ds> <iterateable> final class Ds\Stack implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate, ArrayAccess ] {
- Constants [0] {
}
@@ -847,7 +956,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [17] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -858,7 +967,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method allocate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $capacity ]
+ Parameter #0 [ <required> int $capacity ]
}
}
@@ -866,7 +975,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds> public method peek ] {
@@ -888,6 +997,43 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
+ Method [ <internal:ds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Traversable or NULL ]
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
- Parameters [0] {
@@ -905,14 +1051,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Collection> public method isEmpty ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype JsonSerializable> public method jsonSerialize ] {
@@ -930,10 +1076,10 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
- Class [ <internal:ds> <iterateable> final class Ds\Queue implements Ds\Collection, JsonSerializable, Countable, Traversable ] {
+ Class [ <internal:ds> <iterateable> final class Ds\Queue implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate ] {
- Constants [1] {
- Constant [ public integer MIN_CAPACITY ] { 8 }
+ Constant [ public int MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
@@ -945,7 +1091,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [17] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -956,7 +1102,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method allocate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $capacity ]
+ Parameter #0 [ <required> int $capacity ]
}
}
@@ -964,7 +1110,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds> public method peek ] {
@@ -986,6 +1132,43 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
+ Method [ <internal:ds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Traversable or NULL ]
+ }
+
+ Method [ <internal:ds> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ds> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:ds> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:ds> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
- Parameters [0] {
@@ -1003,14 +1186,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Collection> public method isEmpty ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype JsonSerializable> public method jsonSerialize ] {
@@ -1028,10 +1211,10 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
- Class [ <internal:ds> <iterateable> final class Ds\Map implements Ds\Collection, JsonSerializable, Countable, Traversable ] {
+ Class [ <internal:ds> <iterateable> final class Ds\Map implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate, ArrayAccess ] {
- Constants [1] {
- Constant [ public integer MIN_CAPACITY ] { 8 }
+ Constant [ public int MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
@@ -1043,7 +1226,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [38] {
+ - Methods [43] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1054,7 +1237,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method allocate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $capacity ]
+ Parameter #0 [ <required> int $capacity ]
}
}
@@ -1069,7 +1252,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds> public method diff ] {
@@ -1108,7 +1291,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds> public method hasValue ] {
@@ -1116,7 +1299,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [1] {
Parameter #0 [ <required> $value ]
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds> public method intersect ] {
@@ -1226,7 +1409,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method skip ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $position ]
+ Parameter #0 [ <required> int $position ]
}
- Return [ Ds\Pair ]
}
@@ -1234,8 +1417,8 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method slice ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
- Parameter #1 [ <optional> integer or NULL $length ]
+ Parameter #0 [ <required> int $index ]
+ Parameter #1 [ <optional> int or NULL $length ]
}
- Return [ Ds\Map ]
}
@@ -1284,6 +1467,43 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Return [ Ds\Map ]
}
+ Method [ <internal:ds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Traversable or NULL ]
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
- Parameters [0] {
@@ -1301,14 +1521,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Collection> public method isEmpty ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype JsonSerializable> public method jsonSerialize ] {
@@ -1326,10 +1546,10 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
- Class [ <internal:ds> <iterateable> final class Ds\Set implements Ds\Collection, JsonSerializable, Countable, Traversable ] {
+ Class [ <internal:ds> <iterateable> final class Ds\Set implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate ] {
- Constants [1] {
- Constant [ public integer MIN_CAPACITY ] { 8 }
+ Constant [ public int MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
@@ -1341,7 +1561,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [30] {
+ - Methods [35] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
@@ -1359,7 +1579,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method allocate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $capacity ]
+ Parameter #0 [ <required> int $capacity ]
}
}
@@ -1367,7 +1587,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds> public method contains ] {
@@ -1375,7 +1595,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [1] {
Parameter #0 [ <optional> ...$values ]
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds> public method diff ] {
@@ -1403,7 +1623,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method get ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $index ]
+ Parameter #0 [ <required> int $index ]
}
}
@@ -1475,8 +1695,8 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method slice ] {
- Parameters [2] {
- Parameter #0 [ <required> integer $index ]
- Parameter #1 [ <optional> integer or NULL $length ]
+ Parameter #0 [ <required> int $index ]
+ Parameter #1 [ <optional> int or NULL $length ]
}
- Return [ Ds\Set ]
}
@@ -1518,6 +1738,43 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Return [ Ds\Set ]
}
+ Method [ <internal:ds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Traversable or NULL ]
+ }
+
+ Method [ <internal:ds> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ds> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:ds> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:ds> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
- Parameters [0] {
@@ -1535,14 +1792,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Collection> public method isEmpty ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype JsonSerializable> public method jsonSerialize ] {
@@ -1560,10 +1817,10 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
- Class [ <internal:ds> <iterateable> final class Ds\PriorityQueue implements Ds\Collection, JsonSerializable, Countable, Traversable ] {
+ Class [ <internal:ds> <iterateable> final class Ds\PriorityQueue implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate ] {
- Constants [1] {
- Constant [ public integer MIN_CAPACITY ] { 8 }
+ Constant [ public int MIN_CAPACITY ] { 8 }
}
- Static properties [0] {
@@ -1575,7 +1832,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [13] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [0] {
@@ -1585,7 +1842,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
Method [ <internal:ds> public method allocate ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $capacity ]
+ Parameter #0 [ <required> int $capacity ]
}
}
@@ -1593,7 +1850,7 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds> public method peek ] {
@@ -1616,6 +1873,13 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
}
}
+ Method [ <internal:ds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Traversable or NULL ]
+ }
+
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
- Parameters [0] {
@@ -1633,14 +1897,14 @@ Extension [ <persistent> extension #90 ds version 1.2.9 ] {
- Parameters [0] {
}
- - Return [ integer ]
+ - Return [ int ]
}
Method [ <internal:ds, prototype Ds\Collection> public method isEmpty ] {
- Parameters [0] {
}
- - Return [ boolean ]
+ - Return [ bool ]
}
Method [ <internal:ds, prototype JsonSerializable> public method jsonSerialize ] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index a1022ae..3e4173e 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-ds
#
-# Copyright (c) 2016-2019 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -14,9 +14,9 @@
%scl_package php-pecl-ds
%global sub_prefix %{scl_prefix}
# No phpunit in SCL
-%global with_tests 0
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -25,7 +25,7 @@
%global ini_name 40-%{pecl_name}.ini
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit 31d238c463ff04b5bc8a6015b19be134175be141
+%global gh_commit 5323dffd6130d733b308e53cc8017eb41d278f3a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -33,11 +33,11 @@
Summary: Data Structures for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.9
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.3.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# Only use for tests during the build, no value to be packaged separately
# in composer.json: "require-dev": { "php-ds/tests": "dev-master" }
Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
@@ -47,7 +47,7 @@ BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-json
-%if %{with_tests}
+%if %{with tests}
BuildRequires: %{_bindir}/phpunit6
BuildRequires: %{_bindir}/phpab
%endif
@@ -66,22 +66,15 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -216,7 +209,7 @@ cd ../ZTS
%endif
cd ..
-%if %{with_tests}
+%if %{with tests}
: Generate autoloader for tests
%{_bindir}/phpab \
--output tests/autoload.php \
@@ -246,6 +239,9 @@ cd ..
%changelog
+* Wed Oct 14 2020 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.2.9-2
- rebuild for 7.4.0RC1