summaryrefslogtreecommitdiffstats
path: root/php-pecl-ds.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-14 07:51:24 +0100
committerRemi Collet <remi@php.net>2021-12-14 07:51:24 +0100
commit9962481fc712894379c909cef442cbf917c148a2 (patch)
treef8f0c2368f0779558b4f368d3d0c1467b7b02c92 /php-pecl-ds.spec
parent5d6f38cafec257d6e25d1b2b10c272302acecf54 (diff)
update to 1.4.0
raise dependency on PHP 7.3 drop all patches merged upstream switch to phpunit8
Diffstat (limited to 'php-pecl-ds.spec')
-rw-r--r--php-pecl-ds.spec36
1 files changed, 14 insertions, 22 deletions
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 8c673f3..4c3e87d 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -25,7 +25,7 @@
%global ini_name 40-%{pecl_name}.ini
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit 5323dffd6130d733b308e53cc8017eb41d278f3a
+%global gh_commit d4f0a9123a82764841d57aa59b2cf1172a413f1d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -33,8 +33,8 @@
Summary: Data Structures for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.0
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.4.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -42,18 +42,14 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# in composer.json: "require-dev": { "php-ds/tests": "dev-master" }
Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
-Patch0: 0001-fix-missing-return-after-exception.patch
-# output from: git diff v1.3.0 -- src
-Patch1: %{pecl_name}-php81.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-devel >= 7.3
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-json
%if %{with tests}
-BuildRequires: %{_bindir}/phpunit7
+BuildRequires: %{_bindir}/phpunit8
BuildRequires: %{_bindir}/phpab
%endif
#BuildRequires: php-debuginfo
@@ -74,9 +70,7 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
@@ -105,12 +99,6 @@ mv %{gh_project}-%{gh_commit} tests
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%if "%{php_version}" > "8.1"
-%patch1 -p1
-%else
-%patch0 -p1
-%endif
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DS_VERSION/{s/.* "//;s/".*$//;p}' php_ds.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -199,9 +187,8 @@ fi
%check
-modules="-d extension=json.so"
+[ -f %{php_extdir}/json.so ] && modules="-d extension=json.so"
-cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
$modules \
@@ -209,14 +196,12 @@ cd NTS
--modules | grep '^%{pecl_name}$'
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
$modules \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%endif
-cd ..
%if %{with tests}
: Generate autoloader for tests
@@ -227,7 +212,8 @@ cd ..
: Run upstream test suite
%{_bindir}/php \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- %{_bindir}/phpunit7 \
+ %{_bindir}/phpunit8 \
+ --do-not-cache-result \
--bootstrap tests/autoload.php \
--verbose tests
%endif
@@ -248,6 +234,12 @@ cd ..
%changelog
+* Tue Dec 14 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- raise dependency on PHP 7.3
+- drop all patches merged upstream
+- switch to phpunit8
+
* Wed Nov 3 2021 Remi Collet <remi@remirepo.net> - 1.3.0-6
- add patches for PHP 8.1 from upstream and from
https://github.com/php-ds/ext-ds/pull/187