summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-29 06:34:39 +0100
committerRemi Collet <remi@remirepo.net>2017-11-29 06:34:39 +0100
commita595cff2ef10667fed102ac13abdc279d39281f6 (patch)
tree4ea332faacd4480860c726ea3a44d83ffc6ecff5
parenta368163d61c85660cc3d699314622c55172d48f7 (diff)
v1.2.4
-rw-r--r--REFLECTION27
-rw-r--r--php-pecl-ds.spec14
2 files changed, 19 insertions, 22 deletions
diff --git a/REFLECTION b/REFLECTION
index 78aad69..cf81e0b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #81 ds version 1.2.3 ] {
+Extension [ <persistent> extension #82 ds version 1.2.4 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -107,14 +107,7 @@ Extension [ <persistent> extension #81 ds version 1.2.3 ] {
- Properties [0] {
}
- - Methods [30] {
- Method [ <internal:ds, ctor> abstract public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $values ]
- }
- }
-
+ - Methods [29] {
Method [ <internal:ds> abstract public method allocate ] {
- Parameters [1] {
@@ -338,7 +331,7 @@ Extension [ <persistent> extension #81 ds version 1.2.3 ] {
}
- Methods [34] {
- Method [ <internal:ds, prototype Ds\Sequence, ctor> public method __construct ] {
+ Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
Parameter #0 [ <optional> $values ]
@@ -597,6 +590,13 @@ Extension [ <persistent> extension #81 ds version 1.2.3 ] {
}
- Methods [34] {
+ Method [ <internal:ds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $values ]
+ }
+ }
+
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
- Parameters [0] {
@@ -637,13 +637,6 @@ Extension [ <persistent> extension #81 ds version 1.2.3 ] {
- Return [ array ]
}
- Method [ <internal:ds, prototype Ds\Sequence, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $values ]
- }
- }
-
Method [ <internal:ds, prototype Ds\Sequence> public method allocate ] {
- Parameters [1] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 08654bd..bb4ecb6 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -21,7 +21,7 @@
%global ini_name 40-%{pecl_name}.ini
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit 6c2da5d3789b7d0251007eb94e097de9601627d2
+%global gh_commit cca728734beec20b8c2ba52db3c1eb8fe0ce4a1c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -29,8 +29,8 @@
Summary: Data Structures for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.3
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.4
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -43,7 +43,7 @@ BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with_tests}
-BuildRequires: %{_bindir}/phpunit
+BuildRequires: %{_bindir}/phpunit6
BuildRequires: %{_bindir}/phpab
%endif
@@ -214,7 +214,7 @@ cd ..
: Run upstream test suite
%{_bindir}/php \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- %{_bindir}/phpunit \
+ %{_bindir}/phpunit6 \
--bootstrap tests/autoload.php \
tests
%endif
@@ -235,6 +235,10 @@ cd ..
%changelog
+* Wed Nov 29 2017 Remi Collet <remi@remirepo.net> - 1.2.4-1
+- Update to 1.2.4
+- switch to phpunit 6
+
* Wed Aug 16 2017 Remi Collet <remi@remirepo.net> - 1.2.3-2
- Update to 1.2.3
- drop patch merged upstream