summaryrefslogtreecommitdiffstats
path: root/php-pecl-dio-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-dio-dev.spec')
-rw-r--r--php-pecl-dio-dev.spec267
1 files changed, 0 insertions, 267 deletions
diff --git a/php-pecl-dio-dev.spec b/php-pecl-dio-dev.spec
deleted file mode 100644
index 5adde6c..0000000
--- a/php-pecl-dio-dev.spec
+++ /dev/null
@@ -1,267 +0,0 @@
-# remirepo spec file for php-pecl-dio
-#
-# Copyright (c) 2013-2016 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%{?scl: %scl_package php-pecl-dio}
-
-%global svn_date 20161113
-%global svn_rev 340995
-%global prever dev
-%global pecl_name dio
-%global with_zts 0%{?__ztsphp:1}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
-%global ini_name 40-%{pecl_name}.ini
-%endif
-
-Summary: Direct I/O functions
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.0.8
-Release: 0.3.%{svn_date}svn%{svn_rev}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{prever}.tgz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel
-BuildRequires: %{?scl_prefix}php-pear
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}
-Obsoletes: php53u-pecl-%{pecl_name}
-Obsoletes: php54-pecl-%{pecl_name}
-Obsoletes: php54w-pecl-%{pecl_name}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name}
-Obsoletes: php55w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name}
-Obsoletes: php56w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name}
-Obsoletes: php70w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name}
-Obsoletes: php71w-pecl-%{pecl_name}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-PHP supports the direct io functions as described in the
-Posix Standard (Section 6) for performing I/O functions at
-a lower level than the C-Language stream I/O functions
-(fopen(), fread(),..).
-
-DIO provides functions and stream wrappers which provide raw and
-serial low level IO support. The use of the DIO functions should
-be considered only when direct control of a device is needed.
-In all other cases, the standard filesystem functions are
-more than adequate.
-
-
-%prep
-%setup -q -c
-mv %{pecl_name}-%{version}%{prever} NTS
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-cd NTS
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_DIO_VERSION/{s/.* "//;s/".*$//;p}' php7/php_dio.h)
-if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat > %{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-EOF
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
-
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
-
-make %{?_smp_mflags}
-%endif
-
-
-%install
-rm -rf %{buildroot}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-cd NTS
-for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%check
-: Minimal load test for NTS extension
-cd NTS
-%{_bindir}/php --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
-
-
-%if %{with_zts}
-: Minimal load test for ZTS extension
-cd ../ZTS
-%{__ztsphp} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{?_licensedir:%license NTS/LICENSE}
-%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.0.8-0.3.20161113svn340995
-- rebuild with PHP 7.1.0 GA
-
-* Sun Nov 13 2016 Remi Collet <remi@fedoraproject.org> - 0.0.8-0.2.20161113svn340995
-- update to 0.0.8dev for PHP 7+
-
-* Sun Nov 13 2016 Remi Collet <remi@fedoraproject.org> - 0.0.8-0.1.20161113svn340993
-- update to 0.0.8dev for PHP 7+
-
-* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.0.7-5
-- adapt for F24
-- drop runtime dependency on pear, new scriptlets
-- fix license management
-- don't install/register tests
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.0.7-4.1
-- Fedora 21 SCL mass rebuild
-
-* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 0.0.7-4
-- improve SCL build
-
-* Tue Apr 15 2014 Remi Collet <remi@fedoraproject.org> - 0.0.7-3
-- add numerical prefix to extension configuration file
-
-* Sun Mar 23 2014 Remi Collet <remi@fedoraproject.org> - 0.0.7-2
-- allow SCL build
-- install doc in pecl_docdir
-- install tests in pecl_testdir
-
-* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 0.0.7-1
-- initial package, version 0.0.7 (beta)