summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-13 17:41:55 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-13 17:41:55 +0100
commitad9e3332941afa15ea475661b66333a62526a40a (patch)
tree9214926fc8f970c277d69d428e8061ab3342a8f3
parent4116850682dcbae6b5c860513c8889689dab4e33 (diff)
php-pecl-dio: dup the spec
-rw-r--r--REFLECTION-DEV138
-rw-r--r--php-pecl-dio-dev.spec261
2 files changed, 399 insertions, 0 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
new file mode 100644
index 0000000..9420c91
--- /dev/null
+++ b/REFLECTION-DEV
@@ -0,0 +1,138 @@
+Extension [ <persistent> extension #80 dio version 0.0.7 ] {
+
+ - Constants [36] {
+ Constant [ integer O_RDONLY ] { 0 }
+ Constant [ integer O_WRONLY ] { 1 }
+ Constant [ integer O_RDWR ] { 2 }
+ Constant [ integer O_CREAT ] { 64 }
+ Constant [ integer O_EXCL ] { 128 }
+ Constant [ integer O_TRUNC ] { 512 }
+ Constant [ integer O_APPEND ] { 1024 }
+ Constant [ integer O_NONBLOCK ] { 2048 }
+ Constant [ integer O_NDELAY ] { 2048 }
+ Constant [ integer O_SYNC ] { 1052672 }
+ Constant [ integer O_ASYNC ] { 8192 }
+ Constant [ integer O_NOCTTY ] { 256 }
+ Constant [ integer S_IRWXU ] { 448 }
+ Constant [ integer S_IRUSR ] { 256 }
+ Constant [ integer S_IWUSR ] { 128 }
+ Constant [ integer S_IXUSR ] { 64 }
+ Constant [ integer S_IRWXG ] { 56 }
+ Constant [ integer S_IRGRP ] { 32 }
+ Constant [ integer S_IWGRP ] { 16 }
+ Constant [ integer S_IXGRP ] { 8 }
+ Constant [ integer S_IRWXO ] { 7 }
+ Constant [ integer S_IROTH ] { 4 }
+ Constant [ integer S_IWOTH ] { 2 }
+ Constant [ integer S_IXOTH ] { 1 }
+ Constant [ integer F_DUPFD ] { 0 }
+ Constant [ integer F_GETFD ] { 1 }
+ Constant [ integer F_GETFL ] { 3 }
+ Constant [ integer F_SETFL ] { 4 }
+ Constant [ integer F_GETLK ] { 5 }
+ Constant [ integer F_SETLK ] { 6 }
+ Constant [ integer F_SETLKW ] { 7 }
+ Constant [ integer F_SETOWN ] { 8 }
+ Constant [ integer F_GETOWN ] { 9 }
+ Constant [ integer F_UNLCK ] { 2 }
+ Constant [ integer F_RDLCK ] { 0 }
+ Constant [ integer F_WRLCK ] { 1 }
+ }
+
+ - Functions {
+ Function [ <internal:dio> function dio_open ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $flags ]
+ Parameter #2 [ <optional> $mode ]
+ }
+ }
+ Function [ <internal:dio> function dio_fdopen ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+ Function [ <internal:dio> function dio_dup ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+ Function [ <internal:dio> function dio_truncate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $offset ]
+ }
+ }
+ Function [ <internal:dio> function dio_stat ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+ Function [ <internal:dio> function dio_seek ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $pos ]
+ Parameter #2 [ <required> $whence ]
+ }
+ }
+ Function [ <internal:dio> function dio_fcntl ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $cmd ]
+ Parameter #2 [ <optional> $arg ]
+ }
+ }
+ Function [ <internal:dio> function dio_read ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <optional> $n ]
+ }
+ }
+ Function [ <internal:dio> function dio_write ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $data ]
+ Parameter #2 [ <optional> $len ]
+ }
+ }
+ Function [ <internal:dio> function dio_close ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+ Function [ <internal:dio> function dio_tcsetattr ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $args ]
+ }
+ }
+ Function [ <internal:dio> function dio_raw ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $mode ]
+ Parameter #2 [ <optional> $options ]
+ }
+ }
+ Function [ <internal:dio> function dio_serial ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $mode ]
+ Parameter #2 [ <optional> $options ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-dio-dev.spec b/php-pecl-dio-dev.spec
new file mode 100644
index 0000000..10a521a
--- /dev/null
+++ b/php-pecl-dio-dev.spec
@@ -0,0 +1,261 @@
+# remirepo spec file for php-pecl-dio
+#
+# Copyright (c) 2013-2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-dio}
+
+%global pecl_name dio
+%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: Direct I/O functions
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.0.7
+Release: 5%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# https://bugs.php.net/65869 Please Provides LICENSE file
+# Link from the headers
+Source1: http://www.php.net/license/3_01.txt
+
+# Fix build warnings
+# http://svn.php.net/viewvc?view=revision&revision=331749
+# http://svn.php.net/viewvc?view=revision&revision=331750
+# http://svn.php.net/viewvc?view=revision&revision=331751
+Patch0: %{pecl_name}-svn.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+Obsoletes: php54-pecl-%{pecl_name}
+Obsoletes: php54w-pecl-%{pecl_name}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name}
+Obsoletes: php55w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+Obsoletes: php56w-pecl-%{pecl_name}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+PHP supports the direct io functions as described in the
+Posix Standard (Section 6) for performing I/O functions at
+a lower level than the C-Language stream I/O functions
+(fopen(), fread(),..).
+
+DIO provides functions and stream wrappers which provide raw and
+serial low level IO support. The use of the DIO functions should
+be considered only when direct control of a device is needed.
+In all other cases, the standard filesystem functions are
+more than adequate.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+cp %{SOURCE1} LICENSE
+%patch0 -p3
+
+# http://svn.php.net/viewvc?view=revision&revision=331748
+chmod -x *.c *.h
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_DIO_VERSION/{s/.* "//;s/".*$//;p}' php_dio.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd NTS
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+%{!?_licensedir:install -Dpm 644 LICENSE %{buildroot}%{pecl_docdir}/%{pecl_name}/LICENSE}
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+: Minimal load test for NTS extension
+cd NTS
+%{_bindir}/php --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php
+
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+cd ../ZTS
+%{__ztsphp} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
+#doc %%{pecl_docdir}/%%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.0.7-5
+- adapt for F24
+- drop runtime dependency on pear, new scriptlets
+- fix license management
+- don't install/register tests
+
+* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.0.7-4.1
+- Fedora 21 SCL mass rebuild
+
+* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 0.0.7-4
+- improve SCL build
+
+* Tue Apr 15 2014 Remi Collet <remi@fedoraproject.org> - 0.0.7-3
+- add numerical prefix to extension configuration file
+
+* Sun Mar 23 2014 Remi Collet <remi@fedoraproject.org> - 0.0.7-2
+- allow SCL build
+- install doc in pecl_docdir
+- install tests in pecl_testdir
+
+* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 0.0.7-1
+- initial package, version 0.0.7 (beta)