summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-09 14:34:05 +0200
committerRemi Collet <fedora@famillecollet.com>2013-10-09 14:34:05 +0200
commit4b45ff3b2073c59da43c0d2c524b3f11ddb424a3 (patch)
tree677d68f2c9c8a26508a66876a8ac1bd3324fd1f3
php-pecl-dio: 0.0.7 - New package
-rw-r--r--3_01.txt68
-rw-r--r--Makefile4
-rw-r--r--dio-svn.patch71
-rw-r--r--php-pecl-dio.spec195
4 files changed, 338 insertions, 0 deletions
diff --git a/3_01.txt b/3_01.txt
new file mode 100644
index 0000000..42536af
--- /dev/null
+++ b/3_01.txt
@@ -0,0 +1,68 @@
+--------------------------------------------------------------------
+ The PHP License, version 3.01
+Copyright (c) 1999 - 2012 The PHP Group. All rights reserved.
+--------------------------------------------------------------------
+
+Redistribution and use in source and binary forms, with or without
+modification, is permitted provided that the following conditions
+are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ 3. The name "PHP" must not be used to endorse or promote products
+ derived from this software without prior written permission. For
+ written permission, please contact group@php.net.
+
+ 4. Products derived from this software may not be called "PHP", nor
+ may "PHP" appear in their name, without prior written permission
+ from group@php.net. You may indicate that your software works in
+ conjunction with PHP by saying "Foo for PHP" instead of calling
+ it "PHP Foo" or "phpfoo"
+
+ 5. The PHP Group may publish revised and/or new versions of the
+ license from time to time. Each version will be given a
+ distinguishing version number.
+ Once covered code has been published under a particular version
+ of the license, you may always continue to use it under the terms
+ of that version. You may also choose to use such covered code
+ under the terms of any subsequent version of the license
+ published by the PHP Group. No one other than the PHP Group has
+ the right to modify the terms applicable to covered code created
+ under this License.
+
+ 6. Redistributions of any form whatsoever must retain the following
+ acknowledgment:
+ "This product includes PHP software, freely available from
+ <http://www.php.net/software/>".
+
+THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
+ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
+DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
+INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
+OF THE POSSIBILITY OF SUCH DAMAGE.
+
+--------------------------------------------------------------------
+
+This software consists of voluntary contributions made by many
+individuals on behalf of the PHP Group.
+
+The PHP Group can be contacted via Email at group@php.net.
+
+For more information on the PHP Group and the PHP project,
+please see <http://www.php.net>.
+
+PHP includes the Zend Engine, freely available at
+<http://www.zend.com>.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/dio-svn.patch b/dio-svn.patch
new file mode 100644
index 0000000..7bbf472
--- /dev/null
+++ b/dio-svn.patch
@@ -0,0 +1,71 @@
+--- pecl/dio/trunk/dio.c 2013/10/09 12:04:16 331748
++++ pecl/dio/trunk/dio.c 2013/10/09 12:15:51 331749
+@@ -775,7 +775,7 @@
+ ZEND_ARG_INFO(0, options)
+ ZEND_END_ARG_INFO()
+
+-static zend_object_handlers dio_raw_object_handlers;
++// not used static zend_object_handlers dio_raw_object_handlers;
+
+ static zend_function_entry dio_functions[] = {
+ /* Class functions. */
+--- pecl/dio/trunk/dio_posix.c 2013/10/09 12:04:16 331748
++++ pecl/dio/trunk/dio_posix.c 2013/10/09 12:15:51 331749
+@@ -266,7 +266,6 @@
+ * earlier than early time.
+ */
+ static int dio_timeval_subtract(struct timeval *late, struct timeval *early, struct timeval *diff) {
+- struct timeval *tmp;
+
+ /* Handle negatives */
+ if (late->tv_sec < early->tv_sec) {
+--- pecl/dio/trunk/dio_stream_wrappers.c 2013/10/09 12:15:51 331749
++++ pecl/dio/trunk/dio_stream_wrappers.c 2013/10/09 12:18:34 331750
+@@ -228,9 +228,8 @@
+ efree(data);
+ RETURN_FALSE;
+ }
++ php_stream_to_zval(stream, return_value);
+ }
+-
+- php_stream_to_zval(stream, return_value);
+ }
+ /* }}} */
+
+@@ -390,9 +389,8 @@
+ efree(data);
+ RETURN_FALSE;
+ }
++ php_stream_to_zval(stream, return_value);
+ }
+-
+- php_stream_to_zval(stream, return_value);
+ }
+ /* }}} */
+
+--- pecl/dio/trunk/dio_posix.c 2013/10/09 12:18:34 331750
++++ pecl/dio/trunk/dio_posix.c 2013/10/09 12:24:28 331751
+@@ -28,7 +28,10 @@
+ * Convert an fopen() mode string to open() flags
+ */
+ static int dio_stream_mode_to_flags(const char *mode) {
+- int flags = 0, ch = 0, bin = 1;
++ int flags = 0, ch = 0;
++#if defined(_O_TEXT) && defined(O_BINARY)
++ int bin = 1;
++#endif
+
+ switch(mode[ch++]) {
+ case 'r':
+@@ -45,9 +48,11 @@
+ break;
+ }
+
++#if defined(_O_TEXT) && defined(O_BINARY)
+ if (mode[ch] != '+') {
+ bin = (mode[ch++] == 'b');
+ }
++#endif
+
+ if (mode[ch] == '+') {
+ flags |= O_RDWR;
diff --git a/php-pecl-dio.spec b/php-pecl-dio.spec
new file mode 100644
index 0000000..de0fa80
--- /dev/null
+++ b/php-pecl-dio.spec
@@ -0,0 +1,195 @@
+# spec file for php-pecl-dio
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?php_inidir: %{expand: %%global php_inidir %{_sysconfdir}/php.d}}
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name dio
+
+Summary: Direct I/O functions
+Name: php-pecl-%{pecl_name}
+Version: 0.0.7
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# https://bugs.php.net/65869 Please Provides LICENSE file
+# Link from the headers
+Source1: http://www.php.net/license/3_01.txt
+
+# Fix build warnings
+# http://svn.php.net/viewvc?view=revision&revision=331749
+# http://svn.php.net/viewvc?view=revision&revision=331750
+# http://svn.php.net/viewvc?view=revision&revision=331751
+Patch0: %{pecl_name}-svn.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: php-devel
+BuildRequires: php-pear
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+
+
+%description
+PHP supports the direct io functions as described in the
+Posix Standard (Section 6) for performing I/O functions at
+a lower level than the C-Language stream I/O functions
+(fopen(), fread(),..).
+
+DIO provides functions and stream wrappers which provide raw and
+serial low level IO support. The use of the DIO functions should
+be considered only when direct control of a device is needed.
+In all other cases, the standard filesystem functions are
+more than adequate.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+cp %{SOURCE1} LICENSE
+%patch0 -p3
+
+# http://svn.php.net/viewvc?view=revision&revision=331748
+chmod -x *.c *.h
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_DIO_VERSION/{s/.* "//;s/".*$//;p}' php_dio.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{pecl_name}.ini << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+%endif
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+: Minimal load test for NTS extension
+cd NTS
+%{_bindir}/php --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php
+
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+cd ../ZTS
+%{__ztsphp} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc NTS/LICENSE
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 0.0.7-1
+- initial package, version 0.0.7 (beta)