summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-decimal.spec31
4 files changed, 19 insertions, 24 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index 1690582..80f81e4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
decimal
decimal support => enabled
-decimal version => 1.3.1
-libmpdec version => 2.4.2
+decimal version => 1.4.0
+libmpdec version => 2.5.0
diff --git a/REFLECTION b/REFLECTION
index bba6510..a842798 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #109 decimal version 1.3.1 ] {
+Extension [ <persistent> extension #121 decimal version 1.4.0 ] {
- Classes [1] {
Class [ <internal:decimal> final class Decimal\Decimal implements JsonSerializable ] {
@@ -331,8 +331,8 @@ Extension [ <persistent> extension #109 decimal version 1.3.1 ] {
Method [ <internal:decimal> public method between ] {
- Parameters [2] {
- Parameter #0 [ <required> $other ]
- Parameter #1 [ <optional> $other ]
+ Parameter #0 [ <required> $op1 ]
+ Parameter #1 [ <optional> $op2 ]
}
- Return [ bool ]
}
diff --git a/php-pecl-decimal.spec b/php-pecl-decimal.spec
index 15f9e81..347f2f3 100644
--- a/php-pecl-decimal.spec
+++ b/php-pecl-decimal.spec
@@ -23,18 +23,18 @@
Summary: Arbitrary-precision floating-point decimal
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.4.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
-BuildRequires: mpdecimal-devel
+BuildRequires: mpdecimal-devel >= 2.4
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -51,21 +51,14 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -173,12 +166,9 @@ fi
%check
-%if 0%{?fedora} >= 33
-rm ?TS/tests/methods/{ceil,floor,truncate}.phpt
-%endif
-
cd NTS
-OPT="-n -d extension=json.so"
+OPT="-n"
+[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
# Minimal load test for NTS extension
%{__php} $OPT \
@@ -227,6 +217,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Feb 18 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+
* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 1.3.1-2
- report Test failure with mpdecimal version 2.5
see https://github.com/php-decimal/ext-decimal/issues/48