summaryrefslogtreecommitdiffstats
path: root/php-pecl-decimal.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-04 09:37:24 +0100
committerRemi Collet <remi@remirepo.net>2020-02-04 09:37:24 +0100
commit09e48a05b98b94fd52dc2562089f67e8d1279298 (patch)
treea1ef9b67ca87f0f3d563a41961d82cb248092309 /php-pecl-decimal.spec
parent483932783561752f0add0693b8b221a2fd09246e (diff)
update to 2.0.0 (alpha)HEADmaster
raise dependency on PHP 7.2 fix undefined symbol using patch from https://github.com/php-decimal/ext-decimal/pull/34 disable ZTS build which segfaults, reported as https://github.com/php-decimal/ext-decimal/issues/35
Diffstat (limited to 'php-pecl-decimal.spec')
-rw-r--r--php-pecl-decimal.spec22
1 files changed, 19 insertions, 3 deletions
diff --git a/php-pecl-decimal.spec b/php-pecl-decimal.spec
index d289100..d084c77 100644
--- a/php-pecl-decimal.spec
+++ b/php-pecl-decimal.spec
@@ -15,7 +15,8 @@
%scl_package php-pecl-decimal
%endif
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+# see https://github.com/php-decimal/ext-decimal/issues/35
+%global with_zts 0
%global with_tests 0%{!?_without_tests:1}
%global pecl_name decimal
# After 20-json.ini
@@ -23,14 +24,17 @@
Summary: Arbitrary-precision floating-point decimal
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.1
+Version: 2.0.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source1: https://raw.githubusercontent.com/php-decimal/ext-decimal/42bfd98e8742c6321b9b58eedeebc3de13eede99/tests/Number/helpers/Number.php
+Patch0: https://patch-diff.githubusercontent.com/raw/php-decimal/ext-decimal/pull/34.patch
+
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel > 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: mpdecimal-devel
@@ -92,6 +96,10 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
+mkdir tests/Number/helpers
+cp %{SOURCE1} tests/Number/helpers/Number.php
+%patch0 -p1 -b .pr34
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DECIMAL_VERSION/{s/.* "//;s/".*$//;p}' php_decimal.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -228,6 +236,14 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Feb 4 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0 (alpha)
+- raise dependency on PHP 7.2
+- fix undefined symbol using patch from
+ https://github.com/php-decimal/ext-decimal/pull/34
+- disable ZTS build which segfaults, reported as
+ https://github.com/php-decimal/ext-decimal/issues/35
+
* Tue Feb 4 2020 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1
- drop patch merged upstream