summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-21 07:49:31 +0100
committerRemi Collet <remi@remirepo.net>2018-11-21 07:49:31 +0100
commit7978ec08798961a26f71948fcb69e2ae6159bdbe (patch)
tree3ebc59b7caa065ef911b2e8816df1b80c56d5f07
parentc5981b455eba02bffc251205e99dbe2bb44e0834 (diff)
v1.1.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-decimal.spec5
3 files changed, 14 insertions, 4 deletions
diff --git a/PHPINFO b/PHPINFO
index 790d784..9726348 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
decimal
decimal support => enabled
-decimal version => 1.0.1
+decimal version => 1.1.0
libmpdec version => 2.4.2
diff --git a/REFLECTION b/REFLECTION
index cd0d22e..3d424da 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #83 decimal version 1.0.1 ] {
+Extension [ <persistent> extension #84 decimal version 1.1.0 ] {
- Classes [1] {
Class [ <internal:decimal> final class Decimal\Decimal implements JsonSerializable ] {
@@ -45,7 +45,7 @@ Extension [ <persistent> extension #83 decimal version 1.0.1 ] {
- Properties [0] {
}
- - Methods [39] {
+ - Methods [40] {
Method [ <internal:decimal, ctor> public method __construct ] {
- Parameters [2] {
@@ -183,6 +183,13 @@ Extension [ <persistent> extension #83 decimal version 1.0.1 ] {
- Return [ Decimal\Decimal ]
}
+ Method [ <internal:decimal> public method trim ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
Method [ <internal:decimal> public method precision ] {
- Parameters [0] {
diff --git a/php-pecl-decimal.spec b/php-pecl-decimal.spec
index 2e59346..72db458 100644
--- a/php-pecl-decimal.spec
+++ b/php-pecl-decimal.spec
@@ -23,7 +23,7 @@
Summary: Arbitrary-precision floating-point decimal
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.1
+Version: 1.1.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: http://pecl.php.net/package/%{pecl_name}
@@ -227,6 +227,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Nov 21 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Tue Oct 30 2018 Remi Collet <remi@remirepo.net> - 1.0.1-1
- update to 1.0.1