summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-29 07:29:29 +0100
committerRemi Collet <remi@remirepo.net>2018-10-29 07:29:29 +0100
commit5842b73b99841eb96770b62a35d52770b25c9b4c (patch)
tree0d5ca0953867c30d253a376b3eca9442b85d9d6e
new package
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION341
-rw-r--r--php-pecl-decimal.spec234
5 files changed, 592 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..72df39a
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,6 @@
+
+decimal
+
+decimal support => enabled
+decimal version => 1.0.0
+libmpdec version => 2.4.2
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..62898bf
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,341 @@
+Extension [ <persistent> extension #83 decimal version 1.0.0 ] {
+
+ - Classes [1] {
+ Class [ <internal:decimal> final class Decimal\Decimal implements JsonSerializable ] {
+
+ - Constants [13] {
+ Constant [ public integer ROUND_UP ] { 101 }
+ Constant [ public integer ROUND_DOWN ] { 102 }
+ Constant [ public integer ROUND_CEILING ] { 103 }
+ Constant [ public integer ROUND_FLOOR ] { 104 }
+ Constant [ public integer ROUND_HALF_UP ] { 105 }
+ Constant [ public integer ROUND_HALF_DOWN ] { 106 }
+ Constant [ public integer ROUND_HALF_EVEN ] { 107 }
+ Constant [ public integer ROUND_HALF_ODD ] { 108 }
+ Constant [ public integer ROUND_TRUNCATE ] { 109 }
+ Constant [ public integer DEFAULT_PRECISION ] { 28 }
+ Constant [ public integer DEFAULT_ROUNDING ] { 107 }
+ Constant [ public integer MIN_PRECISION ] { 1 }
+ Constant [ public integer MAX_PRECISION ] { 999999999999999999 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:decimal> static public method sum ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $values ]
+ Parameter #1 [ <optional> integer or NULL $precision ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> static public method avg ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $values ]
+ Parameter #1 [ <optional> integer or NULL $precision ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [39] {
+ Method [ <internal:decimal, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $value ]
+ Parameter #1 [ <optional> integer $precision ]
+ }
+ }
+
+ Method [ <internal:decimal> public method copy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method sub ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method mul ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method div ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method rem ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method mod ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method pow ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method ln ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method exp ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method log10 ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method sqrt ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method floor ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method ceil ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method truncate ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method round ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> integer or NULL $places ]
+ Parameter #1 [ <optional> integer or NULL $rounding ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method shift ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> integer $places ]
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method precision ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:decimal> public method signum ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:decimal> public method parity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:decimal> public method abs ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method negate ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Decimal\Decimal ]
+ }
+
+ Method [ <internal:decimal> public method isEven ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method isOdd ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method isPositive ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method isNegative ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method isNaN ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method isInf ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method isInteger ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method isZero ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method toFixed ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> integer or NULL $places ]
+ Parameter #1 [ <optional> boolean or NULL $commas ]
+ Parameter #2 [ <optional> integer or NULL $rounding ]
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:decimal> public method toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:decimal> public method toInt ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:decimal> public method toFloat ] {
+
+ - Parameters [0] {
+ }
+ - Return [ float ]
+ }
+
+ Method [ <internal:decimal> public method equals ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $other ]
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:decimal> public method compareTo ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $other ]
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:decimal> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:decimal, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-decimal.spec b/php-pecl-decimal.spec
new file mode 100644
index 0000000..97c73f4
--- /dev/null
+++ b/php-pecl-decimal.spec
@@ -0,0 +1,234 @@
+# remirepo spec file for php-pecl-decimal
+#
+# Copyright (c) 2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-decimal
+%endif
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global with_tests 0%{!?_without_tests:1}
+%global pecl_name decimal
+# After 20-json.ini
+%global ini_name 40-%{pecl_name}.ini
+
+Summary: Arbitrary-precision floating-point decimal
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 1.0.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: MIT
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-json
+BuildRequires: mpdecimal-devel
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-json%{?_isa}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.3"
+Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+Adds support for correctly-rounded arbitrary precision decimal floating point
+arithmetic in PHP 7.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_DECIMAL_VERSION/{s/.* "//;s/".*$//;p}' php_decimal.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-decimal \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-decimal \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+cd NTS
+OPT="-n -d extension=json.so"
+
+# Minimal load test for NTS extension
+%{__php} $OPT \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+# Minimal load test for ZTS extension
+%{__ztsphp} $OPT \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/zts-php -n run-tests.php --show-diff
+%endif
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package, version 1.0.0 (php 7, stable)
+- open https://github.com/php-decimal/extension/pull/1 default path
+- open https://github.com/php-decimal/extension/pull/2 ship tests
+