summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-15 15:45:17 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-15 15:45:17 +0200
commita61bc2150cb222eac9c8d4a2828cc97b452c1938 (patch)
treedaee62e4135c1199a0a0bfb26f126a488f4db20e
parent07e81be1c794c778adc7ce51bee5740d629a6057 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-dbus.spec29
1 files changed, 20 insertions, 9 deletions
diff --git a/php-pecl-dbus.spec b/php-pecl-dbus.spec
index 72ba1f1..6e48691 100644
--- a/php-pecl-dbus.spec
+++ b/php-pecl-dbus.spec
@@ -11,13 +11,18 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
-%global pecl_name dbus
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name dbus
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Extension for interaction with DBUS busses
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.1.1
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/DBus
@@ -51,7 +56,7 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if 0%{!?scl:1}
+%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
%if "%{php_version}" > "5.4"
Obsoletes: php53-pecl-%{pecl_name}
@@ -61,6 +66,9 @@ Obsoletes: php54-pecl-%{pecl_name}
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -102,7 +110,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -133,7 +141,7 @@ make -C NTS \
install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -142,7 +150,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
make -C ZTS \
install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
@@ -185,16 +193,19 @@ rm -rf %{buildroot}
%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Tue Apr 15 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-3
+- add numerical prefix to extension configuration file
+
* Sun Feb 23 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-2
- fix build with php 5.3 (EL-6)