summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-02-23 08:53:38 +0100
committerRemi Collet <fedora@famillecollet.com>2014-02-23 08:53:38 +0100
commit463c2265d861048aac60e3f4fb383d0fdbab0f53 (patch)
tree8093cb8f71a1e5bd924eaeecf403b2fc93dc92c2
parent00a558fd6e7df730676dac2329fd186768d6ce0e (diff)
php-pecl-dbus: fix build with php 5.3 (EL-6)
-rw-r--r--dbus-svn.patch13
-rw-r--r--php-pecl-dbus.spec6
2 files changed, 18 insertions, 1 deletions
diff --git a/dbus-svn.patch b/dbus-svn.patch
index 9e8bd74..40c6d49 100644
--- a/dbus-svn.patch
+++ b/dbus-svn.patch
@@ -206,3 +206,16 @@
return props;
}
+--- pecl/dbus/trunk/dbus.c 2014/02/21 10:51:45 332875
++++ pecl/dbus/trunk/dbus.c 2014/02/23 07:50:34 332876
+@@ -44,6 +44,10 @@
+ # define INIT_OBJ_PROP zend_hash_copy(intern->std.properties, &class_type->default_properties, (copy_ctor_func_t) zval_add_ref, (void *) &tmp, sizeof(zval *));
+ #endif
+
++#ifndef ZEND_MOD_END
++#define ZEND_MOD_END {NULL, NULL, NULL}
++#endif
++
+ /* {{{ arginfo */
+ ZEND_BEGIN_ARG_INFO_EX(arginfo_dbus_object___call, 0, 0, 2)
+ ZEND_ARG_INFO(0, function_name)
diff --git a/php-pecl-dbus.spec b/php-pecl-dbus.spec
index dff2c34..7fce7d2 100644
--- a/php-pecl-dbus.spec
+++ b/php-pecl-dbus.spec
@@ -17,7 +17,7 @@
Summary: Extension for interaction with DBUS busses
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.1.1
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -29,6 +29,7 @@ Source1: http://www.php.net/license/3_01.txt
# Fix RPATH added because of "pkg-config --libs dbus-1"
Patch0: %{pecl_name}-rpath.patch
+# http://svn.php.net/viewvc?view=revision&revision=332876
# http://svn.php.net/viewvc?view=revision&revision=332055
# http://svn.php.net/viewvc?view=revision&revision=315794
# http://svn.php.net/viewvc?view=revision&revision=314194
@@ -194,6 +195,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 23 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-2
+- fix build with php 5.3 (EL-6)
+
* Sun Feb 23 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-1
- initial package, version 0.1.1 (alpha)
- upstream patches from SVN \ No newline at end of file