summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-17 11:53:45 +0200
committerRemi Collet <remi@remirepo.net>2019-04-17 11:53:45 +0200
commitbe675d3ded38012450821d17b52524e44f5065a0 (patch)
tree6952e336243d8ee2c16d7a3063320be53bb7bb50
parent56a6b5928273a0c1a40beb51a0d71ca39dcac079 (diff)
v7.0.0 (stable)
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--dbase-rev347132.patch11
-rw-r--r--dbase-rev347133.patch44
-rw-r--r--php-pecl-dbase.spec15
5 files changed, 8 insertions, 68 deletions
diff --git a/PHPINFO b/PHPINFO
index d7560ae..6db6943 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,4 +1,4 @@
dbase
-Version => 7.0.0RC1
+Version => 7.0.0
diff --git a/REFLECTION b/REFLECTION
index b7e90d9..d20c861 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,7 @@
-Extension [ <persistent> extension #86 dbase version 7.0.0RC1 ] {
+Extension [ <persistent> extension #86 dbase version 7.0.0 ] {
- Constants [5] {
- Constant [ string DBASE_VERSION ] { 7.0.0RC1 }
+ Constant [ string DBASE_VERSION ] { 7.0.0 }
Constant [ integer DBASE_TYPE_DBASE ] { 3 }
Constant [ integer DBASE_TYPE_FOXPRO ] { 48 }
Constant [ integer DBASE_RDONLY ] { 0 }
diff --git a/dbase-rev347132.patch b/dbase-rev347132.patch
deleted file mode 100644
index db9a5dc..0000000
--- a/dbase-rev347132.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- pecl/dbase/trunk/dbase.c 2019/04/04 08:53:11 347131
-+++ pecl/dbase/trunk/dbase.c 2019/04/04 09:08:20 347132
-@@ -822,7 +822,7 @@
- ZEND_ARG_INFO(0, record)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO(arginfo_dbase_create, 0)
-+ZEND_BEGIN_ARG_INFO_EX(arginfo_dbase_create, 0, 0, 2)
- ZEND_ARG_INFO(0, filename)
- ZEND_ARG_ARRAY_INFO(0, fields, 0)
- ZEND_ARG_INFO(0, type)
diff --git a/dbase-rev347133.patch b/dbase-rev347133.patch
deleted file mode 100644
index 7b53892..0000000
--- a/dbase-rev347133.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- pecl/dbase/trunk/tests/dbase_delete_record_error_32bit.phpt 2019/04/04 09:08:20 347132
-+++ pecl/dbase/trunk/tests/dbase_delete_record_error_32bit.phpt 2019/04/04 09:25:54 347133
-@@ -31,7 +31,7 @@
- Warning: dbase_delete_record(): record 1 out of bounds in %s on line %d
- bool(false)
-
--Warning: dbase_delete_record() expects parameter 2 to be integer, float given in %s on line %d
-+Warning: dbase_delete_record() expects parameter 2 to be in%s, float given in %s on line %d
- NULL
- ===DONE===
- --CLEAN--
---- pecl/dbase/trunk/tests/dbase_get_record_error_32bit.phpt 2019/04/04 09:08:20 347132
-+++ pecl/dbase/trunk/tests/dbase_get_record_error_32bit.phpt 2019/04/04 09:25:54 347133
-@@ -32,7 +32,7 @@
- Warning: dbase_get_record(): Tried to read bad record 1 in %s on line %d
- bool(false)
-
--Warning: dbase_get_record() expects parameter 2 to be integer, float given in %s on line %d
-+Warning: dbase_get_record() expects parameter 2 to be in%s, float given in %s on line %d
- NULL
- ===DONE===
- --CLEAN--
---- pecl/dbase/trunk/tests/dbase_get_record_with_names_error_32bit.phpt 2019/04/04 09:08:20 347132
-+++ pecl/dbase/trunk/tests/dbase_get_record_with_names_error_32bit.phpt 2019/04/04 09:25:54 347133
-@@ -32,7 +32,7 @@
- Warning: dbase_get_record_with_names(): Tried to read bad record 1 in %s on line %d
- bool(false)
-
--Warning: dbase_get_record_with_names() expects parameter 2 to be integer, float given in %s on line %d
-+Warning: dbase_get_record_with_names() expects parameter 2 to be in%s, float given in %s on line %d
- NULL
- ===DONE===
- --CLEAN--
---- pecl/dbase/trunk/tests/dbase_replace_record_error_32bit.phpt 2019/04/04 09:08:20 347132
-+++ pecl/dbase/trunk/tests/dbase_replace_record_error_32bit.phpt 2019/04/04 09:25:54 347133
-@@ -30,7 +30,7 @@
- Warning: dbase_replace_record(): record number has to be in range 1..2147483647, but is -1 in %s on line %d
- bool(false)
-
--Warning: dbase_replace_record() expects parameter 3 to be integer, float given in %s on line %d
-+Warning: dbase_replace_record() expects parameter 3 to be in%s, float given in %s on line %d
- NULL
-
- Warning: dbase_replace_record(): expected 7 fields, but got 0 in %s on line %d
diff --git a/php-pecl-dbase.spec b/php-pecl-dbase.spec
index 39473b7..7b9ab22 100644
--- a/php-pecl-dbase.spec
+++ b/php-pecl-dbase.spec
@@ -17,21 +17,18 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name dbase
-%global prever RC1
+#global prever RC1
%global ini_name 40-%{pecl_name}.ini
%global with_tests 0%{!?_without_tests:1}
Summary: dBase database file access functions
Name: %{?sub_prefix}php-pecl-dbase
Version: 7.0.0
-Release: 0.7.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-Patch0: %{pecl_name}-rev347132.patch
-Patch1: %{pecl_name}-rev347133.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -97,11 +94,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p3 -b .up1
-%patch1 -p3 -b .up2
-
-chmod -wx *.c *.h
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DBASE_VERSION/{s/.* "//;s/".*$//;p}' php_dbase.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -236,6 +228,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Apr 17 2019 Remi Collet <remi@remirepo.net> - 7.0.0-1
+- update to 7.0.0 (stable)
+
* Thu Apr 4 2019 Remi Collet <remi@remirepo.net> - 7.0.0-0.7.RC1
- update to 7.0.0RC1
- add upstream patch to fix BC of dbase_create