summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-04 11:17:58 +0200
committerRemi Collet <remi@remirepo.net>2019-04-04 11:17:58 +0200
commit517843f3f91f570946ecb30c1ecf81d60562d187 (patch)
treee5777d7f1e564c119428f7b1236161c16294c3e2
parent1b6ea011df6703ec386291b8d7a716c257e2be4b (diff)
update to 7.0.0RC1
add upstream patch to fix BC of dbase_create
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION13
-rw-r--r--dbase-rev347132.patch11
-rw-r--r--php-pecl-dbase.spec34
4 files changed, 39 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..d7560ae
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,4 @@
+
+dbase
+
+Version => 7.0.0RC1
diff --git a/REFLECTION b/REFLECTION
index 8072022..b7e90d9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,12 @@
-Extension [ <persistent> extension #79 dbase version 7.0.0beta1 ] {
+Extension [ <persistent> extension #86 dbase version 7.0.0RC1 ] {
+
+ - Constants [5] {
+ Constant [ string DBASE_VERSION ] { 7.0.0RC1 }
+ Constant [ integer DBASE_TYPE_DBASE ] { 3 }
+ Constant [ integer DBASE_TYPE_FOXPRO ] { 48 }
+ Constant [ integer DBASE_RDONLY ] { 0 }
+ Constant [ integer DBASE_RDWR ] { 2 }
+ }
- Functions {
Function [ <internal:dbase> function dbase_open ] {
@@ -10,9 +18,10 @@ Extension [ <persistent> extension #79 dbase version 7.0.0beta1 ] {
}
Function [ <internal:dbase> function dbase_create ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $filename ]
Parameter #1 [ <required> array $fields ]
+ Parameter #2 [ <optional> $type ]
}
}
Function [ <internal:dbase> function dbase_close ] {
diff --git a/dbase-rev347132.patch b/dbase-rev347132.patch
new file mode 100644
index 0000000..db9a5dc
--- /dev/null
+++ b/dbase-rev347132.patch
@@ -0,0 +1,11 @@
+--- pecl/dbase/trunk/dbase.c 2019/04/04 08:53:11 347131
++++ pecl/dbase/trunk/dbase.c 2019/04/04 09:08:20 347132
+@@ -822,7 +822,7 @@
+ ZEND_ARG_INFO(0, record)
+ ZEND_END_ARG_INFO()
+
+-ZEND_BEGIN_ARG_INFO(arginfo_dbase_create, 0)
++ZEND_BEGIN_ARG_INFO_EX(arginfo_dbase_create, 0, 0, 2)
+ ZEND_ARG_INFO(0, filename)
+ ZEND_ARG_ARRAY_INFO(0, fields, 0)
+ ZEND_ARG_INFO(0, type)
diff --git a/php-pecl-dbase.spec b/php-pecl-dbase.spec
index 85ad9da..e391ab5 100644
--- a/php-pecl-dbase.spec
+++ b/php-pecl-dbase.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-dbase
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,20 +17,19 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name dbase
-%global prever beta1
+%global prever RC1
%global ini_name 40-%{pecl_name}.ini
%global with_tests 0%{!?_without_tests:1}
Summary: dBase database file access functions
Name: %{?sub_prefix}php-pecl-dbase
Version: 7.0.0
-Release: 0.6.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.7.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# Created from svn
-# see http://svn.php.net/viewvc?view=revision&revision=340710
-Source1: http://pecl.php.net/get/%{pecl_name}-tests-%{version}.tgz
+
+Patch0: %{pecl_name}-rev347132.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
@@ -50,17 +49,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -99,9 +87,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
-%setup -q -c -a1
+%setup -q -c
mv %{pecl_name}-%{version}%{?prever} NTS
-mv tests NTS/tests
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -109,6 +96,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p3 -b .up
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DBASE_VERSION/{s/.* "//;s/".*$//;p}' php_dbase.h)
@@ -208,7 +196,7 @@ TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
+%{__php} -n run-tests.php --show-diff
%endif
%if %{with_zts}
@@ -224,7 +212,7 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
+%{__ztsphp} -n run-tests.php --show-diff
%endif
%endif
@@ -244,6 +232,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Apr 4 2019 Remi Collet <remi@remirepo.net> - 7.0.0-0.7.RC1
+- update to 7.0.0RC1
+- add upstream patch to fix BC of dbase_create
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 7.0.0-0.6.beta1
- rebuild for 7.3.0beta2 new ABI