summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION29
-rw-r--r--php-pecl-datadog-trace.spec24
3 files changed, 49 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index 698dbce..0edf624 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,7 +7,7 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2019
Datadog tracing support => enabled
-Version => 0.23.0
+Version => 0.26.0
Directive => Local Value => Master Value
ddtrace.disable => Off => Off
diff --git a/REFLECTION b/REFLECTION
index 8b99fdb..654092a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #87 ddtrace version 0.23.0 ] {
+Extension [ <persistent> extension #87 ddtrace version 0.26.0 ] {
- INI {
Entry [ ddtrace.disable <SYSTEM> ]
@@ -31,6 +31,33 @@ Extension [ <persistent> extension #87 ddtrace version 0.23.0 ] {
}
Function [ <internal:ddtrace> function dd_trace_disable_in_request ] {
}
+ Function [ <internal:ddtrace> function dd_trace_dd_get_memory_limit ] {
+ }
+ Function [ <internal:ddtrace> function dd_trace_check_memory_under_limit ] {
+ }
+ Function [ <internal:ddtrace> function dd_tracer_circuit_breaker_register_error ] {
+ }
+ Function [ <internal:ddtrace> function dd_tracer_circuit_breaker_register_success ] {
+ }
+ Function [ <internal:ddtrace> function dd_tracer_circuit_breaker_can_try ] {
+ }
+ Function [ <internal:ddtrace> function dd_tracer_circuit_breaker_info ] {
+ }
+ Function [ <internal:ddtrace> function dd_trace_coms_flush_span ] {
+ }
+ Function [ <internal:ddtrace> function dd_trace_coms_next_span_group_id ] {
+ }
+ Function [ <internal:ddtrace> function dd_trace_coms_trigger_writer_flush ] {
+ }
+ Function [ <internal:ddtrace> function dd_trace_flush_span ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $group_id ]
+ Parameter #1 [ <required> &$trace_array ]
+ }
+ }
+ Function [ <internal:ddtrace> function dd_trace_internal_fn ] {
+ }
Function [ <internal:ddtrace> function dd_trace_serialize_msgpack ] {
- Parameters [1] {
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index d020e8e..d65aded 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -34,17 +34,20 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.23.0
+Version: 0.26.0
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: http://pecl.php.net/package/%{proj_name}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/DataDog/dd-trace-php/pull/452.patch
-
+%if 0%{?rhel} == 6
+BuildRequires: devtoolset-6-toolchain
+%else
BuildRequires: %{?dtsprefix}gcc
+%endif
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: curl-devel
# For tests
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-posix
@@ -106,7 +109,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
cp src/ext/mpack/LICENSE LICENSE.mpack
-%patch0 -p1
: Sanity check, really often broken
extver=$(sed -n '/#define PHP_DDTRACE_VERSION /{s/.* "//;s/".*$//;p}' src/ext/version.h)
@@ -136,6 +138,9 @@ EOF
%build
+%if 0%{?rhel} == 6
+source /opt/rh/devtoolset-6/enable
+%endif
%{?dtsenable}
cd NTS
@@ -156,6 +161,9 @@ make %{?_smp_mflags}
%install
+%if 0%{?rhel} == 6
+source /opt/rh/devtoolset-6/enable
+%endif
%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -182,6 +190,10 @@ done
# Erratic result on 5.6 and EL-6
rm ?TS/tests/ext/segfault_backtrace_disabled_via_env_enabled_in_ini.phpt
rm ?TS/tests/ext/segfault_backtrace_disabled.phpt
+%if %{__isa_bits} < 64
+rm ?TS/tests/ext/dd_trace_coms_test_parallel_writer_consistency.phpt
+%endif
+
MOD="-n"
[ -f %{php_extdir}/json.so ] && MOD="$MOD -d extension=json.so"
@@ -249,6 +261,10 @@ fi
%changelog
+* Sat Jun 1 2019 Remi Collet <remi@remirepo.net> - 0.26.0-1
+- update to 0.26.0
+- drop patch merged upstream
+
* Mon May 27 2019 Remi Collet <remi@remirepo.net> - 0.23.0-2
- add patch for 7.4 from
https://github.com/DataDog/dd-trace-php/pull/452