summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-datadog-trace.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index 31e97bd..87144d5 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -20,9 +20,10 @@
%global pecl_name ddtrace
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global with_tests 0%{!?_without_tests:1}
%global ini_name 40-%{pecl_name}.ini
+%bcond_without tests
+
Summary: APM and distributed tracing for PHP
Name: %{?scl_prefix}php-pecl-datadog-trace
Version: 0.76.2
@@ -195,11 +196,13 @@ cd NTS
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep -i '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="$DEP $MOD -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{_bindir}/php -n run-tests.php -q --show-diff
+%endif
%if %{with_zts}
cd ../ZTS