summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO41
-rw-r--r--REFLECTION44
-rw-r--r--php-pecl-datadog-trace.spec14
3 files changed, 77 insertions, 22 deletions
diff --git a/PHPINFO b/PHPINFO
index cb85210..e130533 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -6,19 +6,19 @@ Datadog PHP tracer extension
For help, check out the documentation at https://docs.datadoghq.com/tracing/languages/php/
(c) Datadog 2020
-Datadog tracing support => disabled
-Version => 1.3.2
+Datadog tracing support => enabled
+Version => 1.4.0
DATADOG TRACER CONFIGURATION => {
- "date": "2024-09-27T08:41:26Z",
- "os_name": "Linux builder.remirepo.net 6.10.11-100.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Wed Sep 18 21:08:06 UTC 2024 x86_64",
- "os_version": "6.10.11-100.fc39.x86_64",
- "version": "1.3.2",
+ "date": "2024-10-09T07:47:16Z",
+ "os_name": "Linux builder.remirepo.net 6.10.12-100.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Mon Sep 30 21:36:56 UTC 2024 x86_64",
+ "os_version": "6.10.12-100.fc39.x86_64",
+ "version": "1.4.0",
"lang": "php",
"lang_version": "8.2.24",
"env": null,
"enabled": true,
"service": null,
- "enabled_cli": false,
+ "enabled_cli": true,
"agent_url": "http:\/\/localhost:8126",
"debug": false,
"analytics_enabled": false,
@@ -36,18 +36,22 @@ DATADOG TRACER CONFIGURATION => {
"uri_fragment_regex": null,
"uri_mapping_incoming": null,
"uri_mapping_outgoing": null,
- "auto_flush_enabled": false,
+ "auto_flush_enabled": true,
"generate_root_span": true,
"http_client_split_by_domain": false,
"measure_compile_time": true,
"report_hostname_on_root_span": false,
"traced_internal_functions": null,
- "enabled_from_env": false,
+ "enabled_from_env": true,
"opcache.file_cache": null,
"sidecar_trace_sender": false,
"agent_error": "Failed to connect to localhost port 8126 after 0 ms: Couldn't connect to server"
}
+ Diagnostics
+agent_error => Failed to connect to localhost port 8126 after 0 ms: Couldn't connect to server
+Diagnostic checks => failed
+
Directive => Local Value => Master Value
ddtrace.disable => 0 => 0
ddtrace.cgroup_file => /proc/self/cgroup => /proc/self/cgroup
@@ -70,17 +74,21 @@ datadog.tags => no value => no value
datadog.trace.agent_port => 0 => 0
datadog.trace.analytics_enabled => Off => Off
datadog.trace.append_trace_ids_to_logs => Off => Off
-datadog.trace.auto_flush_enabled => Off => Off
-datadog.trace.cli_enabled => Off => Off
+datadog.trace.auto_flush_enabled => On => On
+datadog.trace.cli_enabled => On => On
datadog.trace.measure_compile_time => On => On
+datadog.trace.measure_peak_memory_usage => On => On
datadog.trace.debug => Off => Off
-datadog.trace.enabled => Off => On
+datadog.trace.enabled => On => On
datadog.instrumentation_telemetry_enabled => On => On
datadog.trace.health_metrics_enabled => Off => Off
datadog.trace.health_metrics_heartbeat_sample_rate => 0.001 => 0.001
datadog.trace.db_client_split_by_instance => Off => Off
datadog.trace.http_client_split_by_domain => Off => Off
datadog.trace.redis_client_split_by_host => Off => Off
+datadog.exception_replay_enabled => Off => Off
+datadog.exception_replay_capture_max_frames => -1 => -1
+datadog.exception_replay_capture_interval_seconds => 3600 => 3600
datadog.trace.memory_limit => no value => no value
datadog.trace.report_hostname => Off => Off
datadog.trace.flush_collect_cycles => Off => Off
@@ -115,7 +123,8 @@ datadog.trace.traced_internal_functions => no value => no value
datadog.trace.agent_timeout => 500 => 500
datadog.trace.agent_connect_timeout => 100 => 100
datadog.trace.debug_prng_seed => -1 => -1
-datadog.log_backtrace => On => On
+datadog.log_backtrace => Off => Off
+datadog.crashtracking_enabled => On => On
datadog.trace.generate_root_span => On => On
datadog.trace.spans_limit => 1000 => 1000
datadog.trace.128_bit_traceid_generation_enabled => On => On
@@ -166,6 +175,12 @@ datadog.openai_logs_enabled => Off => Off
datadog.openai_span_char_limit => 128 => 128
datadog.openai_span_prompt_completion_sample_rate => 1.0 => 1.0
datadog.openai_log_prompt_completion_sample_rate => 0.1 => 0.1
+datadog.inject_force => Off => Off
+datadog.remote_config_poll_interval_seconds => 5 => 5
+datadog.remote_config_enabled => On => On
+datadog.dynamic_instrumentation.enabled => Off => Off
+datadog.dynamic_instrumentation.redacted_identifiers => no value => no value
+datadog.dynamic_instrumentation.redacted_types => no value => no value
datadog.trace.amqp_enabled => On => On
datadog.trace.amqp_analytics_enabled => Off => Off
datadog.amqp_analytics_enabled => Off => Off
diff --git a/REFLECTION b/REFLECTION
index 3a62695..af0e975 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 ddtrace version 1.3.2 ] {
+Extension [ <persistent> extension #122 ddtrace version 1.4.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -70,20 +70,22 @@ Extension [ <persistent> extension #119 ddtrace version 1.3.2 ] {
Current = 'false'
}
Entry [ datadog.trace.auto_flush_enabled <ALL> ]
- Current = 'false'
+ Current = 'true'
}
Entry [ datadog.trace.cli_enabled <ALL> ]
- Current = 'false'
+ Current = 'true'
}
Entry [ datadog.trace.measure_compile_time <ALL> ]
Current = 'true'
}
+ Entry [ datadog.trace.measure_peak_memory_usage <ALL> ]
+ Current = 'true'
+ }
Entry [ datadog.trace.debug <ALL> ]
Current = 'false'
}
Entry [ datadog.trace.enabled <ALL> ]
- Current = '0'
- Default = 'true'
+ Current = 'true'
}
Entry [ datadog.instrumentation_telemetry_enabled <SYSTEM> ]
Current = 'true'
@@ -103,6 +105,15 @@ Extension [ <persistent> extension #119 ddtrace version 1.3.2 ] {
Entry [ datadog.trace.redis_client_split_by_host <ALL> ]
Current = 'false'
}
+ Entry [ datadog.exception_replay_enabled <ALL> ]
+ Current = 'false'
+ }
+ Entry [ datadog.exception_replay_capture_max_frames <ALL> ]
+ Current = '-1'
+ }
+ Entry [ datadog.exception_replay_capture_interval_seconds <ALL> ]
+ Current = '3600'
+ }
Entry [ datadog.trace.memory_limit <ALL> ]
Current = ''
}
@@ -206,6 +217,9 @@ Extension [ <persistent> extension #119 ddtrace version 1.3.2 ] {
Current = '-1'
}
Entry [ datadog.log_backtrace <ALL> ]
+ Current = 'false'
+ }
+ Entry [ datadog.crashtracking_enabled <ALL> ]
Current = 'true'
}
Entry [ datadog.trace.generate_root_span <ALL> ]
@@ -358,6 +372,24 @@ Extension [ <persistent> extension #119 ddtrace version 1.3.2 ] {
Entry [ datadog.openai_log_prompt_completion_sample_rate <ALL> ]
Current = '0.1'
}
+ Entry [ datadog.inject_force <SYSTEM> ]
+ Current = 'false'
+ }
+ Entry [ datadog.remote_config_poll_interval_seconds <SYSTEM> ]
+ Current = '5'
+ }
+ Entry [ datadog.remote_config_enabled <SYSTEM> ]
+ Current = 'true'
+ }
+ Entry [ datadog.dynamic_instrumentation.enabled <SYSTEM> ]
+ Current = 'false'
+ }
+ Entry [ datadog.dynamic_instrumentation.redacted_identifiers <SYSTEM> ]
+ Current = ''
+ }
+ Entry [ datadog.dynamic_instrumentation.redacted_types <SYSTEM> ]
+ Current = ''
+ }
Entry [ datadog.trace.amqp_enabled <ALL> ]
Current = 'true'
}
@@ -941,7 +973,7 @@ Extension [ <persistent> extension #119 ddtrace version 1.3.2 ] {
Constant [ int DDTrace\DBM_PROPAGATION_FULL ] { 2 }
Constant [ int DDTrace\Internal\SPAN_FLAG_OPENTELEMETRY ] { 1 }
Constant [ int DDTrace\Internal\SPAN_FLAG_OPENTRACING ] { 2 }
- Constant [ string DD_TRACE_VERSION ] { 1.3.2 }
+ Constant [ string DD_TRACE_VERSION ] { 1.4.0 }
Constant [ int DD_TRACE_PRIORITY_SAMPLING_AUTO_KEEP ] { 1 }
Constant [ int DD_TRACE_PRIORITY_SAMPLING_AUTO_REJECT ] { 0 }
Constant [ int DD_TRACE_PRIORITY_SAMPLING_USER_KEEP ] { 2 }
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index 89215eb..d1e92a5 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -30,7 +30,7 @@
# extension name
%global pecl_name ddtrace
-%global upstream_version 1.3.2
+%global upstream_version 1.4.0
#global upstream_prever beta1
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
@@ -167,11 +167,15 @@ source /opt/%{scl_vendor}/%{scl}/enable
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
--enable-ddtrace \
--with-php-config=%{__phpconfig}
+
+# make_build breaks verbose mode for rust, so keep old way
make %{?_smp_mflags}
%if %{with_zts}
@@ -179,6 +183,7 @@ cd ../ZTS
%configure \
--enable-ddtrace \
--with-php-config=%{__ztsphpconfig}
+
make %{?_smp_mflags}
%endif
@@ -186,7 +191,7 @@ make %{?_smp_mflags}
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -195,7 +200,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -275,6 +280,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Oct 9 2024 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+
* Fri Sep 27 2024 Remi Collet <remi@remirepo.net> - 1.3.2-1
- update to 1.3.2