summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-23 09:10:22 +0100
committerRemi Collet <remi@php.net>2021-12-23 09:10:22 +0100
commitc89404063dc9d2d3decd4463fdc9f8b72386295f (patch)
tree7dd210c5cf4fb4510544182947efa404f0aa82f0
parente3c444ac995a040639768036c3589c6857e2b315 (diff)
update to 0.68.0
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION130
-rw-r--r--php-pecl-datadog-trace.spec19
3 files changed, 106 insertions, 51 deletions
diff --git a/PHPINFO b/PHPINFO
index df1e462..0305f74 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,11 +7,11 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2020
Datadog tracing support => disabled
-Version => 0.67.0
-DATADOG TRACER CONFIGURATION => {"date":"2021-11-02T10:09:15Z","os_name":"Linux builder.remirepo.net 5.14.13-100.fc33.x86_64 #1 SMP Mon Oct 18 12:36:04 UTC 2021 x86_64","os_version":"5.14.13-100.fc33.x86_64","version":"0.67.0","lang":"php","lang_version":"7.4.25","env":null,"enabled":true,"service":null,"enabled_cli":false,"agent_url":"http://localhost:8126","debug":false,"analytics_enabled":false,"sample_rate":1,000000,"sampling_rules":null,"tags":{},"service_mapping":{},"distributed_tracing_enabled":true,"priority_sampling_enabled":true,"dd_version":null,"architecture":"x86_64","sapi":"cli","datadog.trace.request_init_hook":"/usr/share/pear/datadog_trace/bridge/dd_wrap_autoloader.php","open_basedir_configured":false,"uri_fragment_regex":null,"uri_mapping_incoming":null,"uri_mapping_outgoing":null,"auto_flush_enabled":false,"generate_root_span":true,"http_client_split_by_domain":false,"measure_compile_time":true,"report_hostname_on_root_span":false,"traced_internal_functions":null,"auto_prepend_file_configured":false,"integrations_disabled":"default","enabled_from_env":false,"opcache.file_cache":null,"agent_error":"Failed to connect to localhost port 8126: Connexion refusée"}
+Version => 0.68.0
+DATADOG TRACER CONFIGURATION => {"date":"2021-12-23T07:47:40Z","os_name":"Linux builder.remirepo.net 5.15.10-200.fc35.x86_64 #1 SMP Fri Dec 17 14:46:39 UTC 2021 x86_64","os_version":"5.15.10-200.fc35.x86_64","version":"0.68.0","lang":"php","lang_version":"8.0.14","env":null,"enabled":true,"service":null,"enabled_cli":false,"agent_url":"http:\/\/localhost:8126","debug":false,"analytics_enabled":false,"sample_rate":1,"sampling_rules":[],"tags":[],"service_mapping":[],"distributed_tracing_enabled":true,"priority_sampling_enabled":true,"dd_version":null,"architecture":"x86_64","sapi":"cli","datadog.trace.request_init_hook":"\/usr\/share\/pear\/datadog_trace\/bridge\/dd_wrap_autoloader.php","open_basedir_configured":false,"uri_fragment_regex":null,"uri_mapping_incoming":null,"uri_mapping_outgoing":null,"auto_flush_enabled":false,"generate_root_span":true,"http_client_split_by_domain":false,"measure_compile_time":true,"report_hostname_on_root_span":false,"traced_internal_functions":null,"auto_prepend_file_configured":false,"integrations_disabled":"default","enabled_from_env":false,"opcache.file_cache":null,"agent_error":"Failed to connect to localhost port 8126 after 0 ms: Connexion refus\u00e9e"}
Diagnostics
-agent_error => Failed to connect to localhost port 8126: Connexion refusée
+agent_error => Failed to connect to localhost port 8126 after 0 ms: Connexion refusée
Diagnostic checks => failed
Directive => Local Value => Master Value
@@ -50,7 +50,7 @@ datadog.trace.resource_uri_mapping_incoming => no value => no value
datadog.trace.resource_uri_mapping_outgoing => no value => no value
datadog.trace.sample_rate => 1 => 1
datadog.sampling_rate => 1 => 1
-datadog.trace.sampling_rules => no value => no value
+datadog.trace.sampling_rules => [] => []
datadog.trace.header_tags => no value => no value
datadog.trace.traced_internal_functions => no value => no value
datadog.trace.agent_timeout => 500 => 500
diff --git a/REFLECTION b/REFLECTION
index 6a96ebc..1f22726 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,8 @@
-Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
+Extension [ <persistent> extension #119 ddtrace version 0.68.0 ] {
+
+ - Dependencies {
+ Dependency [ json (Required) ]
+ }
- INI {
Entry [ ddtrace.disable <SYSTEM> ]
@@ -108,7 +112,7 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
Current = '1'
}
Entry [ datadog.trace.sampling_rules <ALL> ]
- Current = ''
+ Current = '[]'
}
Entry [ datadog.trace.header_tags <ALL> ]
Current = ''
@@ -508,8 +512,14 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
}
}
- - Constants [1] {
- Constant [ string DD_TRACE_VERSION ] { 0.67.0 }
+ - Constants [7] {
+ Constant [ string DD_TRACE_VERSION ] { 0.68.0 }
+ Constant [ int DD_TRACE_PRIORITY_SAMPLING_AUTO_KEEP ] { 1 }
+ Constant [ int DD_TRACE_PRIORITY_SAMPLING_AUTO_REJECT ] { 0 }
+ Constant [ int DD_TRACE_PRIORITY_SAMPLING_USER_KEEP ] { 2 }
+ Constant [ int DD_TRACE_PRIORITY_SAMPLING_USER_REJECT ] { -1 }
+ Constant [ int DD_TRACE_PRIORITY_SAMPLING_UNKNOWN ] { 1073741824 }
+ Constant [ int DD_TRACE_PRIORITY_SAMPLING_UNSET ] { 1073741825 }
}
- Functions {
@@ -518,7 +528,7 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
- Parameters [3] {
Parameter #0 [ <required> $class_or_function_name ]
Parameter #1 [ <required> $method_name_or_tracing_closure ]
- Parameter #2 [ <optional> $tracing_closure ]
+ Parameter #2 [ <optional> $tracing_closure = <default> ]
}
}
Function [ <internal:ddtrace> function dd_trace_buffer_span ] {
@@ -566,7 +576,7 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
Function [ <internal:ddtrace> function dd_trace_generate_id ] {
- Parameters [1] {
- Parameter #0 [ <optional> $existing_id ]
+ Parameter #0 [ <optional> $existing_id = <default> ]
}
}
Function [ <internal:ddtrace> function dd_trace_internal_fn ] {
@@ -589,13 +599,13 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
Function [ <internal:ddtrace> function DDTrace\start_span ] {
- Parameters [1] {
- Parameter #0 [ <optional> $start_time ]
+ Parameter #0 [ <optional> $start_time = <default> ]
}
}
Function [ <internal:ddtrace> function DDTrace\close_span ] {
- Parameters [1] {
- Parameter #0 [ <optional> $finish_time ]
+ Parameter #0 [ <optional> $finish_time = <default> ]
}
}
Function [ <internal:ddtrace> function DDTrace\active_span ] {
@@ -618,20 +628,20 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
- Parameters [0] {
}
}
- Function [ <internal:ddtrace> function DDTrace\trace_id ] {
+ Function [ <internal:ddtrace> function dd_trace_push_span_id ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $existing_id = <default> ]
}
}
- Function [ <internal:ddtrace> function DDTrace\current_context ] {
+ Function [ <internal:ddtrace> function DDTrace\trace_id ] {
- Parameters [0] {
}
}
- Function [ <internal:ddtrace> function dd_trace_push_span_id ] {
+ Function [ <internal:ddtrace> function DDTrace\current_context ] {
- - Parameters [1] {
- Parameter #0 [ <optional> $existing_id ]
+ - Parameters [0] {
}
}
Function [ <internal:ddtrace> function dd_trace_reset ] {
@@ -703,7 +713,7 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
Function [ <internal:ddtrace> function ddtrace_config_app_name ] {
- Parameters [1] {
- Parameter #0 [ <optional> $default_name ]
+ Parameter #0 [ <optional> $default_name = <default> ]
}
}
Function [ <internal:ddtrace> function ddtrace_config_distributed_tracing_enabled ] {
@@ -774,8 +784,8 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
- Parameters [3] {
Parameter #0 [ <required> $function_name ]
- Parameter #1 [ <optional> $prehook ]
- Parameter #2 [ <optional> $posthook ]
+ Parameter #1 [ <optional> $prehook = <default> ]
+ Parameter #2 [ <optional> $posthook = <default> ]
}
}
Function [ <internal:ddtrace> function DDTrace\hook_method ] {
@@ -783,8 +793,8 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
- Parameters [4] {
Parameter #0 [ <required> $class_name ]
Parameter #1 [ <required> $method_name ]
- Parameter #2 [ <optional> $prehook ]
- Parameter #3 [ <optional> $posthook ]
+ Parameter #2 [ <optional> $prehook = <default> ]
+ Parameter #3 [ <optional> $posthook = <default> ]
}
}
Function [ <internal:ddtrace> function DDTrace\startup_logs ] {
@@ -792,6 +802,19 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
- Parameters [0] {
}
}
+ Function [ <internal:ddtrace> function DDTrace\get_priority_sampling ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $global = <default> ]
+ }
+ }
+ Function [ <internal:ddtrace> function DDTrace\set_priority_sampling ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $priority ]
+ Parameter #1 [ <optional> $global = <default> ]
+ }
+ }
Function [ <internal:ddtrace> function DDTrace\Config\integration_analytics_enabled ] {
- Parameters [1] {
@@ -830,14 +853,15 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
- Static methods [0] {
}
- - Properties [7] {
- Property [ <default> public $name ]
- Property [ <default> public $resource ]
- Property [ <default> public $service ]
- Property [ <default> public $type ]
- Property [ <default> public $meta ]
- Property [ <default> public $metrics ]
- Property [ <default> public $exception ]
+ - Properties [8] {
+ Property [ public $name = NULL ]
+ Property [ public $resource = NULL ]
+ Property [ public $service = NULL ]
+ Property [ public $type = NULL ]
+ Property [ public $meta = NULL ]
+ Property [ public $metrics = NULL ]
+ Property [ public $exception = NULL ]
+ Property [ public $parent = NULL ]
}
- Methods [2] {
@@ -855,7 +879,7 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
}
}
- Class [ <internal:ddtrace> class DDTrace\FatalError extends Exception implements Throwable ] {
+ Class [ <internal:ddtrace> class DDTrace\FatalError extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -867,47 +891,81 @@ Extension [ <persistent> extension #128 ddtrace version 0.67.0 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index b5e5a46..891e52b 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -26,7 +26,7 @@
Summary: APM and distributed tracing for PHP
Name: %{?sub_prefix}php-pecl-datadog-trace
-Version: 0.67.0
+Version: 0.68.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# extension is dual-licensed under Apache 2.0 or BSD3.
# mpack is MIT
@@ -48,9 +48,9 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: curl-devel
-# For tests
-BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-json
+BuildRequires: %{?scl_prefix}php-curl
+# For tests
BuildRequires: %{?scl_prefix}php-posix
#BuildRequires: gdb
#BuildRequires: %%{?scl_prefix}php-debuginfo
@@ -59,6 +59,7 @@ BuildRequires: %{?scl_prefix}php-posix
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+Requires: %{?scl_prefix}php-json%{?_isa}
%if "%{php_version}" > "8.0"
Requires: %{?scl_prefix}php-curl%{?_isa}
%endif
@@ -110,7 +111,6 @@ sed -e 's:@php_dir@:%{pear_phpdir}:' \
-i ext/php?/ddtrace.c \
ext/php?/configuration.h
-cp ext/vendor/mpack/LICENSE LICENSE.mpack
: Sanity check, really often broken
extver=$(sed -n '/#define PHP_DDTRACE_VERSION /{s/.* "//;s/".*$//;p}' ext/version.h)
if test "x${extver}" != "x%{version}"; then
@@ -204,7 +204,7 @@ MOD="-n -d ddtrace.request_init_hook="
%else
[ -f %{php_extdir}/curl.so ] && MOD="$MOD -d extension=curl.so"
%endif
-[ -f %{php_extdir}/json.so ] && MOD="$MOD -d extension=json.so"
+[ -f %{php_extdir}/json.so ] && DEP="$DEP -d extension=json.so"
[ -f %{php_extdir}/posix.so ] && MOD="$MOD -d extension=posix.so"
cd NTS
@@ -225,12 +225,6 @@ cd ../ZTS
%{__ztsphp} --no-php-ini $DEP \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep -i '^%{pecl_name}$'
-
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="$DEP $MOD -d extension=$PWD/modules/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -271,6 +265,9 @@ fi
%changelog
+* Thu Dec 23 2021 Remi Collet <remi@remirepo.net> - 0.68.0-1
+- update to 0.68.0
+
* Tue Nov 2 2021 Remi Collet <remi@remirepo.net> - 0.67.0-1
- update to 0.67.0