summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-08-30 17:55:31 +0200
committerRemi Collet <remi@php.net>2024-08-30 17:55:31 +0200
commit148294fdaffb831da7213216bbe432d8f7c2ade8 (patch)
tree17375d4aa4c9a315bb2fb79b1dada3c66333fe09
parent9cb270ddf55fd5c5ed391eca8f41e46ddf3fb358 (diff)
update to 1.3.0
open https://github.com/DataDog/dd-trace-php/issues/2825 offline build
-rw-r--r--PHPINFO24
-rw-r--r--REFLECTION116
-rw-r--r--php-pecl-datadog-trace.spec8
3 files changed, 134 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index 782cd21..ab5d236 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -7,14 +7,14 @@ For help, check out the documentation at https://docs.datadoghq.com/tracing/lang
(c) Datadog 2020
Datadog tracing support => disabled
-Version => 1.2.0
+Version => 1.3.0
DATADOG TRACER CONFIGURATION => {
- "date": "2024-07-24T05:35:13Z",
- "os_name": "Linux builder.remirepo.net 6.9.9-100.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Thu Jul 11 19:26:10 UTC 2024 x86_64",
- "os_version": "6.9.9-100.fc39.x86_64",
- "version": "1.2.0",
+ "date": "2024-08-30T13:35:29Z",
+ "os_name": "Linux builder.remirepo.net 6.10.6-100.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Mon Aug 19 14:35:32 UTC 2024 x86_64",
+ "os_version": "6.10.6-100.fc39.x86_64",
+ "version": "1.3.0",
"lang": "php",
- "lang_version": "8.2.21",
+ "lang_version": "8.2.23",
"env": null,
"enabled": true,
"service": null,
@@ -85,7 +85,10 @@ datadog.trace.memory_limit => no value => no value
datadog.trace.report_hostname => Off => Off
datadog.trace.flush_collect_cycles => Off => Off
datadog.trace.laravel_queue_distributed_tracing => On => On
+datadog.trace.symfony_messenger_distributed_tracing => On => On
+datadog.trace.symfony_messenger_middlewares => Off => Off
datadog.trace.remove_root_span_laravel_queue => On => On
+datadog.trace.remove_root_span_symfony_messenger => On => On
datadog.trace.remove_autoinstrumentation_orphans => Off => Off
datadog.trace.resource_uri_fragment_regex => no value => no value
datadog.trace.resource_uri_mapping_incoming => no value => no value
@@ -112,7 +115,7 @@ datadog.trace.traced_internal_functions => no value => no value
datadog.trace.agent_timeout => 500 => 500
datadog.trace.agent_connect_timeout => 100 => 100
datadog.trace.debug_prng_seed => -1 => -1
-datadog.log_backtrace => Off => Off
+datadog.log_backtrace => On => On
datadog.trace.generate_root_span => On => On
datadog.trace.spans_limit => 1000 => 1000
datadog.trace.128_bit_traceid_generation_enabled => On => On
@@ -143,6 +146,7 @@ datadog.trace.buffer_size => 2097152 => 2097152
datadog.trace.agent_max_payload_size => 52428800 => 52428800
datadog.trace.agent_stack_initial_size => 131072 => 131072
datadog.trace.agent_stack_backlog => 12 => 12
+datadog.trace.agent_test_session_token => no value => no value
datadog.trace.propagate_user_id_default => Off => Off
datadog.dbm_propagation_mode => disabled => disabled
datadog.trace.wordpress_additional_actions => no value => no value
@@ -152,6 +156,7 @@ datadog.trace.otel_enabled => Off => Off
datadog.trace.log_file => no value => no value
datadog.trace.log_level => error => error
datadog.appsec.sca_enabled => Off => Off
+datadog.appsec.testing => Off => Off
datadog.trace.git_metadata_enabled => On => On
datadog.git_commit_sha => no value => no value
datadog.git_repository_url => no value => no value
@@ -327,6 +332,11 @@ datadog.trace.symfony_analytics_enabled => Off => Off
datadog.symfony_analytics_enabled => Off => Off
datadog.trace.symfony_analytics_sample_rate => 1 => 1
datadog.symfony_analytics_sample_rate => 1 => 1
+datadog.trace.symfonymessenger_enabled => On => On
+datadog.trace.symfonymessenger_analytics_enabled => Off => Off
+datadog.symfonymessenger_analytics_enabled => Off => Off
+datadog.trace.symfonymessenger_analytics_sample_rate => 1 => 1
+datadog.symfonymessenger_analytics_sample_rate => 1 => 1
datadog.trace.web_enabled => On => On
datadog.trace.web_analytics_enabled => Off => Off
datadog.web_analytics_enabled => Off => Off
diff --git a/REFLECTION b/REFLECTION
index af2a304..4b926c0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
+Extension [ <persistent> extension #115 ddtrace version 1.3.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -115,9 +115,18 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
Entry [ datadog.trace.laravel_queue_distributed_tracing <ALL> ]
Current = 'true'
}
+ Entry [ datadog.trace.symfony_messenger_distributed_tracing <ALL> ]
+ Current = 'true'
+ }
+ Entry [ datadog.trace.symfony_messenger_middlewares <ALL> ]
+ Current = 'false'
+ }
Entry [ datadog.trace.remove_root_span_laravel_queue <ALL> ]
Current = 'true'
}
+ Entry [ datadog.trace.remove_root_span_symfony_messenger <ALL> ]
+ Current = 'true'
+ }
Entry [ datadog.trace.remove_autoinstrumentation_orphans <ALL> ]
Current = 'false'
}
@@ -197,7 +206,7 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
Current = '-1'
}
Entry [ datadog.log_backtrace <ALL> ]
- Current = 'false'
+ Current = 'true'
}
Entry [ datadog.trace.generate_root_span <ALL> ]
Current = 'true'
@@ -289,6 +298,9 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
Entry [ datadog.trace.agent_stack_backlog <SYSTEM> ]
Current = '12'
}
+ Entry [ datadog.trace.agent_test_session_token <ALL> ]
+ Current = ''
+ }
Entry [ datadog.trace.propagate_user_id_default <ALL> ]
Current = 'false'
}
@@ -316,6 +328,9 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
Entry [ datadog.appsec.sca_enabled <SYSTEM> ]
Current = 'false'
}
+ Entry [ datadog.appsec.testing <ALL> ]
+ Current = 'false'
+ }
Entry [ datadog.trace.git_metadata_enabled <ALL> ]
Current = 'true'
}
@@ -841,6 +856,21 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
Entry [ datadog.symfony_analytics_sample_rate <ALL> ]
Current = '1'
}
+ Entry [ datadog.trace.symfonymessenger_enabled <ALL> ]
+ Current = 'true'
+ }
+ Entry [ datadog.trace.symfonymessenger_analytics_enabled <ALL> ]
+ Current = '0'
+ }
+ Entry [ datadog.symfonymessenger_analytics_enabled <ALL> ]
+ Current = '0'
+ }
+ Entry [ datadog.trace.symfonymessenger_analytics_sample_rate <ALL> ]
+ Current = '1'
+ }
+ Entry [ datadog.symfonymessenger_analytics_sample_rate <ALL> ]
+ Current = '1'
+ }
Entry [ datadog.trace.web_enabled <ALL> ]
Current = 'true'
}
@@ -911,7 +941,7 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
Constant [ int DDTrace\DBM_PROPAGATION_FULL ] { 2 }
Constant [ int DDTrace\Internal\SPAN_FLAG_OPENTELEMETRY ] { 1 }
Constant [ int DDTrace\Internal\SPAN_FLAG_OPENTRACING ] { 2 }
- Constant [ string DD_TRACE_VERSION ] { 1.2.0 }
+ Constant [ string DD_TRACE_VERSION ] { 1.3.0 }
Constant [ int DD_TRACE_PRIORITY_SAMPLING_AUTO_KEEP ] { 1 }
Constant [ int DD_TRACE_PRIORITY_SAMPLING_AUTO_REJECT ] { 0 }
Constant [ int DD_TRACE_PRIORITY_SAMPLING_USER_KEEP ] { 2 }
@@ -1460,7 +1490,7 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
}
}
- - Classes [9] {
+ - Classes [11] {
Class [ <internal:ddtrace> class DDTrace\HookData ] {
- Constants [0] {
@@ -1592,7 +1622,7 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
- Static methods [0] {
}
- - Properties [15] {
+ - Properties [16] {
Property [ public ?string $name = '' ]
Property [ public ?string $resource = '' ]
Property [ public ?string $service = '' ]
@@ -1605,6 +1635,7 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
Property [ public ?Throwable $exception = NULL ]
Property [ public readonly string $id ]
Property [ public array $links = [] ]
+ Property [ public array $events = [] ]
Property [ public array $peerServiceSources = [] ]
Property [ public readonly ?DDTrace\SpanData $parent ]
Property [ public readonly DDTrace\SpanStack $stack ]
@@ -1652,7 +1683,7 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
- Static methods [0] {
}
- - Properties [24] {
+ - Properties [25] {
Property [ public ?string $name = '' ]
Property [ public ?string $resource = '' ]
Property [ public ?string $service = '' ]
@@ -1665,6 +1696,7 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
Property [ public ?Throwable $exception = NULL ]
Property [ public readonly string $id ]
Property [ public array $links = [] ]
+ Property [ public array $events = [] ]
Property [ public array $peerServiceSources = [] ]
Property [ public readonly ?DDTrace\SpanData $parent ]
Property [ public readonly DDTrace\SpanStack $stack ]
@@ -1885,6 +1917,78 @@ Extension [ <persistent> extension #109 ddtrace version 1.2.0 ] {
}
}
+ Class [ <internal:ddtrace> class DDTrace\SpanEvent implements JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ public string $name ]
+ Property [ public array $attributes ]
+ Property [ public int $timestamp ]
+ }
+
+ - Methods [2] {
+ Method [ <internal:ddtrace, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <optional> array $attributes = [] ]
+ Parameter #2 [ <optional> ?int $timestamp = null ]
+ }
+ }
+
+ Method [ <internal:ddtrace, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+ }
+ }
+
+ Class [ <internal:ddtrace> class DDTrace\ExceptionSpanEvent extends DDTrace\SpanEvent implements JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ public string $name ]
+ Property [ public array $attributes ]
+ Property [ public int $timestamp ]
+ Property [ public Throwable $exception ]
+ }
+
+ - Methods [2] {
+ Method [ <internal:ddtrace, overwrites DDTrace\SpanEvent, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Throwable $exception ]
+ Parameter #1 [ <optional> array $attributes = [] ]
+ }
+ }
+
+ Method [ <internal:ddtrace, inherits DDTrace\SpanEvent, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+ }
+ }
+
Class [ <internal:ddtrace> class DDTrace\GitMetadata ] {
- Constants [0] {
diff --git a/php-pecl-datadog-trace.spec b/php-pecl-datadog-trace.spec
index d39abb1..05e74ae 100644
--- a/php-pecl-datadog-trace.spec
+++ b/php-pecl-datadog-trace.spec
@@ -13,6 +13,8 @@
%global _root_bindir %{_bindir}
%endif
+# NOTICE: mock may requires --enable-network --cleanup-after
+
# to much issues with test suite and parallel builds
%bcond_with tests
@@ -28,7 +30,7 @@
# extension name
%global pecl_name ddtrace
-%global upstream_version 1.2.0
+%global upstream_version 1.3.0
#global upstream_prever beta1
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
@@ -278,6 +280,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Aug 30 2024 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+- open https://github.com/DataDog/dd-trace-php/issues/2825 offline build
+
* Wed Jul 24 2024 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0