summaryrefslogtreecommitdiffstats
path: root/php-pecl-csv.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-csv.spec')
-rw-r--r--php-pecl-csv.spec22
1 files changed, 9 insertions, 13 deletions
diff --git a/php-pecl-csv.spec b/php-pecl-csv.spec
index 898f03d..88d0e77 100644
--- a/php-pecl-csv.spec
+++ b/php-pecl-csv.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-csv
#
-# Copyright (c) 2020 Remi Collet
+# Copyright (c) 2020-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -21,16 +21,15 @@
Summary: CSV PHP extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.3.1
+Version: 0.3.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{proj_name}
Source0: https://pecl.php.net/get/%{proj_name}-%{version}.tgz
-Patch0: 0001-fix-c89.patch
-
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.3
+BuildRequires: %{?scl_prefix}php-devel >= 7.3
+BuildRequires: %{?scl_prefix}php-devel < 8
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -84,8 +83,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
find . -type f -exec chmod -x {} \;
-%patch0 -p1 -b .pr2
-
: Sanity check, really often broken
extver=$(sed -n '/# define PHP_CSV_VERSION /{s/.* "//;s/".*$//;p}' php_csv.h)
if test "x${extver}" != "x%{version}"; then
@@ -159,9 +156,7 @@ cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff
+%{_bindir}/php -n run-tests.php -q --show-diff
%if %{with_zts}
cd ../ZTS
@@ -173,9 +168,7 @@ cd ../ZTS
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -214,6 +207,9 @@ fi
%changelog
+* Wed Jun 1 2022 Remi Collet <remi@remirepo.net> - 0.3.2-1
+- update to 0.3.2
+
* Thu Mar 5 2020 Remi Collet <remi@remirepo.net> - 0.3.1-1
- update to 0.3.1