summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-01 07:38:52 +0200
committerRemi Collet <remi@php.net>2022-06-01 07:38:52 +0200
commit4e7193ae269a9202a3d660ea270ad3920cce3858 (patch)
tree42a54f3e681816a04b3fb2853b979cec346b8473
parent3f06d7b3662b616c28ec77ed9279575a33201abd (diff)
update to 0.4.2
-rw-r--r--0001-fix-c89.patch33
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-csv.spec21
4 files changed, 9 insertions, 49 deletions
diff --git a/0001-fix-c89.patch b/0001-fix-c89.patch
deleted file mode 100644
index d5ba611..0000000
--- a/0001-fix-c89.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 9085a7d766983a4d3aa9172a64b0e79c9cb01ae5 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 4 Mar 2020 08:49:20 +0100
-Subject: [PATCH] fix c89
-
----
- csv.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/csv.c b/csv.c
-index 0ed90d3..77263b6 100644
---- a/csv.c
-+++ b/csv.c
-@@ -226,6 +226,7 @@ static HashTable* rfc4180_string_to_hashtable(
- char **buffer, const size_t length, const zend_string *delimiter,
- const zend_string *enclosure, const zend_string *eol_sequence)
- {
-+ size_t index;
- HashTable *return_value = zend_new_array(8);
-
- bool in_escaped_field = false;
-@@ -237,7 +238,7 @@ static HashTable* rfc4180_string_to_hashtable(
- size_t field_value_length = 0;
-
- /* Main loop to "tokenize" the row */
-- for (size_t index = 0; index < length; ++index) {
-+ for (index = 0; index < length; ++index) {
- /* Check for field escape sequence (i.e. enclosure) */
- if (php_memnstr(row, ZSTR_VAL(enclosure), ZSTR_LEN(enclosure), row + ZSTR_LEN(enclosure))) {
- row += ZSTR_LEN(enclosure);
---
-2.24.1
-
diff --git a/PHPINFO b/PHPINFO
index 5ad8912..0449842 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
csv
CSV support => enabled
-Version => 0.4.1
+Version => 0.4.2
Author => George Peter Banyard
Bug reports => https://gitlab.com/Girgias/csv-php-extension/issues
Sponsor me => https://github.com/sponsors/Girgias
diff --git a/REFLECTION b/REFLECTION
index f1afc73..23a2ea3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #73 csv version 0.4.1 ] {
+Extension [ <persistent> extension #72 csv version 0.4.2 ] {
- Classes [1] {
Class [ <internal:csv> final class CSV ] {
diff --git a/php-pecl-csv.spec b/php-pecl-csv.spec
index 4419cc4..fc05e64 100644
--- a/php-pecl-csv.spec
+++ b/php-pecl-csv.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-csv
#
-# Copyright (c) 2020-2021 Remi Collet
+# Copyright (c) 2020-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -21,14 +21,12 @@
Summary: CSV PHP extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.4.1
+Version: 0.4.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{proj_name}
Source0: https://pecl.php.net/get/%{proj_name}-%{version}.tgz
-Patch0: 0001-fix-c89.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
@@ -81,8 +79,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
find . -type f -exec chmod -x {} \;
-%patch0 -p1 -b .pr2
-
: Sanity check, really often broken
extver=$(sed -n '/# define PHP_CSV_VERSION /{s/.* "//;s/".*$//;p}' php_csv.h)
if test "x${extver}" != "x%{version}"; then
@@ -154,11 +150,8 @@ cd NTS
--modules | grep -i '^%{pecl_name}$'
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff
+%{_bindir}/php -n run-tests.php -q --show-diff
%if %{with_zts}
cd ../ZTS
@@ -168,11 +161,8 @@ cd ../ZTS
--modules | grep -i '^%{pecl_name}$'
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -211,6 +201,9 @@ fi
%changelog
+* Wed Jun 1 2022 Remi Collet <remi@remirepo.net> - 0.4.2-1
+- update to 0.4.2
+
* Mon Sep 6 2021 Remi Collet <remi@remirepo.net> - 0.4.1-1
- update to 0.4.1