summaryrefslogtreecommitdiffstats
path: root/php-pecl-couchbase4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-31 14:06:59 +0200
committerRemi Collet <remi@php.net>2023-08-31 14:06:59 +0200
commitaa4f4eaf8b52607c434302899e3e0be5d06bdf16 (patch)
treec8f4818ceef2f5b4afcbd1c302d1bc90c5732f06 /php-pecl-couchbase4.spec
parent07a67bde3e62aa58eb137358b3d5f385c4d4d044 (diff)
add patch for PHP 8.3 from
https://github.com/couchbase/couchbase-php-client/pull/130
Diffstat (limited to 'php-pecl-couchbase4.spec')
-rw-r--r--php-pecl-couchbase4.spec44
1 files changed, 25 insertions, 19 deletions
diff --git a/php-pecl-couchbase4.spec b/php-pecl-couchbase4.spec
index d6190c9..8634d13 100644
--- a/php-pecl-couchbase4.spec
+++ b/php-pecl-couchbase4.spec
@@ -9,27 +9,25 @@
# NOTICE: el-7 is not supported because of OpenSSL 1.0
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
# Disable RPATH check
%global __arch_install_post /bin/true
%global __brp_check_rpaths /bin/true
-%if 0%{?scl:1}
-%scl_package php-pecl-couchbase2
-%endif
+%{?scl:%scl_package php-pecl-couchbase2}
-%global pecl_name couchbase
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name couchbase
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# After 20-tokenizer.ini, 40-igbinary and 40-json
-%global ini_name 50-%{pecl_name}.ini
-#global prever beta4
+%global ini_name 50-%{pecl_name}.ini
+#global prever beta4
+%global sources %{pecl_name}-%{version}%{?prever}
+%global _configure ../%{sources}/configure
+
Summary: Couchbase Server PHP extension
Name: %{?scl_prefix}php-pecl-couchbase4
-Version: 4.1.4
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 4.1.5
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Apache-2.0
# src
# third_party/json/LICENSE.ryu
@@ -50,7 +48,9 @@ Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_V
# third_party/spdlog/LICENSE
License: Apache-2.0 AND BSD-3-Clause AND BSD-2-Clause AND MIT
URL: https://pecl.php.net/package/couchbase
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+Patch0: 0001-zend_bool-was-removed-from-8.3.patch
BuildRequires: make
BuildRequires: cmake >= 3.17
@@ -67,7 +67,6 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-tokenizer%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -117,7 +116,9 @@ sed -e '/LICENSE/s/role="doc"/role="src"/;/COPYING/s/role="doc"/role="src"/' -i
: Collect license files
mkdir lic
-cd %{pecl_name}-%{version}%{?prever}
+cd %{sources}
+%patch -P0 -p1 -b .php83
+
cp src/deps/couchbase-cxx-client/third_party/hdr_histogram_c/COPYING.txt ../lic/hdr_histogram_c_COPYING.txt
cp src/deps/couchbase-cxx-client/third_party/snappy/COPYING ../lic/snappy_COPYING
cp src/deps/couchbase-cxx-client/third_party/fmt/LICENSE.rst ../lic/fmt_LICENSE.rst
@@ -170,12 +171,10 @@ mkdir ZTS
%endif
-%global _configure ../%{pecl_name}-%{version}%{?prever}/configure
-
%build
%{?dtsenable}
-cd %{pecl_name}-%{version}%{?prever}
+cd %{sources}
%{__phpize}
cd ../NTS
@@ -206,7 +205,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
# Test & Documentation
-cd %{pecl_name}-%{version}%{?prever}
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -246,6 +245,13 @@ done
%changelog
+* Thu Aug 31 2023 Remi Collet <remi@remirepo.net> - 4.1.5-2
+- add patch for PHP 8.3 from
+ https://github.com/couchbase/couchbase-php-client/pull/130
+
+* Mon Aug 21 2023 Remi Collet <remi@remirepo.net> - 4.1.5-1
+- update to 4.1.5
+
* Fri May 26 2023 Remi Collet <remi@remirepo.net> - 4.1.4-1
- update to 4.1.4