summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-04-13 19:23:04 +0200
committerRemi Collet <remi@php.net>2023-04-13 19:23:04 +0200
commited3165602fd2f4cc338828206bd9d8035c64e486 (patch)
tree293e631740871b6175f354b170385389860192eb
parent3ba263fbb08e213b911e2b51fe057e7872f913bf (diff)
update to 4.1.3
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION46
-rw-r--r--php-pecl-couchbase4.spec40
3 files changed, 57 insertions, 35 deletions
diff --git a/PHPINFO b/PHPINFO
index adff944..15eb470 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase => enabled
-couchbase_extension_version => 4.1.2
-couchbase_extension_revision => 3886e668d3a159a7d6563a6d97964ca5b3e56eb7
-couchbase_client_revision => b1b5a6fb03ec6e82a9a55e029fae0926c0b20203
+couchbase_extension_version => 4.1.3
+couchbase_extension_revision => 8963a0976d75eccb894dc3d30265d787b2cd53a8
+couchbase_client_revision => 98af5a9a2169c9bba284d3cb1e839b6f5e54c3b8
Directive => Local Value => Master Value
couchbase.max_persistent => -1 => -1
diff --git a/REFLECTION b/REFLECTION
index da4548a..6f9c15f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 couchbase version 4.1.2 ] {
+Extension [ <persistent> extension #122 couchbase version 4.1.3 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -506,6 +506,50 @@ Extension [ <persistent> extension #121 couchbase version 4.1.2 ] {
Parameter #2 [ <optional> ?array $options = <default> ]
}
}
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeGetAll ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $name ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeCreate ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeDrop ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\collectionCreate ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> array $collectionSpec ]
+ Parameter #3 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\collectionDrop ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> array $collectionSpec ]
+ Parameter #3 [ <optional> ?array $options = <default> ]
+ }
+ }
Function [ <internal:couchbase> function Couchbase\Extension\userUpsert ] {
- Parameters [3] {
diff --git a/php-pecl-couchbase4.spec b/php-pecl-couchbase4.spec
index 3868977..e159b46 100644
--- a/php-pecl-couchbase4.spec
+++ b/php-pecl-couchbase4.spec
@@ -7,6 +7,8 @@
# Please, preserve the changelog entries
#
+# NOTICE: el-7 is not supported because of OpenSSL 1.0
+
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
@@ -26,8 +28,8 @@
Summary: Couchbase Server PHP extension
Name: %{?scl_prefix}php-pecl-couchbase4
-Version: 4.1.2
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 4.1.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Apache-2.0
# src
# third_party/json/LICENSE.ryu
@@ -51,11 +53,7 @@ URL: https://pecl.php.net/package/couchbase
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: make
-%if 0%{?rhel} == 7
-BuildRequires: cmake3 >= 3.17
-%else
BuildRequires: cmake >= 3.17
-%endif
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?scl_prefix}php-devel >= 8.0
@@ -115,7 +113,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/;/COPYING/s/role="doc"/role="src"/' -i package.xml}
+sed -e '/LICENSE/s/role="doc"/role="src"/;/COPYING/s/role="doc"/role="src"/' -i package.xml
: Collect license files
mkdir lic
@@ -135,12 +133,9 @@ cp src/deps/couchbase-cxx-client/third_party/jsonsl/LICENSE ../l
cp src/deps/couchbase-cxx-client/third_party/spdlog/LICENSE ../lic/spdlog_LICENSE
cp src/deps/couchbase-cxx-client/LICENSE.txt ../lic/LICENSE.txt
-%if 0%{?rhel} == 7
-: Switch to cmake3
-sed -e 's/cmake/cmake3/' -i config.m4
-%endif
: Build wrapper only once
sed -e 's:/cmake-build:/../cmake-build:' -i config.m4
+
: Parallel build
sed -e 's/--verbose/%{?_smp_mflags} --verbose/' -i Makefile.frag
@@ -232,27 +227,7 @@ done
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{!?_licensedir:%global license %%doc}
%license lic/*
%{pecl_xmldir}/%{name}.xml
@@ -269,6 +244,9 @@ fi
%changelog
+* Thu Apr 13 2023 Remi Collet <remi@remirepo.net> - 4.1.3-1
+- update to 4.1.3
+
* Wed Mar 22 2023 Remi Collet <remi@remirepo.net> - 4.1.2-2
- build out of sources tree