summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-19 11:10:06 +0100
committerRemi Collet <remi@php.net>2024-03-19 11:10:06 +0100
commit0fcdf4c59afef2bc0ed0c1c269298679e8f11a4f (patch)
tree5d63593de29910c39474783399c2d01e3b3e659a
parent5cb1cb657a5475a6b79546f4615cfdc02258f6e5 (diff)
update to 4.2.0
raise dependency on PHP 8.1 not buildable offline, reported upstream
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION335
-rw-r--r--php-pecl-couchbase4.spec90
3 files changed, 381 insertions, 50 deletions
diff --git a/PHPINFO b/PHPINFO
index 6ca88ed..2385558 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase => enabled
-couchbase_extension_version => 4.1.6
-couchbase_extension_revision => dac7e56a90346c16e2d9738bf8e7180ddf165bb9
-couchbase_client_revision => a873bb91aa487fab8acd3b619355b911b1588fc1
+couchbase_extension_version => 4.2.0
+couchbase_extension_revision => 4807e92e003f4eb1fbb32be7b30cb15ba5a15c56
+couchbase_client_revision => 933e87eeab58b0a3f063fc12d93b443eea39cca7
Directive => Local Value => Master Value
couchbase.max_persistent => -1 => -1
diff --git a/REFLECTION b/REFLECTION
index e48e143..36aca5a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #126 couchbase version 4.1.6 ] {
+Extension [ <persistent> extension #91 couchbase version 4.2.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -390,6 +390,17 @@ Extension [ <persistent> extension #126 couchbase version 4.1.6 ] {
Parameter #3 [ <optional> ?array $options = <default> ]
}
}
+ Function [ <internal:couchbase> function Couchbase\Extension\vectorSearch ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $indexName ]
+ Parameter #2 [ <required> string $query ]
+ Parameter #3 [ <required> string $vector_search ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ Parameter #5 [ <optional> ?array $vector_options = <default> ]
+ }
+ }
Function [ <internal:couchbase> function Couchbase\Extension\ping ] {
- Parameters [2] {
@@ -579,6 +590,126 @@ Extension [ <persistent> extension #126 couchbase version 4.1.6 ] {
Parameter #3 [ <optional> ?array $options = <default> ]
}
}
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexGet ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexGetAll ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexUpsert ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> array $index ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexDrop ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexGetDocumentsCount ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexIngestPause ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexIngestResume ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexQueryingAllow ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexQueryingDisallow ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexPlanFreeze ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexPlanUnfreeze ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\scopeSearchIndexDocumentAnalyze ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $bucketName ]
+ Parameter #2 [ <required> string $scopeName ]
+ Parameter #3 [ <required> string $indexName ]
+ Parameter #4 [ <required> string $document ]
+ Parameter #5 [ <optional> ?array $options = <default> ]
+ }
+ }
Function [ <internal:couchbase> function Couchbase\Extension\viewIndexUpsert ] {
- Parameters [5] {
@@ -887,7 +1018,7 @@ Extension [ <persistent> extension #126 couchbase version 4.1.6 ] {
}
}
- - Classes [73] {
+ - Classes [75] {
Class [ <internal:couchbase> class Couchbase\Exception\CouchbaseException extends Exception implements Throwable, Stringable ] {
- Constants [0] {
@@ -3289,6 +3420,106 @@ Extension [ <persistent> extension #126 couchbase version 4.1.6 ] {
}
}
+ Class [ <internal:couchbase> class Couchbase\Exception\DocumentNotLockedException extends Couchbase\Exception\CouchbaseException implements Stringable, Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
+ }
+
+ - Methods [11] {
+ Method [ <internal:couchbase, inherits Couchbase\Exception\CouchbaseException> public method getContext ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\Exception\CouchbaseException, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
+ Parameter #3 [ <optional> ?array $context = null ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
Class [ <internal:couchbase> class Couchbase\Exception\DocumentNotJsonException extends Couchbase\Exception\CouchbaseException implements Stringable, Throwable ] {
- Constants [0] {
@@ -5889,6 +6120,106 @@ Extension [ <persistent> extension #126 couchbase version 4.1.6 ] {
}
}
+ Class [ <internal:couchbase> class Couchbase\Exception\PermissionDeniedException extends Couchbase\Exception\CouchbaseException implements Stringable, Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
+ }
+
+ - Methods [11] {
+ Method [ <internal:couchbase, inherits Couchbase\Exception\CouchbaseException> public method getContext ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\Exception\CouchbaseException, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
+ Parameter #3 [ <optional> ?array $context = null ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
Class [ <internal:couchbase> class Couchbase\Exception\PlanningFailureException extends Couchbase\Exception\CouchbaseException implements Stringable, Throwable ] {
- Constants [0] {
diff --git a/php-pecl-couchbase4.spec b/php-pecl-couchbase4.spec
index bf4f960..0c958ce 100644
--- a/php-pecl-couchbase4.spec
+++ b/php-pecl-couchbase4.spec
@@ -1,20 +1,20 @@
# remirepo spec file for php-pecl-couchbase4
#
-# Copyright (c) 2013-2023 Remi Collet
+# Copyright (c) 2013-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# NOTICE: el-7 is not supported (OpenSSL 1.0)
-# build in 2 QUEUES max (tmpfs size)
+# NOTICE: el-7 is not supported (cmake 3.19)
+# mock requires --enable-network
# Disable RPATH check
%global __arch_install_post /bin/true
%global __brp_check_rpaths /bin/true
-%{?scl:%scl_package php-pecl-couchbase2}
+%{?scl:%scl_package php-pecl-couchbase4}
%global pecl_name couchbase
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -27,40 +27,43 @@
Summary: Couchbase Server PHP extension
Name: %{?scl_prefix}php-pecl-couchbase4
-Version: 4.1.6
+Version: 4.2.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Apache-2.0
# src
-# third_party/json/LICENSE.ryu
+# src/deps/cache/json/LICENSE.ryu
+# src/deps/cache/boringssl
+## BOOST
+# asio/asio/include/asio.hpp
## BSD-3-Clause
-# third_party/snappy/COPYING
-# third_party/json/LICENSE.double-conversion
+# src/deps/cache/snappy/COPYING
+# src/deps/cache/json/LICENSE.double-conversion
## BSD-2-Clause
-# third_party/hdr_histogram_c/LICENSE.txt
-# third_party/hdr_histogram_c/COPYING.txt
+# src/deps/cache/hdr_histogram_c/LICENSE.txt
+# src/deps/cache/hdr_histogram_c/COPYING.txt
## MIT
-# third_party/fmt/LICENSE.rst
-# third_party/gsl/LICENSE
-# third_party/http_parser/LICENSE-MIT
-# third_party/json/external/PEGTL/LICENSE
-# third_party/json/LICENSE
-# third_party/json/LICENSE.itoa
-# third_party/jsonsl/LICENSE
-# third_party/spdlog/LICENSE
-License: Apache-2.0 AND BSD-3-Clause AND BSD-2-Clause AND MIT
+# src/cpm
+# src/deps/cache/fmt/LICENSE.rst
+# src/deps/cache/gsl/LICENSE
+# src/deps/cache/llhttp/LICENSE-MIT
+# src/deps/cache/json/external/PEGTL/LICENSE
+# src/deps/cache/json/LICENSE
+# src/deps/cache/json/LICENSE.itoa
+# src/deps/cache/spdlog/LICENSE
+License: Apache-2.0 AND BSD-3-Clause AND BSD-2-Clause AND MIT AND BSL-1.0
URL: https://pecl.php.net/package/couchbase
Source0: https://pecl.php.net/get/%{sources}.tgz
+BuildRequires: git
BuildRequires: make
-BuildRequires: cmake >= 3.17
+BuildRequires: cmake >= 3.19
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel >= 8.0
+BuildRequires: %{?scl_prefix}php-devel >= 8.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-tokenizer
BuildRequires: zlib-devel
-BuildRequires: openssl-devel >= 1:1.1
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -93,7 +96,7 @@ Provides: bundled(fmt)
Provides: bundled(gsl)
Provides: bundled(http_parser)
Provides: bundled(json)
-Provides: bundled(jsonsl)
+Provides: bundled(boringssl)
Provides: bundled(spdlog)
@@ -116,30 +119,24 @@ sed -e '/LICENSE/s/role="doc"/role="src"/;/COPYING/s/role="doc"/role="src"/' -i
: Collect license files
mkdir lic
cd %{sources}
-cp src/deps/couchbase-cxx-client/third_party/hdr_histogram_c/COPYING.txt ../lic/hdr_histogram_c_COPYING.txt
-cp src/deps/couchbase-cxx-client/third_party/snappy/COPYING ../lic/snappy_COPYING
-cp src/deps/couchbase-cxx-client/third_party/fmt/LICENSE.rst ../lic/fmt_LICENSE.rst
-cp src/deps/couchbase-cxx-client/third_party/gsl/LICENSE ../lic/gsl_LICENSE
-cp src/deps/couchbase-cxx-client/third_party/hdr_histogram_c/LICENSE.txt ../lic/hdr_histogram_c_LICENSE.txt
-cp src/deps/couchbase-cxx-client/third_party/http_parser/LICENSE-MIT ../lic/http_parser_LICENSE-MIT
-cp src/deps/couchbase-cxx-client/third_party/json/external/PEGTL/LICENSE ../lic/PEGTL_LICENSE
-cp src/deps/couchbase-cxx-client/third_party/json/LICENSE ../lic/json_LICENSE
-cp src/deps/couchbase-cxx-client/third_party/json/LICENSE.double-conversion ../lic/json_LICENSE.double-conversion
-cp src/deps/couchbase-cxx-client/third_party/json/LICENSE.itoa ../lic/json_LICENSE.itoa
-cp src/deps/couchbase-cxx-client/third_party/json/LICENSE.ryu ../lic/json_LICENSE.ryu
-cp src/deps/couchbase-cxx-client/third_party/jsonsl/LICENSE ../lic/jsonsl_LICENSE
-cp src/deps/couchbase-cxx-client/third_party/spdlog/LICENSE ../lic/spdlog_LICENSE
-cp src/deps/couchbase-cxx-client/LICENSE.txt ../lic/LICENSE.txt
-
-: Build wrapper only once
-sed -e 's:/cmake-build:/../cmake-build:' -i config.m4
+cp src/deps/cache/hdr_histogram/*/hdr_histogram/COPYING.txt ../lic/hdr_histogram_c_COPYING.txt
+cp src/deps/cache/hdr_histogram/*/hdr_histogram/LICENSE.txt ../lic/hdr_histogram_c_LICENSE.txt
+cp src/deps/cache/snappy/*/snappy/COPYING ../lic/snappy_COPYING
+cp src/deps/cache/fmt/*/fmt/LICENSE.rst ../lic/fmt_LICENSE.rst
+cp src/deps/cache/gsl/*/gsl/LICENSE ../lic/gsl_LICENSE
+cp src/deps/cache/llhttp/*/llhttp/LICENSE-MIT ../lic/http_parser_LICENSE-MIT
+cp src/deps/cache/json/*/json/external/PEGTL/LICENSE ../lic/PEGTL_LICENSE
+cp src/deps/cache/json/*/json/LICENSE ../lic/json_LICENSE
+cp src/deps/cache/json/*/json/LICENSE.double-conversion ../lic/json_LICENSE.double-conversion
+cp src/deps/cache/json/*/json/LICENSE.itoa ../lic/json_LICENSE.itoa
+cp src/deps/cache/json/*/json/LICENSE.ryu ../lic/json_LICENSE.ryu
+cp src/deps/cache/spdlog/*/spdlog/LICENSE ../lic/spdlog_LICENSE
+cp src/deps/cache/boringssl/*/boringssl/LICENSE ../lic/boringssl_LICENSE
+cp src/deps/couchbase-cxx-client/LICENSE.txt ../lic/LICENSE.txt
: Parallel build
sed -e 's/--verbose/%{?_smp_mflags} --verbose/' -i Makefile.frag
-: Change option to avoid download
-sed -e '/Download/s/TRUE/FALSE/' -i src/deps/couchbase-cxx-client/cmake/OpenSSL.cmake
-
: Sanity check as really often broken
extver=$(sed -n '/#define PHP_COUCHBASE_VERSION/{s/.* "//;s/".*$//;p}' src/php_couchbase.hxx)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -232,16 +229,19 @@ done
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
-%{php_extdir}/libcouchbase_php_wrapper.so
%if %{with_zts}
%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
-%{php_ztsextdir}/libcouchbase_php_wrapper.so
%endif
%changelog
+* Tue Mar 19 2024 Remi Collet <remi@remirepo.net> - 4.2.0-1
+- update to 4.2.0
+- raise dependency on PHP 8.1
+- not buildable offline, reported upstream
+
* Wed Oct 11 2023 Remi Collet <remi@remirepo.net> - 4.1.6-1
- update to 4.1.6
- drop patch merged upstream