summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-09 06:36:32 +0100
committerRemi Collet <remi@php.net>2021-12-09 06:36:32 +0100
commita00af26728d4296cc651ba877fb374532cc5c807 (patch)
treeb246f43f9216c181b73adf58736a8218fb326b23
parent7cacb861c91c5aad7b7b99e397dc00b1764d9424 (diff)
update to 3.2.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION381
-rw-r--r--php-pecl-couchbase3.spec5
3 files changed, 372 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index cd40563..ea63575 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase support => enabled
-extension version => 3.2.1
+extension version => 3.2.2
libcouchbase runtime version => 3.2.4 (git: 38cc0708dfcc5a706c6b21dc80bcd84f05890225)
-libcouchbase headers version => 3.2.2 (git: fadbd4d1617df952457abfa9984d095015f1ca52)
+libcouchbase headers version => 3.2.4 (git: 38cc0708dfcc5a706c6b21dc80bcd84f05890225)
zlib compressor => enabled
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 33509ba..5da8066 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
+Extension [ <persistent> extension #119 couchbase version 3.2.2 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -31,7 +31,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
}
}
- - Constants [177] {
+ - Constants [179] {
Constant [ int COUCHBASE_PERSISTTO_MASTER ] { 1 }
Constant [ int COUCHBASE_PERSISTTO_ONE ] { 1 }
Constant [ int COUCHBASE_PERSISTTO_TWO ] { 2 }
@@ -73,6 +73,8 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Constant [ int COUCHBASE_ERR_SCOPE_NOT_FOUND ] { 217 }
Constant [ int COUCHBASE_ERR_INDEX_NOT_FOUND ] { 218 }
Constant [ int COUCHBASE_ERR_INDEX_EXISTS ] { 219 }
+ Constant [ int COUCHBASE_ERR_RATE_LIMITED ] { 220 }
+ Constant [ int COUCHBASE_ERR_QUOTA_LIMITED ] { 221 }
Constant [ int COUCHBASE_ERR_DOCUMENT_NOT_FOUND ] { 301 }
Constant [ int COUCHBASE_ERR_DOCUMENT_UNRETRIEVABLE ] { 302 }
Constant [ int COUCHBASE_ERR_DOCUMENT_LOCKED ] { 303 }
@@ -350,7 +352,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
}
}
- - Classes [237] {
+ - Classes [240] {
Interface [ <internal:couchbase> interface Couchbase\MutationToken ] {
- Constants [0] {
@@ -855,7 +857,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase> abstract public method content ] {
- Parameters [0] {
@@ -869,6 +871,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Return [ ?DateTimeInterface ]
}
+ Method [ <internal:couchbase> abstract public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
+
Method [ <internal:couchbase, inherits Couchbase\Result> abstract public method cas ] {
- Parameters [0] {
@@ -889,7 +898,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Static methods [0] {
}
- - Properties [8] {
+ - Properties [10] {
Property [ private $cas = NULL ]
Property [ private $data = NULL ]
Property [ private $expiry = NULL ]
@@ -897,10 +906,12 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Property [ private $status = NULL ]
Property [ private $err_ctx = NULL ]
Property [ private $err_ref = NULL ]
+ Property [ private $flags = NULL ]
+ Property [ private $datatype = NULL ]
Property [ private $decoder = NULL ]
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:couchbase, prototype Couchbase\Result> public method cas ] {
- Parameters [0] {
@@ -927,6 +938,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:couchbase, prototype Couchbase\GetResult> public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
}
}
@@ -1109,7 +1127,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [3] {
Method [ <internal:couchbase> abstract public method mutationToken ] {
- Parameters [0] {
@@ -1117,6 +1135,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Return [ ?Couchbase\MutationToken ]
}
+ Method [ <internal:couchbase> abstract public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
+
Method [ <internal:couchbase, inherits Couchbase\Result> abstract public method cas ] {
- Parameters [0] {
@@ -1147,7 +1172,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Property [ private $mutation_token = NULL ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase, prototype Couchbase\Result> public method cas ] {
- Parameters [0] {
@@ -1168,6 +1193,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
}
- Return [ ?Couchbase\MutationToken ]
}
+
+ Method [ <internal:couchbase, prototype Couchbase\MutationResult> public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
}
}
@@ -1195,7 +1227,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Property [ private $num_replicated = NULL ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase, prototype Couchbase\Result> public method cas ] {
- Parameters [0] {
@@ -1216,6 +1248,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
}
- Return [ ?Couchbase\MutationToken ]
}
+
+ Method [ <internal:couchbase, prototype Couchbase\MutationResult> public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
}
}
@@ -1233,7 +1272,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase> abstract public method content ] {
- Parameters [0] {
@@ -1248,6 +1287,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Return [ ?Couchbase\MutationToken ]
}
+ Method [ <internal:couchbase, inherits Couchbase\MutationResult> abstract public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
+
Method [ <internal:couchbase, inherits Couchbase\Result> abstract public method cas ] {
- Parameters [0] {
@@ -1279,7 +1325,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Property [ private $content = NULL ]
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:couchbase, prototype Couchbase\Result> public method cas ] {
- Parameters [0] {
@@ -1301,6 +1347,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Return [ ?Couchbase\MutationToken ]
}
+ Method [ <internal:couchbase, prototype Couchbase\MutationResult> public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
+
Method [ <internal:couchbase, prototype Couchbase\CounterResult> public method content ] {
- Parameters [0] {
@@ -1466,7 +1519,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase> abstract public method content ] {
- Parameters [1] {
@@ -1481,6 +1534,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Return [ ?Couchbase\MutationToken ]
}
+ Method [ <internal:couchbase, inherits Couchbase\MutationResult> abstract public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
+
Method [ <internal:couchbase, inherits Couchbase\Result> abstract public method cas ] {
- Parameters [0] {
@@ -1512,7 +1572,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Property [ private $data = NULL ]
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:couchbase, prototype Couchbase\Result> public method cas ] {
- Parameters [0] {
@@ -1547,6 +1607,13 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Parameter #0 [ <required> int $index ]
}
}
+
+ Method [ <internal:couchbase, prototype Couchbase\MutationResult> public method error ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Exception ]
+ }
}
}
@@ -7120,6 +7187,242 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
}
}
+ Class [ <internal:couchbase> class Couchbase\RateLimitedException extends Couchbase\BaseException implements Throwable, Stringable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
+ Property [ protected $ref = NULL ]
+ Property [ protected $context = NULL ]
+ Property [ protected $is_input = NULL ]
+ Property [ protected $is_network = NULL ]
+ Property [ protected $is_fatal = NULL ]
+ Property [ protected $is_transient = NULL ]
+ Property [ protected $is_data_operation = NULL ]
+ Property [ protected $is_internal = NULL ]
+ Property [ protected $is_plugin = NULL ]
+ Property [ protected $is_server_under_load = NULL ]
+ Property [ protected $is_server_generated = NULL ]
+ Property [ protected $is_subdoc = NULL ]
+ Property [ protected $is_durability = NULL ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?string ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?object ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\QuotaLimitedException extends Couchbase\BaseException implements Throwable, Stringable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
+ Property [ protected $ref = NULL ]
+ Property [ protected $context = NULL ]
+ Property [ protected $is_input = NULL ]
+ Property [ protected $is_network = NULL ]
+ Property [ protected $is_fatal = NULL ]
+ Property [ protected $is_transient = NULL ]
+ Property [ protected $is_data_operation = NULL ]
+ Property [ protected $is_internal = NULL ]
+ Property [ protected $is_plugin = NULL ]
+ Property [ protected $is_server_under_load = NULL ]
+ Property [ protected $is_server_generated = NULL ]
+ Property [ protected $is_subdoc = NULL ]
+ Property [ protected $is_durability = NULL ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?string ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?object ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
Class [ <internal:couchbase> class Couchbase\Cluster ] {
- Constants [0] {
@@ -7233,7 +7536,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Property [ private $name = NULL ]
}
- - Methods [17] {
+ - Methods [20] {
Method [ <internal:couchbase, ctor> public method __construct ] {
- Parameters [3] {
@@ -7385,6 +7688,33 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Return [ Couchbase\MutateInResult ]
}
+ Method [ <internal:couchbase> public method getMulti ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $ids ]
+ Parameter #1 [ <optional> ?Couchbase\GetOptions $options = <default> ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:couchbase> public method removeMulti ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $ids ]
+ Parameter #1 [ <optional> ?Couchbase\RemoveOptions $options = <default> ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:couchbase> public method upsertMulti ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $ids ]
+ Parameter #1 [ <optional> ?Couchbase\UpsertOptions $options = <default> ]
+ }
+ - Return [ array ]
+ }
+
Method [ <internal:couchbase> public method binary ] {
- Parameters [0] {
@@ -7585,7 +7915,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
- Static methods [0] {
}
- - Properties [10] {
+ - Properties [11] {
Property [ private $name = NULL ]
Property [ private $flush_enabled = NULL ]
Property [ private $ram_quota_mb = NULL ]
@@ -7595,6 +7925,7 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
Property [ private $eviction_policy = NULL ]
Property [ private $max_ttl = NULL ]
Property [ private $compression_mode = NULL ]
+ Property [ private $storage_backend = NULL ]
Property [ private $minimal_durability_level = NULL ]
}
@@ -7788,6 +8119,26 @@ Extension [ <persistent> extension #117 couchbase version 3.2.1 ] {
}
}
+ Interface [ <internal:couchbase> interface Couchbase\StorageBackend ] {
+
+ - Constants [2] {
+ Constant [ public string COUCHSTORE ] { couchstore }
+ Constant [ public string MAGMA ] { magma }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
Class [ <internal:couchbase> class Couchbase\UserManager ] {
- Constants [0] {
diff --git a/php-pecl-couchbase3.spec b/php-pecl-couchbase3.spec
index 928d1a7..5660c94 100644
--- a/php-pecl-couchbase3.spec
+++ b/php-pecl-couchbase3.spec
@@ -24,7 +24,7 @@
Summary: Couchbase Server PHP extension
Name: %{?scl_prefix}php-pecl-couchbase3
-Version: 3.2.1
+Version: 3.2.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/couchbase
@@ -239,6 +239,9 @@ fi
%changelog
+* Thu Dec 9 2021 Remi Collet <remi@remirepo.net> - 3.2.2-1
+- update to 3.2.2
+
* Thu Oct 14 2021 Remi Collet <remi@remirepo.net> - 3.2.1-1
- update to 3.2.1
- raise dependency on libcouchbase 3.2.2