summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-21 08:42:04 +0100
committerRemi Collet <remi@remirepo.net>2021-01-21 08:42:04 +0100
commit90b709fbf27bc0e083e4ca66c64d494c4d4926a7 (patch)
tree783c85a25cf363f05e982fc26847d41dad9dcef7
parentebc20abfebf7a2e4da368b76889736047413a1fd (diff)
update to 3.1.0
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION144
-rw-r--r--php-pecl-couchbase3.spec9
3 files changed, 132 insertions, 29 deletions
diff --git a/PHPINFO b/PHPINFO
index bf6e7e7..b8e1ac8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase support => enabled
-extension version => 3.0.5
-libcouchbase runtime version => 3.0.6 (git: e7b53f01b5c8653e4f4c3ea87e6e1af9c1277a34)
-libcouchbase headers version => 3.0.6 (git: e7b53f01b5c8653e4f4c3ea87e6e1af9c1277a34)
+extension version => 3.1.0
+libcouchbase runtime version => 3.0.7 (git: d2d3666e269b41413408aaae96eb289f1cb4f8ec)
+libcouchbase headers version => 3.0.7 (git: d2d3666e269b41413408aaae96eb289f1cb4f8ec)
zlib compressor => enabled
Directive => Local Value => Master Value
@@ -13,6 +13,6 @@ couchbase.encoder.format => json => json
couchbase.encoder.compression => off => off
couchbase.encoder.compression_threshold => 0 => 0
couchbase.encoder.compression_factor => 0.0 => 0.0
-couchbase.decoder.json_arrays => 0 => 0
+couchbase.decoder.json_arrays => 1 => 1
couchbase.pool.max_idle_time_sec => 60 => 60
couchbase.allow_fallback_to_bucket_connection => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 3f62614..ddc4d4c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
+Extension [ <persistent> extension #119 couchbase version 3.1.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -21,7 +21,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
Current = '0.0'
}
Entry [ couchbase.decoder.json_arrays <ALL> ]
- Current = '0'
+ Current = '1'
}
Entry [ couchbase.pool.max_idle_time_sec <ALL> ]
Current = '60'
@@ -887,7 +887,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [7] {
+ - Properties [8] {
Property [ <default> private $cas ]
Property [ <default> private $data ]
Property [ <default> private $expiry ]
@@ -895,6 +895,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
Property [ <default> private $status ]
Property [ <default> private $err_ctx ]
Property [ <default> private $err_ref ]
+ Property [ <default> private $decoder ]
}
- Methods [4] {
@@ -5399,7 +5400,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
Property [ <default> private $name ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase, ctor> public method __construct ] {
- Parameters [2] {
@@ -5422,6 +5423,15 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\Collection ]
}
+
+ Method [ <internal:couchbase> public method query ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $statement ]
+ Parameter #1 [ <optional> Couchbase\QueryOptions or NULL $queryOptions ]
+ }
+ - Return [ Couchbase\QueryResult ]
+ }
}
}
@@ -9476,13 +9486,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [4] {
Property [ <default> private $timeout ]
Property [ <default> private $with_expiry ]
Property [ <default> private $project ]
+ Property [ <default> private $decoder ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9506,6 +9517,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\GetOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetOptions ]
+ }
}
}
@@ -9520,11 +9539,12 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> private $timeout ]
+ Property [ <default> private $decoder ]
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9532,6 +9552,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\GetAndTouchOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetAndTouchOptions ]
+ }
}
}
@@ -9546,11 +9574,12 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> private $timeout ]
+ Property [ <default> private $decoder ]
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9558,6 +9587,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\GetAndLockOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetAndLockOptions ]
+ }
}
}
@@ -9572,11 +9609,12 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> private $timeout ]
+ Property [ <default> private $decoder ]
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9584,6 +9622,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\GetAllReplicasOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetAllReplicasOptions ]
+ }
}
}
@@ -9598,11 +9644,12 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> private $timeout ]
+ Property [ <default> private $decoder ]
}
- - Methods [1] {
+ - Methods [2] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9610,6 +9657,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\GetAnyReplicaOptions ]
}
+
+ Method [ <internal:couchbase> public method decoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\GetAnyReplicaOptions ]
+ }
}
}
@@ -9676,13 +9731,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [4] {
Property [ <default> private $timeout ]
Property [ <default> private $expiry ]
Property [ <default> private $durability_level ]
+ Property [ <default> private $encoder ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -9706,6 +9762,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\InsertOptions ]
}
+
+ Method [ <internal:couchbase> public method encoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\InsertOptions ]
+ }
}
}
@@ -9720,14 +9784,15 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> private $cas ]
Property [ <default> private $timeout ]
Property [ <default> private $expiry ]
Property [ <default> private $durability_level ]
+ Property [ <default> private $encoder ]
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:couchbase> public method cas ] {
- Parameters [1] {
@@ -9759,6 +9824,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\UpsertOptions ]
}
+
+ Method [ <internal:couchbase> public method encoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\UpsertOptions ]
+ }
}
}
@@ -9773,14 +9846,15 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> private $cas ]
Property [ <default> private $timeout ]
Property [ <default> private $expiry ]
Property [ <default> private $durability_level ]
+ Property [ <default> private $encoder ]
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:couchbase> public method cas ] {
- Parameters [1] {
@@ -9812,6 +9886,14 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\ReplaceOptions ]
}
+
+ Method [ <internal:couchbase> public method encoder ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $arg ]
+ }
+ - Return [ Couchbase\ReplaceOptions ]
+ }
}
}
@@ -10447,7 +10529,7 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [16] {
+ - Properties [18] {
Property [ <default> private $timeout ]
Property [ <default> private $adhoc ]
Property [ <default> private $metrics ]
@@ -10464,9 +10546,11 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
Property [ <default> private $max_parallelism ]
Property [ <default> private $profile ]
Property [ <default> private $client_context_id ]
+ Property [ <default> private $scope_name ]
+ Property [ <default> private $scope_qualifier ]
}
- - Methods [16] {
+ - Methods [18] {
Method [ <internal:couchbase> public method timeout ] {
- Parameters [1] {
@@ -10595,6 +10679,22 @@ Extension [ <persistent> extension #117 couchbase version 3.0.5 ] {
}
- Return [ Couchbase\QueryOptions ]
}
+
+ Method [ <internal:couchbase> public method scopeName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $value ]
+ }
+ - Return [ Couchbase\QueryOptions ]
+ }
+
+ Method [ <internal:couchbase> public method scopeQualifier ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $value ]
+ }
+ - Return [ Couchbase\QueryOptions ]
+ }
}
}
diff --git a/php-pecl-couchbase3.spec b/php-pecl-couchbase3.spec
index 089d64d..ae20989 100644
--- a/php-pecl-couchbase3.spec
+++ b/php-pecl-couchbase3.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-couchbase3
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -25,7 +25,7 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase3
-Version: 3.0.5
+Version: 3.1.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/couchbase
@@ -128,7 +128,7 @@ extension=%{pecl_name}.so
;couchbase.encoder.compression = 'off'
;couchbase.encoder.compression_threshold = 0
;couchbase.encoder.compression_factor = 0.0
-;couchbase.decoder.json_arrays = 0
+;couchbase.decoder.json_arrays = 1
;couchbase.pool.max_idle_time_sec = 60
;couchbase.allow_fallback_to_bucket_connection = 0
EOF
@@ -239,6 +239,9 @@ fi
%changelog
+* Thu Jan 21 2021 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+
* Mon Dec 7 2020 Remi Collet <remi@remirepo.net> - 3.0.5-1
- update to 3.0.5
- drop patches merged upstream