summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-14 14:52:53 +0200
committerRemi Collet <remi@php.net>2021-10-14 14:52:53 +0200
commit0ff34ca8e0dda4fea7756c48cf4e2572803c5daa (patch)
treee4cd5aa1f7047bedbf081aa60a2a949f15a96a5f
parente092c3bacbf743339d8b37ea000e58a3affe76fe (diff)
update to 3.2.1
raise dependency on libcouchbase 3.2.2
-rw-r--r--32.patch10
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-couchbase3.spec19
4 files changed, 18 insertions, 19 deletions
diff --git a/32.patch b/32.patch
index 7bd8db9..76e39f0 100644
--- a/32.patch
+++ b/32.patch
@@ -29,7 +29,7 @@ diff --git a/src/couchbase/pool.c b/src/couchbase/pool.c
index 9dfac11..3f5d8bd 100644
--- a/src/couchbase/pool.c
+++ b/src/couchbase/pool.c
-@@ -265,11 +265,19 @@ static lcb_STATUS pcbc_normalize_connstr(lcb_INSTANCE_TYPE type, char *connstr,
+@@ -266,11 +266,19 @@ static lcb_STATUS pcbc_normalize_connstr(lcb_INSTANCE_TYPE type, char *connstr,
// rebuild connection string with username as the bucket
smart_str buf = {0};
if (url->scheme) {
@@ -49,7 +49,7 @@ index 9dfac11..3f5d8bd 100644
}
if (url->port) {
smart_str_appendc(&buf, ':');
-@@ -279,7 +287,11 @@ static lcb_STATUS pcbc_normalize_connstr(lcb_INSTANCE_TYPE type, char *connstr,
+@@ -280,7 +288,11 @@ static lcb_STATUS pcbc_normalize_connstr(lcb_INSTANCE_TYPE type, char *connstr,
smart_str_appends(&buf, bucketname);
if (url->query) {
smart_str_appendc(&buf, '?');
@@ -61,7 +61,7 @@ index 9dfac11..3f5d8bd 100644
}
smart_str_0(&buf);
PCBC_SMARTSTR_DUP(buf, *normalized);
-@@ -290,15 +302,27 @@ static lcb_STATUS pcbc_normalize_connstr(lcb_INSTANCE_TYPE type, char *connstr,
+@@ -291,15 +303,27 @@ static lcb_STATUS pcbc_normalize_connstr(lcb_INSTANCE_TYPE type, char *connstr,
}
break;
case LCB_TYPE_CLUSTER:
@@ -89,7 +89,7 @@ index 9dfac11..3f5d8bd 100644
}
if (url->port) {
smart_str_appendc(&buf, ':');
-@@ -306,7 +330,11 @@ static lcb_STATUS pcbc_normalize_connstr(lcb_INSTANCE_TYPE type, char *connstr,
+@@ -307,7 +331,11 @@ static lcb_STATUS pcbc_normalize_connstr(lcb_INSTANCE_TYPE type, char *connstr,
}
if (url->query) {
smart_str_appendc(&buf, '?');
@@ -101,7 +101,7 @@ index 9dfac11..3f5d8bd 100644
}
smart_str_0(&buf);
PCBC_SMARTSTR_DUP(buf, *normalized);
-@@ -360,7 +388,11 @@ static lcb_STATUS pcbc_connection_cache(smart_str *plist_key, pcbc_connection_t
+@@ -361,7 +389,11 @@ static lcb_STATUS pcbc_connection_cache(smart_str *plist_key, pcbc_connection_t
zend_resource res;
res.type = pcbc_res_couchbase;
res.ptr = conn;
diff --git a/PHPINFO b/PHPINFO
index 6193fda..382c2b8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase support => enabled
-extension version => 3.2.0
-libcouchbase runtime version => 3.2.0 (git: c712686af5825f2f05c89112e555cd09906aa727)
-libcouchbase headers version => 3.2.0 (git: c712686af5825f2f05c89112e555cd09906aa727)
+extension version => 3.2.1
+libcouchbase runtime version => 3.2.2 (git: fadbd4d1617df952457abfa9984d095015f1ca52)
+libcouchbase headers version => 3.2.2 (git: fadbd4d1617df952457abfa9984d095015f1ca52)
zlib compressor => enabled
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 0b6fd2a..21fb41a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 couchbase version 3.2.0 ] {
+Extension [ <persistent> extension #126 couchbase version 3.2.1 ] {
- Dependencies {
Dependency [ json (Required) ]
diff --git a/php-pecl-couchbase3.spec b/php-pecl-couchbase3.spec
index 7bcc397..928d1a7 100644
--- a/php-pecl-couchbase3.spec
+++ b/php-pecl-couchbase3.spec
@@ -11,7 +11,6 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-couchbase2
%endif
@@ -24,9 +23,9 @@
%global libbuildver %(pkg-config --silence-errors --modversion libcouchbase 2>/dev/null || echo 65536)
Summary: Couchbase Server PHP extension
-Name: %{?sub_prefix}php-pecl-couchbase3
-Version: 3.2.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Name: %{?scl_prefix}php-pecl-couchbase3
+Version: 3.2.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/couchbase
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
@@ -40,8 +39,8 @@ BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-tokenizer
-# ensure we use the latest version (upstream requires 3.2.0)
-BuildRequires: pkgconfig(libcouchbase) >= 3.2.0
+# ensure we use the latest version (upstream requires 3.2.2)
+BuildRequires: pkgconfig(libcouchbase) >= 3.2.2
BuildRequires: fastlz-devel
BuildRequires: zlib-devel
@@ -55,10 +54,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}2 = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}2%{?_isa} = %{version}-%{release}
-%endif
Obsoletes: %{?scl_prefix}php-pecl-couchbase < 3
Provides: %{?scl_prefix}php-pecl-couchbase = %{version}
Provides: %{?scl_prefix}php-pecl-couchbase%{?_isa} = %{version}
@@ -244,6 +239,10 @@ fi
%changelog
+* Thu Oct 14 2021 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- update to 3.2.1
+- raise dependency on libcouchbase 3.2.2
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 3.2.0-2
- rebuild for 8.1.0RC1