summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-05-14 07:00:32 +0200
committerRemi Collet <remi@remirepo.net>2021-05-14 07:00:32 +0200
commit03802968f1a647a72dc78ab73a1641f8b2a3d204 (patch)
tree6c367d79436320b8fb8feb5c191b63c20dc1c222
parent36c45d780ded7574689791be02a5d0d89c9434f3 (diff)
update to 3.1.2
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION689
-rw-r--r--php-pecl-couchbase3.spec9
3 files changed, 690 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index 4e9f4a6..558db8e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase support => enabled
-extension version => 3.1.1
-libcouchbase runtime version => 3.1.0 (git: ed8b57e731e04e2749393c8bed8f9eb88d5d663d)
-libcouchbase headers version => 3.1.0 (git: ed8b57e731e04e2749393c8bed8f9eb88d5d663d)
+extension version => 3.1.2
+libcouchbase runtime version => 3.1.3 (git: 7739e685e579fb981eda1fdf89f7d6fcd5b2ebc9)
+libcouchbase headers version => 3.1.3 (git: 7739e685e579fb981eda1fdf89f7d6fcd5b2ebc9)
zlib compressor => enabled
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 777652c..fe49541 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
+Extension [ <persistent> extension #118 couchbase version 3.1.2 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -31,7 +31,7 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
}
}
- - Constants [176] {
+ - Constants [177] {
Constant [ int COUCHBASE_PERSISTTO_MASTER ] { 1 }
Constant [ int COUCHBASE_PERSISTTO_ONE ] { 1 }
Constant [ int COUCHBASE_PERSISTTO_TWO ] { 2 }
@@ -106,6 +106,7 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
Constant [ int COUCHBASE_ERR_INDEX_FAILURE ] { 402 }
Constant [ int COUCHBASE_ERR_PREPARED_STATEMENT_FAILURE ] { 403 }
Constant [ int COUCHBASE_ERR_KEYSPACE_NOT_FOUND ] { 404 }
+ Constant [ int COUCHBASE_ERR_DML_FAILURE ] { 405 }
Constant [ int COUCHBASE_ERR_COMPILATION_FAILED ] { 501 }
Constant [ int COUCHBASE_ERR_JOB_QUEUE_FULL ] { 502 }
Constant [ int COUCHBASE_ERR_DATASET_NOT_FOUND ] { 503 }
@@ -349,7 +350,7 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
}
}
- - Classes [195] {
+ - Classes [203] {
Interface [ <internal:couchbase> interface Couchbase\MutationToken ] {
- Constants [0] {
@@ -865,7 +866,7 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
- Parameters [0] {
}
- - Return [ DateTimeImmutable or NULL ]
+ - Return [ DateTimeInterface or NULL ]
}
Method [ <internal:couchbase, inherits Couchbase\Result> abstract public method cas ] {
@@ -918,7 +919,7 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
- Parameters [0] {
}
- - Return [ DateTimeImmutable or NULL ]
+ - Return [ DateTimeInterface or NULL ]
}
Method [ <internal:couchbase, prototype Couchbase\GetResult> public method content ] {
@@ -1328,7 +1329,7 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
- Parameters [0] {
}
- - Return [ DateTimeImmutable or NULL ]
+ - Return [ DateTimeInterface or NULL ]
}
Method [ <internal:couchbase> abstract public method content ] {
@@ -1403,7 +1404,7 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
- Parameters [0] {
}
- - Return [ DateTimeImmutable or NULL ]
+ - Return [ DateTimeInterface or NULL ]
}
Method [ <internal:couchbase, prototype Couchbase\LookupInResult> public method content ] {
@@ -2449,6 +2450,426 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
}
}
+ Class [ <internal:couchbase> class Couchbase\ParsingFailureException extends Couchbase\HttpException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $ref ]
+ Property [ <default> protected $context ]
+ Property [ <default> protected $is_input ]
+ Property [ <default> protected $is_network ]
+ Property [ <default> protected $is_fatal ]
+ Property [ <default> protected $is_transient ]
+ Property [ <default> protected $is_data_operation ]
+ Property [ <default> protected $is_internal ]
+ Property [ <default> protected $is_plugin ]
+ Property [ <default> protected $is_server_under_load ]
+ Property [ <default> protected $is_server_generated ]
+ Property [ <default> protected $is_subdoc ]
+ Property [ <default> protected $is_durability ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object or NULL ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\IndexNotFoundException extends Couchbase\HttpException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $ref ]
+ Property [ <default> protected $context ]
+ Property [ <default> protected $is_input ]
+ Property [ <default> protected $is_network ]
+ Property [ <default> protected $is_fatal ]
+ Property [ <default> protected $is_transient ]
+ Property [ <default> protected $is_data_operation ]
+ Property [ <default> protected $is_internal ]
+ Property [ <default> protected $is_plugin ]
+ Property [ <default> protected $is_server_under_load ]
+ Property [ <default> protected $is_server_generated ]
+ Property [ <default> protected $is_subdoc ]
+ Property [ <default> protected $is_durability ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object or NULL ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\PlanningFailureException extends Couchbase\HttpException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $ref ]
+ Property [ <default> protected $context ]
+ Property [ <default> protected $is_input ]
+ Property [ <default> protected $is_network ]
+ Property [ <default> protected $is_fatal ]
+ Property [ <default> protected $is_transient ]
+ Property [ <default> protected $is_data_operation ]
+ Property [ <default> protected $is_internal ]
+ Property [ <default> protected $is_plugin ]
+ Property [ <default> protected $is_server_under_load ]
+ Property [ <default> protected $is_server_generated ]
+ Property [ <default> protected $is_subdoc ]
+ Property [ <default> protected $is_durability ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object or NULL ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\IndexFailureException extends Couchbase\HttpException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $ref ]
+ Property [ <default> protected $context ]
+ Property [ <default> protected $is_input ]
+ Property [ <default> protected $is_network ]
+ Property [ <default> protected $is_fatal ]
+ Property [ <default> protected $is_transient ]
+ Property [ <default> protected $is_data_operation ]
+ Property [ <default> protected $is_internal ]
+ Property [ <default> protected $is_plugin ]
+ Property [ <default> protected $is_server_under_load ]
+ Property [ <default> protected $is_server_generated ]
+ Property [ <default> protected $is_subdoc ]
+ Property [ <default> protected $is_durability ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object or NULL ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\KeyspaceNotFoundException extends Couchbase\HttpException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $ref ]
+ Property [ <default> protected $context ]
+ Property [ <default> protected $is_input ]
+ Property [ <default> protected $is_network ]
+ Property [ <default> protected $is_fatal ]
+ Property [ <default> protected $is_transient ]
+ Property [ <default> protected $is_data_operation ]
+ Property [ <default> protected $is_internal ]
+ Property [ <default> protected $is_plugin ]
+ Property [ <default> protected $is_server_under_load ]
+ Property [ <default> protected $is_server_generated ]
+ Property [ <default> protected $is_subdoc ]
+ Property [ <default> protected $is_durability ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object or NULL ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:couchbase> class Couchbase\QueryException extends Couchbase\HttpException implements Throwable ] {
- Constants [0] {
@@ -2701,6 +3122,174 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
}
}
+ Class [ <internal:couchbase> class Couchbase\PreparedStatementFailureException extends Couchbase\QueryException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $ref ]
+ Property [ <default> protected $context ]
+ Property [ <default> protected $is_input ]
+ Property [ <default> protected $is_network ]
+ Property [ <default> protected $is_fatal ]
+ Property [ <default> protected $is_transient ]
+ Property [ <default> protected $is_data_operation ]
+ Property [ <default> protected $is_internal ]
+ Property [ <default> protected $is_plugin ]
+ Property [ <default> protected $is_server_under_load ]
+ Property [ <default> protected $is_server_generated ]
+ Property [ <default> protected $is_subdoc ]
+ Property [ <default> protected $is_durability ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object or NULL ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\DmlFailureException extends Couchbase\QueryException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $ref ]
+ Property [ <default> protected $context ]
+ Property [ <default> protected $is_input ]
+ Property [ <default> protected $is_network ]
+ Property [ <default> protected $is_fatal ]
+ Property [ <default> protected $is_transient ]
+ Property [ <default> protected $is_data_operation ]
+ Property [ <default> protected $is_internal ]
+ Property [ <default> protected $is_plugin ]
+ Property [ <default> protected $is_server_under_load ]
+ Property [ <default> protected $is_server_generated ]
+ Property [ <default> protected $is_subdoc ]
+ Property [ <default> protected $is_durability ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object or NULL ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:couchbase> class Couchbase\SearchException extends Couchbase\HttpException implements Throwable ] {
- Constants [0] {
@@ -4213,7 +4802,91 @@ Extension [ <persistent> extension #119 couchbase version 3.1.1 ] {
}
}
- Class [ <internal:couchbase> class Couchbase\ServiceMissingException extends Couchbase\BaseException implements Throwable ] {
+ Class [ <internal:couchbase> class Couchbase\RequestCanceledException extends Couchbase\BaseException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [17] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $ref ]
+ Property [ <default> protected $context ]
+ Property [ <default> protected $is_input ]
+ Property [ <default> protected $is_network ]
+ Property [ <default> protected $is_fatal ]
+ Property [ <default> protected $is_transient ]
+ Property [ <default> protected $is_data_operation ]
+ Property [ <default> protected $is_internal ]
+ Property [ <default> protected $is_plugin ]
+ Property [ <default> protected $is_server_under_load ]
+ Property [ <default> protected $is_server_generated ]
+ Property [ <default> protected $is_subdoc ]
+ Property [ <default> protected $is_durability ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method ref ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\BaseException> public method context ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object or NULL ]
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\ServiceNotAvailableException extends Couchbase\BaseException implements Throwable ] {
- Constants [0] {
}
diff --git a/php-pecl-couchbase3.spec b/php-pecl-couchbase3.spec
index 10115cf..381a2fe 100644
--- a/php-pecl-couchbase3.spec
+++ b/php-pecl-couchbase3.spec
@@ -25,7 +25,7 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase3
-Version: 3.1.1
+Version: 3.1.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/couchbase
@@ -40,8 +40,8 @@ BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-tokenizer
-# ensure we use the latest version (upstream requires 3.0.0)
-BuildRequires: pkgconfig(libcouchbase) >= 3.1
+# ensure we use the latest version (upstream requires 3.1.3)
+BuildRequires: pkgconfig(libcouchbase) >= 3.1.3
BuildRequires: fastlz-devel
BuildRequires: zlib-devel
@@ -241,6 +241,9 @@ fi
%changelog
+* Fri May 14 2021 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+
* Fri Mar 5 2021 Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1
- raise dependency on libcouchbase 3.1