summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION28
-rw-r--r--php-pecl-couchbase2.spec7
2 files changed, 26 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index 3b1ea6d..5e88b90 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #166 couchbase version 2.3.3 ] {
+Extension [ <persistent> extension #169 couchbase version 2.3.4 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -26,7 +26,7 @@ Extension [ <persistent> extension #166 couchbase version 2.3.3 ] {
}
}
- - Constants [150] {
+ - Constants [151] {
Constant [ integer COUCHBASE_PERSISTTO_MASTER ] { 1 }
Constant [ integer COUCHBASE_PERSISTTO_ONE ] { 1 }
Constant [ integer COUCHBASE_PERSISTTO_TWO ] { 2 }
@@ -142,6 +142,7 @@ Extension [ <persistent> extension #166 couchbase version 2.3.3 ] {
Constant [ integer COUCHBASE_GENERIC_SUBDOCERR ] { 81 }
Constant [ integer COUCHBASE_GENERIC_CONSTRAINT_ERR ] { 82 }
Constant [ integer COUCHBASE_NAMESERVER_ERROR ] { 83 }
+ Constant [ integer COUCHBASE_NOT_AUTHORIZED ] { 84 }
Constant [ integer COUCHBASE_TMPFAIL ] { 11 }
Constant [ integer COUCHBASE_KEYALREADYEXISTS ] { 12 }
Constant [ integer COUCHBASE_KEYNOTFOUND ] { 13 }
@@ -478,7 +479,9 @@ Extension [ <persistent> extension #166 couchbase version 2.3.3 ] {
Class [ <internal:couchbase> final class Couchbase\ClusterManager ] {
- - Constants [0] {
+ - Constants [2] {
+ Constant [ integer RBAC_DOMAIN_LOCAL ] { 1 }
+ Constant [ integer RBAC_DOMAIN_EXTERNAL ] { 2 }
}
- Static properties [0] {
@@ -490,7 +493,7 @@ Extension [ <persistent> extension #166 couchbase version 2.3.3 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
@@ -520,22 +523,33 @@ Extension [ <persistent> extension #166 couchbase version 2.3.3 ] {
Method [ <internal:couchbase> final public method listUsers ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $domain ]
}
}
Method [ <internal:couchbase> final public method upsertUser ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $name ]
Parameter #1 [ <required> $settings ]
+ Parameter #2 [ <required> $domain ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method getUser ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $domain ]
}
}
Method [ <internal:couchbase> final public method removeUser ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $domain ]
}
}
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index 9f45512..8db55b8 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -27,8 +27,8 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.3.3
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.3.4
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: pecl.php.net/package/couchbase
@@ -254,6 +254,9 @@ fi
%changelog
+* Tue Aug 1 2017 Remi Collet <remi@remirepo.net> - 2.3.4-1
+- Update to 2.3.4
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.3.3-3
- rebuild for PHP 7.2.0beta1 new API