summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-couchbase2.spec7
2 files changed, 17 insertions, 4 deletions
diff --git a/REFLECTION b/REFLECTION
index ad89ccc..241af89 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #180 couchbase version 2.4.4 ] {
+Extension [ <persistent> extension #179 couchbase version 2.4.5 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -29,7 +29,7 @@ Extension [ <persistent> extension #180 couchbase version 2.4.4 ] {
}
}
- - Constants [151] {
+ - Constants [161] {
Constant [ integer COUCHBASE_PERSISTTO_MASTER ] { 1 }
Constant [ integer COUCHBASE_PERSISTTO_ONE ] { 1 }
Constant [ integer COUCHBASE_PERSISTTO_TWO ] { 2 }
@@ -146,6 +146,16 @@ Extension [ <persistent> extension #180 couchbase version 2.4.4 ] {
Constant [ integer COUCHBASE_GENERIC_CONSTRAINT_ERR ] { 82 }
Constant [ integer COUCHBASE_NAMESERVER_ERROR ] { 83 }
Constant [ integer COUCHBASE_NOT_AUTHORIZED ] { 84 }
+ Constant [ integer COUCHBASE_SUBDOC_INVALID_COMBO ] { 85 }
+ Constant [ integer COUCHBASE_SUBDOC_MULTI_PATH_FAILURE ] { 86 }
+ Constant [ integer COUCHBASE_SUBDOC_SUCCESS_DELETED ] { 87 }
+ Constant [ integer COUCHBASE_SUBDOC_XATTR_INVALID_FLAG_COMBO ] { 88 }
+ Constant [ integer COUCHBASE_SUBDOC_XATTR_INVALID_KEY_COMBO ] { 89 }
+ Constant [ integer COUCHBASE_SUBDOC_XATTR_UNKNOWN_MACRO ] { 90 }
+ Constant [ integer COUCHBASE_SUBDOC_XATTR_UNKNOWN_VATTR ] { 91 }
+ Constant [ integer COUCHBASE_SUBDOC_XATTR_CANT_MODIFY_VATTR ] { 92 }
+ Constant [ integer COUCHBASE_SUBDOC_MULTI_PATH_FAILURE_DELETED ] { 93 }
+ Constant [ integer COUCHBASE_SUBDOC_INVALID_XATTR_ORDER ] { 94 }
Constant [ integer COUCHBASE_TMPFAIL ] { 11 }
Constant [ integer COUCHBASE_KEYALREADYEXISTS ] { 12 }
Constant [ integer COUCHBASE_KEYNOTFOUND ] { 13 }
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index fb8fe26..28a51f3 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -25,7 +25,7 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.4.4
+Version: 2.4.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/couchbase
@@ -206,7 +206,7 @@ done
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
@@ -241,6 +241,9 @@ fi
%changelog
+* Sun Mar 11 2018 Remi Collet <remi@remirepo.net> - 2.4.5-1
+- update to 2.4.5
+
* Tue Feb 13 2018 Remi Collet <remi@remirepo.net> - 2.4.4-1
- Update to 2.4.4