summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION47
-rw-r--r--php-pecl-couchbase2.spec16
2 files changed, 55 insertions, 8 deletions
diff --git a/REFLECTION b/REFLECTION
index d4a4da8..5abd171 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #164 couchbase version 2.3.1 ] {
+Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -317,7 +317,7 @@ Extension [ <persistent> extension #164 couchbase version 2.3.1 ] {
}
}
- - Classes [42] {
+ - Classes [43] {
Class [ <internal:couchbase> class Couchbase\Exception extends Exception implements Throwable ] {
- Constants [0] {
@@ -1040,6 +1040,43 @@ Extension [ <persistent> extension #164 couchbase version 2.3.1 ] {
}
}
+ Class [ <internal:couchbase> final class Couchbase\PasswordAuthenticator implements Couchbase\Authenticator ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:couchbase, ctor> final public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> final public method username ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $username ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method password ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $password ]
+ }
+ }
+ }
+ }
+
Class [ <internal:couchbase> final class Couchbase\MutationToken ] {
- Constants [0] {
@@ -1574,15 +1611,17 @@ Extension [ <persistent> extension #164 couchbase version 2.3.1 ] {
Method [ <internal:couchbase> final public method get ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $path ]
+ Parameter #1 [ <optional> $options ]
}
}
Method [ <internal:couchbase> final public method exists ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $path ]
+ Parameter #1 [ <optional> $options ]
}
}
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index 7137fc0..c0b2c5d 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -23,9 +23,11 @@
%endif
#global prever beta4
+%global libbuildver %(pkg-config --silence-errors --modversion libcouchbase 2>/dev/null || echo 65536)
+
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.3.1
+Version: 2.3.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -36,16 +38,15 @@ BuildRequires: %{?scl_prefix}php-devel >= 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-pecl-igbinary-devel
BuildRequires: %{?scl_prefix}php-json
-BuildRequires: libcouchbase-devel >= 2.7.3
+BuildRequires: pkgconfig(libcouchbase) >= 2.7.4
BuildRequires: fastlz-devel
BuildRequires: zlib-devel
-# to ensure compatibility with XDebug
-BuildRequires: %{?scl_prefix}php-pecl-xdebug
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-igbinary%{?_isa}
+Requires: libcouchbase%{?_isa} >= %{libbuildver}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
@@ -85,6 +86,10 @@ Obsoletes: php70w-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php71u-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php71w-pecl-%{pecl_name}2 <= %{version}
%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name}2 <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name}2 <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -249,6 +254,9 @@ fi
%changelog
+* Tue May 2 2017 Remi Collet <remi@remirepo.net> - 2.3.2-1
+- Update to 2.3.2
+
* Wed Apr 5 2017 Remi Collet <remi@remirepo.net> - 2.3.1-1
- Update to 2.3.1